Opened 13 years ago

Closed 13 years ago

#3129 closed defect (fixed)

SPYFOX1: Background buffer not been cleared

Reported by: (none) Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Spy Fox 1

Description

ScummVM 0.10.0svn (Mar 19 2007 08:10:12)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

The font is crippled/looks wrong in the outtro of this game.
I can't compare to the original cause i never played it before ScummVM.

Correct me if this is normal behaviour

English Windows CD

AmigaOS4
gcc version 4.0.2 (AmigaOS build 20051012)ţ

Ticket imported from: #1684010. Ticket imported from: bugs/3129.

Attachments (2)

spyfox.s07 (12.0 KB ) - added by SF/*anonymous 13 years ago.
Save game right into the outtro
SpyFox_Outtro.jpg (30.6 KB ) - added by SF/*anonymous 13 years ago.
Crippled font?

Download all attachments as: .zip

Change History (11)

by SF/*anonymous, 13 years ago

Attachment: spyfox.s07 added

Save game right into the outtro

by SF/*anonymous, 13 years ago

Attachment: SpyFox_Outtro.jpg added

Crippled font?

comment:1 by (none), 13 years ago

File Added: SpyFox_Outtro.jpg

comment:2 by Kirben, 13 years ago

The problem doesn't occur in the HE100 version of Spy Fox that I have.

Please start ScummVM via the command line, with a debug level of 1 and report the md5 details listed. ie scummvm -d1 spyfox

comment:3 by sev-, 13 years ago

HE90 version here doesn't have this bug either.

comment:4 by (none), 13 years ago

Trying to start game 'SPY Fox 1: Dry Cereal'
Using gameid spyfox, variant HE 99, extra Updated
Using MD5 '58436e634f4fae1d9973591c2ffa1fcb'

Just a little question before i file another bugreport on
this variant. Do the HE100 and HE90 versions have gfx problems
in the "wrist watch submarine fun game" at all?
Because if not, i may have another HE99 only problem
(The blue "water" background is being erased by NPC sprites!)

Thank you

comment:5 by sev-, 13 years ago

Tested with HE90 and HE100. No glitches. Please, submit a separate bugreport and attach a screenshot.

comment:6 by Kirben, 13 years ago

Actually the two issues sound related, so a single bug report is fine for now. I suspect this could be caused by different flags when drawing boxes.

Add the following line at the start of the ScummEngine::drawBox() function in engines/scumm/gfx.cpp in source code:
printf("drawBox: flags 0x0%x\n", color);

Recompile ScummVM and please report the output, when these two issues occur.

comment:7 by (none), 13 years ago

On starting the "fun game" i get
drawBox: flags 0x01000013
drawBox: flags 0x01000012
drawBox: flags 0x01000011
which keeps repeating.

When the outtro starts i get
drawBox: flags 0x010000f0
which also keeps repeating.

Hope that helps

comment:8 by Kirben, 13 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed
Summary: SPYFOX1: Crippled font in outtroSPYFOX1: Background buffer not been cleared

comment:9 by Kirben, 13 years ago

Fixed in ScummVM SVN, by checking for both flags types in all HE71+ games.

The flags for clearing buffers through the drawBox opcode changed in later HE games, and previously was limited to only HE100 games.

Note: See TracTickets for help on using tickets.