Opened 13 years ago

Closed 13 years ago

#3130 closed defect (fixed)

PSP: Gob2 stutters at every sound

Reported by: hkzlab Owned by: joostp
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Gobliins 2

Description

The game works, but every time a sound is played the game stops for a fraction of second, the music plays fine though. This problem isn't present in the linux build (same svn revision 26252). I don't know if this bug always existed, as when i recovered my gob2 version ( PC floppy version ) it was already there.

Ticket imported from: #1684515. Ticket imported from: bugs/3130.

Change History (10)

comment:1 by hkzlab, 13 years ago

I've just tested my pc version of Gobliiins: same problem, the game pauses a moment when the sound is played. Maybe a bug of the gob engine?

comment:2 by fingolfin, 13 years ago

Owner: set to joostp

comment:3 by bluegr, 13 years ago

I had the same issue, but it seems it's related to the way the your cd-audio tracks have been ripped. Which program have you used? Try using CDex or EAC (Exact Audio Copy) and it should work correctly.

comment:4 by joostp, 13 years ago

gob3 exhibits the same behavior, so it seems like gob-engine issue.
Investigating...

comment:5 by hkzlab, 13 years ago

Resolution: fixed

comment:6 by hkzlab, 13 years ago

As of svn 26477 this problem seems to be fixed.

comment:7 by hkzlab, 13 years ago

Well, it seems that for gob2 the problem is fixed indeed, with gob3 (floppy version) there's still some stuttering, but much less apparent...so it's not COMPLETELY fixed

comment:8 by hkzlab, 13 years ago

Resolution: fixed

comment:9 by joostp, 13 years ago

Gob3 now sounds fine to me with current SVN, although I only briefly tried it (yawning at the beginning and the sound the goblin makes when you click underneath the ship).
If you still experience the problem with current SVN, please let us know where it occurs.

comment:10 by joostp, 13 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.