Opened 17 years ago

Closed 17 years ago

#312 closed defect (invalid)

DOTT crashes when adding soap

Reported by: SF/jbergstrom Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

ScummVM Win32 0.2.0 Release (051302)
English Talkie

When playing with Hoagie, if you use soap on the water
in the bucket, ScummVM crashes.

Ticket imported from: #572810. Ticket imported from: bugs/312.

Attachments (1)

tentacle.s21 (53.8 KB ) - added by SF/jbergstrom 17 years ago.
Crash in Edna's room

Download all attachments as: .zip

Change History (19)

comment:1 by SF/ender, 17 years ago

Owner: set to SF/ender

comment:2 by SF/ender, 17 years ago

Can you attach a saved game before doing this? I cannot
reproduce this myself.

Thanks.

by SF/jbergstrom, 17 years ago

Attachment: tentacle.s21 added

Crash in Edna's room

comment:3 by SF/jbergstrom, 17 years ago

Actually - it seems this lockup is quite random. After I
rebooted my computer it doesn't happen with Hoagie and the
water anymore, but with Bernard and using the videotape
with Edna's equipment.
I'll attach a savegame, but I'm not sure if you can reproduce
the crash with it.

comment:4 by (none), 17 years ago

Logged In: NO

This happened to me when I had Laverne use the name tag
on Ted the mummy, while he was lying against the chair (not
upright or downstairs).

comment:5 by (none), 17 years ago

Logged In: NO

I played and curiously happened the same to me, when
adding a soap to water the program crash and say:
Fatal Signal : Segmentation Fault (SDL Parachute
Deployed)
I have winme, 1.7ghz Sound Blaster Platinum, 256 mbram,
I haven't restarted my computer yet, but without restarting
it at the moment I can recreate the crash.

comment:6 by SF/xybox, 17 years ago

I was the one who wrote the previous message, Sadly I
restarted my computer, it happened the same the first
time I ran, I waited for a while made crash in purpose the
program scummvm using a midi, then ran DOTT, I could
pass that part, when I plugged the extension cord to the
plug with laverne, the game crashed again.
This time what it says WARNING: parse_midi: invalid
control 0
Fatal Signal : Segmentation Fault (SDL Parachute
Deployed)
if you need my saved game just email me at
xybox@softhome.net

comment:7 by fingolfin, 17 years ago

Can't reproduce this with current CVS on Mac OS X either.

I also can't reproduce the VCR crash, nor the
Laverne-extension-cord-crash. Since there are several people
that can reproduce it, I wonder if this is maybe a bug in
the Windows backend? Midi driver? Would be interesting to
know if it works on Linux.

comment:8 by fingolfin, 17 years ago

After a discussion in #scummvm, none of the developers there
could reproduce this bug, not even on windows, and neither
with 0.2.0 nor the latest development version. Please help
us by answering these questions:

1) What is the *exact* version of Windows you use? What
DirectX version, what graphic card, anything else special
that might help?

2) What is the exact version of the game you are using? Is
it english/german/... ? Talkie or non-talkie? Floppy disk
version, CD version? Etc.

3) Try it with a current snapshot of the game
(http://scummvm.sourceforge.net/downloads/scummvmwin32.exe)
and report to us whether the problem occurs with that, too.

4) Run with the -d9 option. Then reproduce the crash, and
give us the last couple of pages of output ScummVM generated
(it will generate a *lot* of output, so you might want to
redirect it into a log file).

comment:9 by SF/xybox, 17 years ago

Thank you very much for your dedication. SCUMMVM
RULEZ!!! hehe.

My Windows Me version is 4.90.3000
DirectX version: 8.1 (4.08.01.0881)
my graphic card is Nvidia tnt2 mach64
Soundcard: Sound Blaster Audigy Ex
the DOTT version I have is the floppy version and its in
English, the games talk, I am able to reproduce the crash in
another computer, the computer has all the same things
mine has except the cpu,ram,modem,. It has a similar
audio card. I first believed it was a problem of the sound
but when I used the -enull happens the same, I use the
game with -g2x, everytime it crash says SDL parachute
deployed, the game has crash other times in different
situations, like the initial one (the soap) but when time pass
an I restart my computer the game is able to continue but
finally crash when I try to use the videocassete with the
vcr, an with Laverne-extension-cord-. I believe this 2
crashes are apparently connected with the same problem.
The crash has happened in fullscreen mode and in windows
mode.
I typed scummvm -d9 tentacle and when it crashed I
couldn't find any file containaing the debug, I uploaded the
final screenshot of Dos on my website so you can take a
look at it www.angelfire.com/linux/xybox/crash.jpg .

I tried to with the extension cord and the screen shot is in
www.angelfire.com/linux/xybox/extensioncord.jpg

Im going to install scummvm on a 3rd machine to see if it
happens the same.

I hope I can help you more.

Sincerely Xybox

comment:10 by SF/ender, 17 years ago

I cannot reproduce this bug under Windows 2000. This is
quite odd, as both the crashes are in a nukeResource
inventory call. nukeResource runs so many checks, I find it
very hard to comprehend how this could be causing a crash.

Unfortunatly, as we cannot reproduce the crash, it is quite
hard to help.

comment:11 by SF/xybox, 17 years ago

I installed the scummvm and the game on a new computer
with the same version of windows me, the computer has a
different videocard\cpu\soundcard etc..
The only thing that has in common is directX 8.1
I played the game and the game crashed again in the same
part, I dont have experience programing but I believe that
there's a conflict with windows me and SLD if scummvm
doesn't crash on other OS with scummvm.

comment:12 by SF/jbergstrom, 17 years ago

It's definitely not just ME, I got this crash on 98.

comment:13 by SF/jbergstrom, 17 years ago

It's definitely not just ME, I got this crash on 98.

comment:14 by fingolfin, 17 years ago

jbergstrom, xybox: what version of ScummVM do you use? 0.2.0
or one of the daily snapshots, or even current CVS compiled
by youself? If you are using 0.2.0, please try a current
snapshot to see if the bug occurs there as well.

jbergstrom, ender: what DirectX versions do you have? Also 8.1 ?

Obviously, if we can find a common factor that distinguishes
the systems on which it crashes from the others, then we are
that much closer to finding a cure.

comment:15 by SF/jbergstrom, 17 years ago

I used one of the daily snapshots, the About Box tells Build
0.2.0 Release(021302). (I downloaded this from the Daily
Snapshot link *much* later, though.)
The current one, Build 0.2.2 CVS(010802), seems to have
gotten rid of the bug. (It seems the dates are a bit off...)

First time I got this bug was using some earlier version of
DirectX, probably 8.0 or 7.0 or something, not 8.1 however. I
have installed 8.1 very recently, and the bug still occurred
using the older version of ScimmVM.

comment:16 by SF/xybox, 17 years ago

I had 0.2.0 (2002-04-14), I downloaded 0.2.2 [CVS] 2002-
07-08 and it worked like a charm, I plugged the extension
cord succesfully in the chron-o-john and used the video
taped with the vcr, well done guys!! as i said earlier,
scummvm rulez!! :D

comment:17 by SF/ender, 17 years ago

Resolution: invalid
Status: newclosed

comment:18 by SF/ender, 17 years ago

Closing as this has somehow mysteriously fixed itself :P

Note: See TracTickets for help on using tickets.