Opened 17 years ago

Closed 17 years ago

#313 closed defect (fixed)

FOA: Crash at Cretan ruin

Reported by: SF/neldredge Owned by: SF/ender
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

I am in the Cretan ruin at the top of the cliff, and I
have put the Sunstone and Moonstone into place and
opened the secret door. When talking to the guard
Klaus I make the following series of responses:

"I have a message for Kerner"
"I will guide him to Atlantis"
"An American working for YOU?"
"I better think this over"

During Indy's little soliloquy following this, ScummVM
crashes (as he says "Hmm. I better get in there").
The following messages precede the crash:

WARNING: roomops:14 load-string(31,"iq-points") not
implemented!
WARNING: roomops:13 save-string(31,"iq-points") not
implemented!
Fatal signal: Segmentation Fault (SDL Parachute Deployed)

I originally did this with 0.2.0 release but I can also
reproduce it with the 20020623 snapshot (using the
savegame from 0.2.0). These are on FreeBSD 4.6-RELEASE
using SDL. (I had to change sdl-config to sdl11-config
in the Makefile to make it compile.) My compiler is
gcc 2.95.3.

The game is the English talking version of Fate of
Atlantis.

The attached savegame is after the conversation with
Klaus ends. Indy will say a few lines and then ScummVM
crashes. I can reproduce this every time.

Please let me know if you need further help tracking
this down. It doesn't seem to be critical, since there
are other ways to get past the guard (on my path at
least, I can insult him, fight with him and win), but
it should be fixed.

Ticket imported from: #572977. Ticket imported from: bugs/313.

Attachments (1)

atlantis.s00 (55.9 KB ) - added by SF/neldredge 17 years ago.
Saved game which is about to crash

Download all attachments as: .zip

Change History (8)

by SF/neldredge, 17 years ago

Attachment: atlantis.s00 added

Saved game which is about to crash

comment:1 by SF/neldredge, 17 years ago

My email address is <neldredge@hmc.edu> should you need more
info.

comment:2 by SF/ender, 17 years ago

Owner: set to SF/ender

comment:3 by SF/ender, 17 years ago

I've commited a temporary fix. The original problem appears
to be an invalid actor number from script-200 passed to
opcode FB..

(Note, running scummvm with the '-d' parameter will usually
tell you about these kinds of problems..)

comment:4 by SF/neldredge, 17 years ago

Ok, with today's CVS, the crash is fixed. Thanks! An odd
side effect though, when I load my saved game and continue
past where it crashed, Indy walks about twice as fast as
usual afterwards. If I leave the room and return, it's back
to normal.

comment:5 by fingolfin, 17 years ago

Endy, can this be closed then? Or do you want to keep it for
reference (although the FIXME in the source references the
bug #, so it's not strictly necessary to keep it open, esp.
as it seems to be a bug in the script not in ScummVM).

comment:6 by SF/ender, 17 years ago

Resolution: fixed
Status: newclosed

comment:7 by SF/ender, 17 years ago

Yeah, I'm not happy with the workaround, but I'll close this
bug for now :)

Note: See TracTickets for help on using tickets.