Opened 12 years ago

Closed 12 years ago

#3117 closed defect (fixed)

SIMON1: Lockup with enhanced Music Tracks

Reported by: (none) Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

ScummVM 0.10.0svn (Mar 12 2007 08:30:39)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

With the new enhanced tracks installed (same dir where the other Simon
datafiles reside) and the Audio output (Edit Game menu) changed to 44kHz
i get a lockup of ScummVM's window/screen as soon as the music playback
ought to be started.

:-(
I wanna play the game with those incredible tracks
:-(

Log attached, hopefully useable (i can do a -d9 log, too, if needed)

Simon the Sorcerer (English/Windows/CD)

Amiga OS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1678846. Ticket imported from: bugs/3117.

Attachments (3)

simon1.zip (14.1 KB) - added by SF/*anonymous 12 years ago.
-d5 log
simon1-d3.log (10.8 KB) - added by SF/*anonymous 12 years ago.
-d3 log
simon1-d2.log (5.6 KB) - added by SF/*anonymous 12 years ago.
-d2 log

Download all attachments as: .zip

Change History (27)

Changed 12 years ago by SF/*anonymous

Attachment: simon1.zip added

-d5 log

comment:1 Changed 12 years ago by bluegr

Tried to run Simon1 under winxp sp2 with the latest SVN version of ScummVM and everything works here. Tried changing the audio sample rate to "default" and "44kHz" and it worked under both cases

comment:2 Changed 12 years ago by bluegr

...oh and of course I forgot to say that I've placed all the .ogg files of the ScummVM MIDI enhancement project in the game's directory

I've got Simon1's audio compressed into MP3 and both audio output works fine (speech and sfx is in mp3 and the music is in ogg)

comment:3 Changed 12 years ago by (none)

>I've placed all the .ogg files of the ScummVM MIDI enhancement project in the game's directory

Did that too, and as you can see in my log the first track
(track08.ogg) is opened, but then it seems to get stuck in
a strange loop, repeating some steps over and over again,
finally locking up.

comment:4 Changed 12 years ago by fingolfin

Summary: Simon1: Lockup with enhanced Music TracksSIMON1: Lockup with enhanced Music Tracks

comment:5 Changed 12 years ago by fingolfin

Why did you mention the 44kHz, i wonder -- do you mean to say that it works fine if you use a different sampling rate?

Does audio CD support work in other ScummVM games (if you have any, like the CD version of Monkey Island or of Loom) ?

And do I understand it correctly that you never hear any of the music?

comment:6 Changed 12 years ago by (none)

> Why did you mention the 44kHz, i wonder -- do you mean to
> say that it works fine if you use a different sampling rate?

I mentioned it because it's one of the steps one should take
when installing the enhanced tracks...taken from James page:

Instructions

These instructions assume you have already installed the game and are ready to install the soundtrack. For further assistance, please check out The Hitchhiker's Guide to setting up ScummVM.

o Download the soundtrack
Download the full soundtrack (do not use right click, only left!)
o Extract the soundtrack
Extract the soundtrack from the compressed *.zip file and place in the root folder of the game installation on the hard drive
o Starting the game
Start the ScummVM program and select Simon the Sorcerer. Now select [Edit Game?], switch to Audio tab and set Sample Rate to 44 kHz.

Now you can enjoy Simon the Sorcerer with my enhanced soundtrack!

> Does audio CD support work in other ScummVM games (if you
> have any, like the CD version of Monkey Island or of Loom)?

Despite what i wrote on IRC earlier, it works with every
other game that has .ogg encoded tracks here (MI1, Loom)

> And do I understand it correctly that you never hear any
> of the music?

You understand it right, i get a black screen/window and it
stays there, no music/sound effects, nothing is played, just
plain silence.

comment:7 Changed 12 years ago by fingolfin

Assigning to kirben, as he wrote that code (I know little to nothing about this "enhancement" project).

comment:8 Changed 12 years ago by fingolfin

Owner: set to Kirben

comment:9 Changed 12 years ago by Kirben

Unassigning as this seems like an Amiga specific issue, I can't reproduce the issue under Windows XP SP2 either.

The AGOS engine simply uses AudioCD manager to start music, stop music and check status of music. So I expect the problem is deeper in the sound code of ScummVM.

Each debug level in the AGOS engine provide a different type of debug output, level 5 simply dumps the complete video script of each animation, as it is used. You could try logs of debug level 2 (Script opcodes) and debug level 3 (Video opcodes), but I doubt they will provide more help.

Do you use vorbis compressed audio tracks for any other game(s) in ScummVM? and if yes, do they show any similar problems? that would be best way to check if issue is in the sound cde.

comment:10 Changed 12 years ago by Kirben

Owner: Kirben deleted

Changed 12 years ago by SF/*anonymous

Attachment: simon1-d3.log added

-d3 log

comment:11 Changed 12 years ago by (none)

> You could try logs of debug level 2 (Script opcodes) and
> debug level 3 (Video opcodes), but I doubt they will provide
> more help.

Did it anyway

> Do you use vorbis compressed audio tracks for any other game(s)
> in ScummVM? and if yes, do they show any similar problems? that
> would be best way to check if issue is in the sound cde.

Yes, i do, see my last post, i have Monkey Island 1, Loom and
ZakMcKracken running flawless with vorbis encodes sound files.

What else could i do to provide some information?
File Added: simon1-d3.log

Changed 12 years ago by SF/*anonymous

Attachment: simon1-d2.log added

-d2 log

comment:12 Changed 12 years ago by (none)

File Added: simon1-d2.log

comment:13 Changed 12 years ago by Kirben

Just to be sure, does Simon the Sorcerer 1 works fine, if you remove the enhanced music tracks?

The script opcodes seems to stop, after music is played and where video script should be starting. If you enable fast mode (Ctrl F) and waiting awhile, is the any visual difference? or any wait timeouts in console?

comment:14 Changed 12 years ago by (none)

> Just to be sure, does Simon the Sorcerer 1 works fine, if you remove the
> enhanced music tracks?

Yes, all back to normal

> The script opcodes seems to stop, after music is played and where video
> script should be starting. If you enable fast mode (Ctrl F) and waiting
> awhile, is the any visual difference? or any wait timeouts in console?

Nothing, just as before, everything black, nothing moving, silence

comment:15 Changed 12 years ago by bluegr

Looking at the code for the music enh project support, I see some special cases triggered when the platform is Amiga:

190 + } else if (getPlatform() == Common::kPlatformAmiga) {
191 + loadModule(music);

and

228 + if (getPlatform() == Common::kPlatformAmiga) {
229 + loadModule(music);

Perhaps you're trying to load music twice? loadModule stops the currently playing track too, could that be it?

Also, there's this bit:
185 + if (AudioCD.isPlaying())
186 + return;

Perhaps it's stuck there waiting for something?

Just my 2c from a quick glance at the code

comment:16 Changed 12 years ago by Kirben

Don't confuse the Amiga version of games, and running ScummVM on an Amiga system.

190 + } else if (getPlatform() ==
Common::kPlatformAmiga) {
191 + loadModule(music);

Simon the Sorcerer 1 specific code, which loads mods on the Amiga versions of the game.

228 + if (getPlatform() == Common::kPlatformAmiga) {
229 + loadModule(music);

Elivra 1/2 and Waxworks specific code, which loads mods on the Amiga versions of the games.

185 + if (AudioCD.isPlaying())
186 + return;

If the enhanced music tracks are been played, the function returns early. So it doesn't attempt to start playing mods (Amiga versions) or MIDI music (Other versions) too.

comment:17 Changed 12 years ago by bluegr

I got it wrong sorry :( Well, have to read the code more carefully next time :)

comment:18 Changed 12 years ago by (none)

Sorry if i bore everyone again, but

the approx. 171MB SIMON.WAV file is the one that holds the
original music tracks, doesn't it?

It's loaded *before* the soundeffects SFX files, the new
enhanced tracks are loaded *after* the sound effects, maybe
they get in their way somehow (audio task stuck -> scummvm stuck?

Also, do i still need the .WAV file installed, if i have the
enhanced tracks (given my assumption from above is correct)?

Last lines from the -d log:

File SIMON.fla not found
File SIMON.ogg not found
File SIMON.mp3 not found
Opening hashed: Games:ScummVM/Games/Simon/Simon/SIMON.WAV
File EFFECTS.fla not found
File EFFECTS.ogg not found
File EFFECTS.mp3 not found
File EFFECTS.voc not found
File EFFECTS not found
Opening hashed: Games:ScummVM/Games/Simon/Simon/GAMEPC
Opening hashed: Games:ScummVM/Games/Simon/Simon/TBLLIST
Opening hashed: Games:ScummVM/Games/Simon/Simon/STRIPPED.TXT
Opening hashed: Games:ScummVM/Games/Simon/Simon/simon.gme
Opening hashed: Games:ScummVM/Games/Simon/Simon/ICON.DAT
Opening hashed: Games:ScummVM/Games/Simon/Simon/SFXXXX05
File 0013.VGA not found
File 0023.VGA not found
File track8.flac not found
File track08.flac not found
File track8.fla not found
File track08.fla not found
File track8.ogg not found
Opening hashed: Games:ScummVM/Games/Simon/Simon/track08.ogg
Opening hashed: Games:ScummVM/Games/Simon/Simon/track08.ogg
Opening hashed: Games:ScummVM/Games/Simon/Simon/track08.ogg
File 1353.VGA not found

Is there anything else i could test with my limited knowledge
of C++ and coding without stealing your time?

Thank you

comment:19 Changed 12 years ago by (none)

Did some more tests and it runs (kind of).

If i remove track08.ogg from the Simon dir and play the game
it loads in the next enhanced track and plays it fine (e.g.
track16.ogg in the pub.

So, it seems it's just the first instance of playing the
tracks.

Oddest thing at all, if i enter the pub (without track08.ogg)
copy back track08.ogg to simon dir and leave the pub the new
track is played quite well. :-?

So it's another of that "Huh, that couldn't be" errors! :-/

Still get a lockup when starting with track08 in place :-(

comment:20 Changed 12 years ago by (none)

Another test:

If i open debugger (CTRL-F) right after the start of Simon1
and before the lockup i can play every enhanced track with
the "music x" command, the dirst one which refuses to run
when the game starts play nicely, too.

Exiting the debugger locks up at the same place, though.

any ideas?
please?

comment:21 Changed 12 years ago by fingolfin

Maybe yet another Amiga specific bug...

Or maybe a flag (e.g. a loop flag?) is not initialized properly. Maybe running Valgrind will turn up something useful (when used in a similar scenario, i.e. with Simon + Enhanced Ogg tracks).

comment:22 Changed 12 years ago by Kirben

No, Valgrind doesn't report anything at all.

comment:23 Changed 12 years ago by (none)

Major breakthrough -t's ALIVE again!!! :-)

One of the magicians changed something from
yesterday (~rev. 27070) upto today (rev. 27100)
and now everythings back to normal.
Running with the beautiful updated music tracks.

Thanks to all involved :-)

comment:24 Changed 12 years ago by Kirben

Owner: set to Kirben
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.