Opened 13 years ago

Closed 13 years ago

Last modified 12 months ago

#3006 closed defect (fixed)

WINCE: Crash maybe related to size of .ini file

Reported by: SF/thestampede01 Owned by: SF/knakos
Priority: high Component: Port: WinCE
Keywords: Cc:
Game:

Description

So, here is the situation. I installed PocketSCUMM 0.9.0 according to SirDave's manual. I installed a bunch of games: Beneath a Steel Sky, Day of the Tentacle, Loom, MI1, MI2, and Sam and Max. The only ones that worked were bass and mi2, and they worked wonderfully. The rest of the kept getting the same error which was

"ScummVM error. Unrecoverable exception occurred - see crash dump ...".
This was getting quite frustrating.

So, then I installed 0.9.1 and I don't get that error anymore. I get a different one and this time it does it for all the games. The error is:

"Assertion failed w <= MAX_MOUSE_W (..\..\..\backends\wince\wince-sdl.cpp,1670)"

-----------------------------------------------------

Update on my situation:

I deleted the .ini file. I then ran ScummVM. I chose a game and it worked. I quit then went back into the program and tried to run the game again. The error showed up. It showed whatever game I tried the second time.

I deleted the .ini file again. Ran a different game and it worked. Same situation.

So I do think it has something to do with the size of the .ini file. What to do about it? That I don't know.

On a side note: Some of the games I tried...like MI1, when I quit the game, it sort of froze up and didn't quit to the desktop.

------------------------------------------------------

Ticket imported from: #1635529. Ticket imported from: bugs/3006.

Attachments (1)

scummvm.ini (798 bytes ) - added by SF/thestampede01 13 years ago.
Crashed .ini file

Download all attachments as: .zip

Change History (18)

comment:1 by SF/knakos, 13 years ago

In that case it would be good if you attached one of those .ini files that cause a crash when loaded.

comment:2 by SF/knakos, 13 years ago

Owner: set to SF/knakos
Summary: Crash maybe related to size of .ini fileWINCE: Crash maybe related to size of .ini file

comment:3 by bluegr, 13 years ago

Dupe - already submitted in bug #1634805

comment:4 by SF/knakos, 13 years ago

Not exactly clear to me that this is a dupe, yet. I'd still like to see the .ini file. thestampede01, are you sure the crash isn't related to the key_mapping line?

comment:5 by SF/thestampede01, 13 years ago

!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
I posted this on the scumm forum....

Like Frank, I did some experimenting of my own and I discovered something. He believes that the problem lies within the size of the scummvm.ini file.

I believe that it has to do with mapping the keys. The games would run perfectly at first. Then, whenever I mapped the keys for the games, they wouldn't run and they would give that error once you clicked start.

"Assertion failed w <= MAX_MOUSE_W (..\..\..\backends\wince\wince-sdl.cpp,1670)"

What I did was edit the scummvm.ini file and deleted the key mapping, and then it worked. Maybe this will help someone in fixing the problem!!

by SF/thestampede01, 13 years ago

Attachment: scummvm.ini added

Crashed .ini file

comment:6 by SF/thestampede01, 13 years ago

File Added: scummvm.ini

comment:7 by fingolfin, 13 years ago

See bug #1634805.

comment:8 by SF/thestampede01, 13 years ago

fingolfin, the other bug, which is this bug, is not yet resolved...

comment:9 by fingolfin, 13 years ago

Priority: normalhigh

comment:10 by fingolfin, 13 years ago

I merely pointed to bug #1634805, which is a dupe of this one (and hence has been closed) for internal reference.

Anyway, see also bugs #1609058 and #1607180. This might (at least partially) be related to changes made to the mouse cursor handling code.

comment:11 by SF/knakos, 13 years ago

Status: newpending

comment:12 by SF/knakos, 13 years ago

I cannot reproduce this bug in the latest svn build (http://forums.scummvm.org/viewtopic.php?t=3518). My .ini size is 3729 bytes and does not exhibit this problem. Please try out the latest version. Switched status to pending.

comment:13 by SF/thestampede01, 13 years ago

I can't seem to reproduce it either. Good riddance.

comment:14 by SF/thestampede01, 13 years ago

Status: pendingnew

comment:15 by SF/knakos, 13 years ago

Resolution: fixed
Status: newclosed

comment:16 by SF/knakos, 13 years ago

closing. thanks.

comment:17 by digitall, 12 months ago

Component: --Unset--Port: WinCE
Note: See TracTickets for help on using tickets.