Opened 13 years ago

Closed 13 years ago

#2981 closed defect (fixed)

FF: segfault after flight from cygnus alpha

Reported by: SF/sebschub Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: The Feeble Files

Description

Here the message after increased debug level:

Left 388 Right 453 Top 172 Bottom 349
Left 390 Right 451 Top 173 Bottom 349
Left 390 Right 451 Top 173 Bottom 349
Left 390 Right 451 Top 173 Bottom 349
Left 390 Right 451 Top 173 Bottom 349
flags 0x080 framesCount 1170 width 640 height 480 rate 10 ticks 100
Playing video escape1.dxa
File escape1.flac not found
File escape1.fla not found
flags 0x080 framesCount 1450 width 640 height 480 rate 10 ticks 100
Playing video escape2.dxa
File escape2.flac not found
File escape2.fla not found
flags 0x00 framesCount 1250 width 640 height 480 rate 10 ticks 100
Playing video fxwakeup.dxa
File fxwakeup.flac not found
File fxwakeup.fla not found
Speicherzugriffsfehler

Speicherzugriffsfehler = segmentation fault

I used a recent svn version on a x86 Linux (Gentoo) machine. I own the 4 CD German version. It is ok, that it does not find the flacs as I use ogg vorbis.

It could be (AFAICS not likely) that the error is caused by the file outmin~1.dxa which I have to rename to the correct long name but I still do not know it (scummvm shows error window so I was able to rename three videos before).

Thx for your work and happy new year.

Ticket imported from: #1625087. Ticket imported from: bugs/2981.

Change History (5)

comment:1 by fingolfin, 13 years ago

Summary: segfault after flight from cygnus alphaFF: segfault after flight from cygnus alpha

comment:2 by eriktorbjorn, 13 years ago

Which version of ScummVM is this? I thought having to rename outmin~1.dxa in the German version was fixed before 0.9.0 was released. I don't have that version of the game myself, though, so I wouldn't know for sure.

Since you're using Linux, you might be able to pinpoint the source of the crash a bit more precisely by running ScummVM under GDB and type "bt" after it crashes. (If it only prints question marks instead of function names, ScummVM was compiled without debugging symbols. Such a backtrace is of no use, so you'd have to recompile ScummVM and not strip it.)

comment:3 by SF/sebschub, 13 years ago

I used a very fresh svn version (about 5 days old) and I had to rename the files. One error message: "ERROR: Failed to load video file NewCredits.dxa or NewCre~1". The extension in the last one is really missing. Maybe this or the fact that I changed every file to complete lowercase. (sry for beeing to lazy to write a bug report concerning this)

Now the crash. Here gdb's output:

sebschub@Satux ~/temp/trunk $ gdb ./scummvm
GNU gdb 6.6
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB. Type "show warranty" for details.
This GDB was configured as "i686-pc-linux-gnu"...
Using host libthread_db library "/lib/libthread_db.so.1".
(gdb) run
Starting program: /tmp/sebschub/trunk/scummvm
Failed to read a valid object file image from memory.
[Thread debugging using libthread_db enabled]
[New Thread -1212925328 (LWP 20408)]
Using configuration file: /home/sebschub/.scummvmrc
[New Thread -1213146208 (LWP 20411)]
[New Thread -1221669984 (LWP 20412)]
Looking for feeble
Trying to start game 'The Feeble Files'

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1212925328 (LWP 20408)]
0xb7bad3b9 in free () from /lib/libc.so.6
(gdb) bt
#0 0xb7bad3b9 in free () from /lib/libc.so.6
#1 0x0814b549 in AGOS::MoviePlayer::play (this=0x85bfbe0)
at engines/agos/animation.cpp:142
#2 0x08165ceb in AGOS::AGOSEngine::runScript (this=0x860a548)
at engines/agos/script.cpp:1032
#3 0x08173024 in AGOS::AGOSEngine::startSubroutine (this=0x860a548, sub=0xb6345008)
at engines/agos/subroutine.cpp:569
#4 0x0816578c in AGOS::AGOSEngine::o_process (this=0x860a548)
at engines/agos/script.cpp:539
#5 0x08165ceb in AGOS::AGOSEngine::runScript (this=0x860a548)
at engines/agos/script.cpp:1032
#6 0x08173024 in AGOS::AGOSEngine::startSubroutine (this=0x860a548, sub=0xb6444624)
at engines/agos/subroutine.cpp:569
#7 0x08169ecc in AGOS::AGOSEngine::oe2_doTable (this=0x860a548)
at engines/agos/script_e2.cpp:168
#8 0x08165ceb in AGOS::AGOSEngine::runScript (this=0x860a548)
at engines/agos/script.cpp:1032
#9 0x08173024 in AGOS::AGOSEngine::startSubroutine (this=0x860a548, sub=0xb642f730)
at engines/agos/subroutine.cpp:569
#10 0x0814ef04 in AGOS::AGOSEngine::invokeTimeEvent (this=0x860a548, te=0x856f0e0)
at engines/agos/event.cpp:111
#11 0x0814efea in AGOS::AGOSEngine::kickoffTimeEvents (this=0x860a548)
at engines/agos/event.cpp:139
#12 0x08153b48 in AGOS::AGOSEngine::hitarea_stuff_helper (this=0x860a548)
at engines/agos/input.cpp:394
#13 0x08153c3e in AGOS::AGOSEngine::waitForInput (this=0x860a548)
at engines/agos/input.cpp:206
#14 0x081478f8 in AGOS::AGOSEngine::go (this=0x860a548) at engines/agos/agos.cpp:867
#15 0x0805254d in runGame (plugin=<value optimized out>, system=@0x84f6008,
edebuglevels=@0xbf8d7a4c) at base/main.cpp:229
#16 0x08052c0c in scummvm_main (argc=1, argv=0xbf8d7df4) at base/main.cpp:327
#17 0x08050f9e in main (argc=1, argv=0xbf8d7df4) at backends/platform/sdl/sdl.cpp:115

comment:4 by Kirben, 13 years ago

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:5 by Kirben, 13 years ago

Both issues fixed in ScummVM SVN, use the next daily snapshot of ScummVM SVN.

Note: See TracTickets for help on using tickets.