Opened 13 years ago

Closed 13 years ago

#2980 closed defect (invalid)

DS: hang on load

Reported by: SF/tomten Owned by: agent-q
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

Here is one of those MI1/VGA savegames that hang after load on scumm-a.nds v0.9.1ab1. I saved the game twice, and both save games exhibit this behaviour, which is why it might not be a "corrupt save" problem. The game loads to the correct point etc, but nothing is clickable (not even SELECT/START) after load.

(Past 3 saves have all exhibited this behaviour - first 5 saves worked fine)

Ticket imported from: #1625015. Ticket imported from: bugs/2980.

Attachments (1)

MONKEY.S03 (99.9 KB ) - added by SF/tomten 13 years ago.
Savegame which hangs after load

Download all attachments as: .zip

Change History (8)

by SF/tomten, 13 years ago

Attachment: MONKEY.S03 added

Savegame which hangs after load

comment:1 by SF/tomten, 13 years ago

Summary: DS-Xtreme: hang on loadScummVM DS 0.9.1ab1: DS-Xtreme: hang on load

comment:2 by fingolfin, 13 years ago

Owner: set to agent-q
Summary: ScummVM DS 0.9.1ab1: DS-Xtreme: hang on loadDS: hang on load

comment:3 by agent-q, 13 years ago

Please describe how to reproduce this crash so I can test it on supported hardware.

comment:4 by SF/tomten, 13 years ago

I just played MI1/VGA @ DS-Xtreme @ v0.9.1ab1 for a while. First ~3 saves worked fine, consequent saves exhibited this behaviour. Maybe I was unclear in my bug report: I didn't experience a crash, I experienced hang symptoms after loading the savegame attached in the bug report.

comment:5 by agent-q, 13 years ago

"I didn't experience a crash, I experienced hang symptoms"

What does that mean? What's the difference between 'hang symptons' and a crash? When I load your saved game, it crashes. This is almost definitely because your save game is corrupt. The DS-X is not supported by ScummVM. You will need to purchase a device that supports homebrew in order to run ScummVM.

comment:6 by agent-q, 13 years ago

Resolution: invalid

comment:7 by agent-q, 13 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.