Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2967 closed defect (fixed)

GOB2: Sounds not played correctly, chopped etc.

Reported by: SF/cirion81 Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Gobliins 2

Description

A lot of sounds are missing (especially) in the intro, seem out of sync or are not played completely (German Disk Version). Since there are a lot of warnings displayed in the status window concerning the sound I assume these bugs are known. Yet what the heck, I thought I post them anyway.

Here is the printout from the console up to where the two buggers land.

Trying to start game 'Gobliins 2'
WARNING: GOB2 Stub! _word_2E8E2, _word_2FC9C, _word_2FC9E, _word_2E51F, _off_2E5
1B, _off_2E517!
WARNING: GOB2 Stub! _byte_2FC82, _byte_2FC83, _word_2FC80!
WARNING: GOB2 Stub! _byte_2FC9B, _dword_2F2B6!
WARNING: GOB2 Stub! _word_2F9C0, _word_2F9BE, _word_2F9BC, _word_2F9BA, _dword_2
F9B6, _dword_2F9B2!
WARNING: STUB: Video::initDriver!
WARNING: Your game version doesn't support the requested language, using the fir
st one available!
WARNING: GOB2 Stub! Inter_v2::o2_initMult(), wide frontSurface, using the extra
space as animSurf!
WARNING: SoundKeyCount: 216!
WARNING: GOB2 Stub! Mult_Data.somepointer09, Mult_Data.somepointer10!
WARNING: Attempted to play a sample with a frequency of -3 (sndDesc->freq = 6182)!
WARNING: Attempted to play a sample with a frequency of -3 (sndDesc->freq = 7700)!
WARNING: Attempted to play a sample with a frequency of -4 (sndDesc->freq = 7714)!
WARNING: Attempted to play a sample with a frequency of -8 (sndDesc->freq = 7700)!
WARNING: Attempted to play a sample with a frequency of -1 (sndDesc->freq = 7046)!
WARNING: Attempted to play a sample with a frequency of -6 (sndDesc->freq = 7800)!
WARNING: Attempted to play a sample with a frequency of -9 (sndDesc->freq = 7714)!
WARNING: Attempted to play a sample with a frequency of -9 (sndDesc->freq = 7500)!
WARNING: => Skipping copy protection screen!
WARNING: GOB2 Stub! ADL command 0x60!
WARNING: GOB2 Stub! Inter_v2::o2_initMult(), wide frontSurface, using the extra
space as animSurf!
WARNING: SoundKeyCount: 155!
WARNING: GOB2 Stub! Mult_Data.somepointer09, Mult_Data.somepointer10!

# ScummVM version (scummvm -v)
ScummVM 0.10.0svn (Dec 28 2006 10:08:09)
# Language of game (English, German, ...)
German
# Version of game (Talkie, Floppy, ...)
Floppy
# Platform and Compiler (Win32, Linux, ...)
Windows 2000

If needed I can supply a sound recording, along with a recording from DOSBOX which IMHO matches the sound I got when I played the game back in 1992.

Ticket imported from: #1623614. Ticket imported from: bugs/2967.

Change History (12)

comment:1 by fingolfin, 13 years ago

Summary: Sounds not played correctly, chopped etc.GOB2: Sounds not played correctly, chopped etc.

comment:2 by fingolfin, 13 years ago

Please describe your machine a bit more -- what CPU / speed, how much memory etc.. Any special sound card?

Are you playing the game from HD or from CD?

comment:3 by SF/cirion81, 13 years ago

CPU: Athlon Thunderbird 1,3Ghz
RAM: 512 MB
Soundcard: Terratec SixPack 5.1+

I play the game from the harddisk (I own the floppy version, no need to put 2.8MB on a CD ;-)).

I don't think there is anything special about my machine. The LucasArts games all do work fine with ScummVM. Simon the Sorcerer as well. I never encountered similar sound issues with ScummVM before.

I ran ScummVM without any unneccesary programs running in background, but this didn't change anything. I did not try running the game with a clean reboted machine, but since other games in ScummVM and DOSBOX do work fine ...

comment:4 by sev-, 13 years ago

Owner: set to DrMcCoy

comment:5 by sev-, 13 years ago

Yes, this is known issue (see http://wiki.scummvm.org/index.php/Gob/TODO), but I'll leave it open as a reminder.

comment:6 by SF/cirion81, 13 years ago

With ScummVM 0.10.0svn (Jan 9 2007 22:58:43) the chopped sounds are much better (especially in the intro). Still not yet perfect ...

Especially looped sounds are played with a pause inbetween the loop, noticably e.g. in the buzzing of the fly in the intro, when pressing the fountain button etc.

Also some sounds are seemingly still chopped of, e.g. when the king is crying about his dissapeared son, or also notable when the "beam in" sound is played for Fingus and Winkle at the beginning of the game.

Also to me some sounds seem to be played a little slower, compared to the sound in DosBox. E.g. the sound of the castle appearing on the wizards table seems to me to be a notch slower than it is played in DosBox. But this could also be an interpolation effect (doesn't Scummvm do an upsampling to 44kHz ?!?).

The next thing I noted is that now the creaking sound of the wizards turning neck is looped too often, but I believe there is an other bugreport on this.

I am posting this update because of

r25025 | drmccoy | 2007-01-06 09:17:20 -0200 (Sat, 06 Jan 2007) | 5 lines

- Fixed cut off and missing sounds
- Fixed a crash/static reported in the forums (sending Winkle to the vulture)
- (Hopefully) fixed the immediately-closing notepad heisenbug (#1621089)
- Fixed using unitialised values after allocating the variables

comment:7 by DrMcCoy, 13 years ago

I mucked about with the sound playing, the current SVN version (or the latest daily build) should do it more correctly...

comment:8 by SF/cirion81, 13 years ago

I checked out your changes with the Daily Snapshot dated January 30, 2007, 6:46 pm

You did a wonderful job, the sound is now almost the same as in DosBox (which I am sure you already noted ;-).
However I found two small glitches which are still present:

1. There are still some clicking noises when sounds are looped. For example auditable when the king cries for his lost son in the intro.

2. Some sounds are not quite in synch with the action on screen. For example when the fountain button is pressed, the water sound starts immediately (which is good), but plays slightly to long when the water stops running (not a big issue, but notable).

comment:9 by DrMcCoy, 13 years ago

Well, issue 1 is caused the sample being cut off in the middle when the crying sound is restarted. There's nothing I can do about that, I'm afraid.
And I can't reproduce issue 2 here. Maybe you could try again with the next daily build, I've changed a few things around again since...

comment:10 by SF/cirion81, 13 years ago

Hello,

I tried again with ScummVM 0.10.0svn (Feb 6 2007 23:25:23), and the sound of the fountain was in synch.

Concerning the clicking: well so much I supposed. But in the original interpreter I noticed less clicking. I don't think they interpolated the sound, because then no clicking should have happened, but maybe they used slightly different looping points. Anyway, the sporadic clicking sound is not disturbing.

If I might add this comment: in comparison to the sound I get from DOSBox the sound in ScummVM seems a little bit "muffled". I tried different output frequencies with ScummVM (44100, 22050 and 11025kHz) with no effect. But this could also be the fault of DOSBox - I don't have a system at hand to play the game on native hardware to determine which one is correct.

As I final statement I would like to thank you sincerely for your great work! In my oppinion the bugs I described are fixed.

comment:11 by DrMcCoy, 13 years ago

> But in the original interpreter I noticed less clicking.

That's because the original has more exact timing control through interrupts and can cut off the waveform at a "click-safe" time (the script's "sound off" commands are probably synched to that as well).

> in comparison to the sound I get from DOSBox the sound in ScummVM seems a little bit "muffled".

In contrast to the original, ScummVM does (simple linear) interpolation. This reduces the clicking a bit, too (not completely though).

> As I final statement I would like to thank you sincerely for your great work!

:)

comment:12 by DrMcCoy, 13 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.