Opened 13 years ago

Closed 13 years ago

#2957 closed defect (fixed)

COMI: Guybrush re-placed

Reported by: (none) Owned by: cyxx
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

ScummVM 0.10.0svn (Dec 21 2006 08:43:30)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

In the restaurant in Puerto Bello when Guybrush
enters it WITH the reservation slip, he gives it
to the pirate (after talking to him) and is
immediately re-placed to a position on the bottom
of screen cut off by approx. the middle (attached).

SaveGame attached later...

English CD (from the Bounty Pack)

AmigaOS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1620023. Ticket imported from: bugs/2957.

Attachments (4)

monkey3.jpg (87.3 KB ) - added by SF/*anonymous 13 years ago.
Guybrush re-placed
comi.s06 (84.3 KB ) - added by SF/*anonymous 13 years ago.
Walk right in (left)
comi.s10 (85.4 KB ) - added by SF/*anonymous 13 years ago.
Eat the biscuit
comi.s12 (87.2 KB ) - added by SF/*anonymous 13 years ago.
Look up the crow's nest

Download all attachments as: .zip

Change History (18)

by SF/*anonymous, 13 years ago

Attachment: monkey3.jpg added

Guybrush re-placed

by SF/*anonymous, 13 years ago

Attachment: comi.s06 added

Walk right in (left)

comment:1 by (none), 13 years ago

File Added: comi.s06

comment:2 by (none), 13 years ago

Summary: MONKEY3: Guybrush re-placedCOMI: Guybrush re-placed

comment:3 by (none), 13 years ago

Sorry, forgot to add, AFTER he showed it to the
pirate Guybrush is placed back to normal position...

comment:4 by cyxx, 13 years ago

Owner: set to cyxx
Resolution: fixed
Status: newpending

comment:5 by cyxx, 13 years ago

The problem is that putActor is called with y equals to -1 in the script roomobj-16-446 :

[037C] (A1) putActorAtXY(1,getObjectX(1),(getObjectY(1) + -241),VAR_ROOM)

Actor position being (320, 240)

The issue should be fixed with the latest SVN.

by SF/*anonymous, 13 years ago

Attachment: comi.s10 added

Eat the biscuit

comment:6 by (none), 13 years ago

Status: pendingnew

comment:7 by (none), 13 years ago

Thanks issue fixed...BUT, new issue comes right
along...sorry :-)

See savegame...eat the biscuit from the inventory,
Guybrush will vanish, you can do whatever you want,
all commands work, but Guybrush is gone from the
screen...

Heh, Monkey Island: The Ghost of Monkey Island :-)
File Added: comi.s10

comment:8 by cyxx, 13 years ago

I am unable to reproduce the issue.

When does Guybrush disappear ? When he starts eating the biscuit ? At the end of the animation ?

Can you also modify Actor::putActor() by adding a debug trace at the beginning of function, something like this :

printf("%d %d %d\n", dstX, dstY, newRoom);

and paste the output here ?

Thanks

comment:9 by (none), 13 years ago

He disappears right after eating the biscuit and
finishing his lines and putting away the buiscuit,
as soon as the pirate starts talking he's gone...

Here's the output:

Using configuration file: scummvm.ini
Looking for comi
Trying to start game 'The Curse of Monkey Island'
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
-1 -1 -1
160 100 1
320 200 87
0 0 0
318 150 16
0 0 0
320 240 16
-1 -1 -1

Thank you

by SF/*anonymous, 13 years ago

Attachment: comi.s12 added

Look up the crow's nest

comment:10 by (none), 13 years ago

I have another instance of this behaviour (well, to
be honest with your last patch, Guybrush disappears
very often :-))

Savegame attached: Just look up the crow's nest, when
the game returns to the ship's deck, he's gone again

Here's part of the output (the last part, hope it helps

0 0 0
0 0 0
0 0 0
0 0 0
0 0 0
432 340 35
320 240 35
-1 -1 -1

File Added: comi.s12

comment:11 by cyxx, 13 years ago

Again, I am not able to reproduce it and I wonder how you can get these "-1 -1 -1" as output.

When you updated your svn local tree, did you make a "full compilation rebuild" ? ie. make clean && make ?
If not, can you try this ?

comment:12 by (none), 13 years ago

/note to self
"ALWAYS build from the FULL source,
NO MATTER how long it will take!!!"

That did it, strange error gone

Sorry for wasting your time :-/

P.S: Thanks for Touch, great engine :-)

comment:13 by cyxx, 13 years ago

Status: newclosed

comment:14 by cyxx, 13 years ago

Good to hear it's finally working for you :)

Note: See TracTickets for help on using tickets.