Opened 13 years ago

Closed 13 years ago

#2956 closed defect

GOB2: No graphics for game

Reported by: SF/adamhearn Owned by: DrMcCoy
Priority: normal Component: Engine: Gob
Keywords: Cc:
Game: Gobliins 2

Description

Gobliins 2 V1.01 from original release CD

Started game and had no video output (just a black screen). Intro played with sound. Pressed ESC lots of times [to skip intro and continue] and got "WARNING: key buffer overflow!" in console window and game didn't start.

Using configuration file: C:\Documents and Settings\Adam\Application Data\ScummVM\scummvm.ini
ScummVM 0.10.0svn (Dec 20 2006 13:01:48)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Folling messages logged to the SCUMMVM console when game started:

Looking for gob2
Trying to start game 'Gobliins 2'
WARNING: GOB2 Stub! _word_2E8E2, _word_2FC9C, _word_2FC9E, _word_2E51F, _off_2E5
1B, _off_2E517!
WARNING: GOB2 Stub! _byte_2FC82, _byte_2FC83, _word_2FC80!
WARNING: GOB2 Stub! _byte_2FC9B, _dword_2F2B6!
WARNING: GOB2 Stub! _word_2F9C0, _word_2F9BE, _word_2F9BC, _word_2F9BA, _dword_2
F9B6, _dword_2F9B2!
WARNING: STUB: Video::initDriver!
WARNING: GOB2 Stub! Inter_v2::o2_initMult(), wide frontSurface, using the extra
space as animSurf!
WARNING: SoundKeyCount: 0!
WARNING: GOB2 Stub! Mult_Data.somepointer09, Mult_Data.somepointer10!

SCUMMVM config:

[scummvm]
gfx_mode=hq3x
music_volume=255
midi_gain=100
speech_volume=100
browser_lastpath=C:\Games\ScummVM\
aspect_ratio=true
music_driver=auto
lastselectedgame=gob2
native_mt32=false
gui_theme=modern
subtitles=true
fullscreen=false
sfx_volume=192
master_volume=255
talkspeed=60
speech_mute=false
enable_gs=false
multi_midi=false
versioninfo=0.10.0svn
savepath=C:\Games\ScummVM

[gob2]
description=Gobliins 2 (CD)
path=C:\Games\ScummVM\Gobliins 2\
aspect_ratio=false
gameid=gob2
fullscreen=false

Other info : Gobliins 2 worked under DOSBox 0.65

Ticket imported from: #1619330. Ticket imported from: bugs/2956.

Change History (12)

comment:1 by DrMcCoy, 13 years ago

Owner: set to DrMcCoy
Summary: No graphics for game (warnings logged in console)GOB2: No graphics for game

comment:2 by DrMcCoy, 13 years ago

Maybe a stupid question, but did you wait a bit? The intro sound fades in for ~ 15 seconds before the graphics should fade in as well.

comment:3 by SF/adamhearn, 13 years ago

Forgot to add platform details:

Platform: WinXP Pro (SP2, full Windows Update), Pentium-M 2Ghz, 2GB RAM, GF6600GT (71.89), Audigy 2ZS (WBUP2_LB_2_09_0016)

In answer to your question. Yes. The fade is approximately the same as Gobliiins (1) which works as expected. I listened to the entire intro and no graphics appeared.

comment:4 by sev-, 13 years ago

Weird, I couldn't reproduce it with both version 1.000 and 1.01. Please, show your gob2 directory contents along with file sizes. Also please, paste contents of file VERSION in your CD root directory.

comment:5 by SF/adamhearn, 13 years ago

Content of Version from CD:
1.01

Filelist from CD:

Volume in drive E is GOB2
Volume Serial Number is 29EB-0F59

Directory of E:\

27/09/1993 08:58 <DIR> DEMOS
20/09/1993 13:29 8,275 DOINSCD.INF
27/09/1993 03:14 4 GO.BAT
20/09/1993 10:44 106,239 GOB2.EXE
15/09/1993 09:48 4,338 GOB2.LIC
15/09/1993 09:48 4,338 GOBNEW.LIC
02/09/1993 02:01 15,885 INSTALL.ASK
26/08/1993 08:29 5,723 INSTALL.EXE
27/09/1993 03:17 632 INSTALL.INF
27/09/1993 04:32 4,541,724 INTRO.STK
09/06/1993 10:06 3,524 L360.GDR
26/06/1992 10:07 14,299 LEGA.GDR
09/06/1993 10:06 4,844 LVGA.GDR
27/09/1993 03:39 172 MDO.DEF
17/09/1993 09:24 70,623 SETUP.EXE
09/06/1993 10:06 2,658 SETUP.PUB
09/06/1993 10:06 4 VERSION
16 File(s) 4,783,282 bytes

Filelist from my SCUMMVM directory:

Directory of C:\Games\ScummVM\Gobliins 2

20/12/2006 11:44 <DIR> .
20/12/2006 11:44 <DIR> ..
15/09/1993 09:48 4,338 GOB2.LIC
15/09/1993 09:48 4,338 GOBNEW.LIC
27/09/1993 04:32 4,541,724 INTRO.STK
09/06/1993 10:06 3,524 L360.GDR
26/06/1992 10:07 14,299 LEGA.GDR
09/06/1993 10:06 4,844 LVGA.GDR
27/09/1993 03:39 172 MDO.DEF
09/06/1993 10:06 4 VERSION
8 File(s) 4,573,243 bytes
2 Dir(s) 122,480,324,608 bytes free

I've double checked everything:
Installed game from CD using DOSBox 0.65 again.
English language selected
Game ran under DOSBox using default directory of c:\cocktel\gobliins
Sound plays from CD as expected
Intro graphics appeared around the time DrMcoy suggests

Deleted game from SCUMMVM
Added game from the c:\cocktel\gobliins directory
Set game options (graphics, audio, midi) with override checked and config data to defaults
Ran game, same issue. Sound plays but no video appears.

Running SCUMMVM with debug output produces no further insight (to me) ->

Looking for gob2
Trying to start game 'Gobliins 2'
Opening hashed: C:\Games\ScummVM\Gobliins 2\INTRO.STK
WARNING: GOB2 Stub! _word_2E8E2, _word_2FC9C, _word_2FC9E, _word_2E51F, _off_2E5
1B, _off_2E517!
WARNING: GOB2 Stub! _byte_2FC82, _byte_2FC83, _word_2FC80!
WARNING: GOB2 Stub! _byte_2FC9B, _dword_2F2B6!
WARNING: GOB2 Stub! _word_2F9C0, _word_2F9BE, _word_2F9BC, _word_2F9BA, _dword_2
F9B6, _dword_2F9B2!
Opening hashed: C:\Games\ScummVM\Gobliins 2\INTRO.STK
Opening hashed: C:\Games\ScummVM\Gobliins 2\INTRO.STK
WARNING: STUB: Video::initDriver!
File intro.inf not found
File jeucar1.let not found
File jeumath.let not found
File gob.lic not found
File intro.ext not found
Opening hashed: C:\Games\ScummVM\Gobliins 2\INTRO.STK
WARNING: GOB2 Stub! Inter_v2::o2_initMult(), wide frontSurface, using the extra
space as animSurf!
WARNING: SoundKeyCount: 0!
WARNING: GOB2 Stub! Mult_Data.somepointer09, Mult_Data.somepointer10!
File track1.flac not found
File track1.fla not found
File track1.ogg not found
File track1.mp3 not found
Track 1 not available in compressed format

comment:6 by sev-, 13 years ago

Do you have your CD inserted when you play? Alternatively you may rip the audio track from the CD. That will work better.

Sven, apparently we should error out or somehow simulate tracks lengths (they're written in LIC) file, so game will work when the audio track is missing.

comment:7 by SF/adamhearn, 13 years ago

Follow up:

Just tested (and had same results on 2 other machines). Two machines are WinXP Pro, the other WinMCE 2005 all fully updated. All machines have nVidia graphics cards. Sound: onboard, Live, Audigy.

Looks like an issue with my CD/version of CD? I can supply it if required. Or I could get a debug build of SCUMMVM done and dig around if you like?

comment:8 by SF/adamhearn, 13 years ago

Q: Do you have your CD inserted when you play? Alternatively you may rip the
audio track from the CD. That will work better.

A: Yes I did have the CD inserted [on all machines tested on]. I usually create a compressed file but I didn't for this test. Will do that now...

comment:9 by SF/adamhearn, 13 years ago

Good call Sev.... Playback from the CD on my system seems to 'lock' the game engine (my evidence is purely that pressing keys soon fills up the keyboard buffer). Playback from a compressed audio file (I used OGG) resolves the missing video for me!

comment:10 by DrMcCoy, 13 years ago

Could you try again with the latest SVN version (or the next daily build)? It should work now directly from the CD.

comment:11 by SF/adamhearn, 13 years ago

Status: newclosed

comment:12 by SF/adamhearn, 13 years ago

Tested successfully using ScummVM 0.10.0svn (Dec 21 2006 11:02:13)

Thanks!

Note: See TracTickets for help on using tickets.