Opened 13 years ago

Closed 12 years ago

Last modified 12 years ago

#2920 closed defect (fixed)

FOTAQ: Music stops playing in temple

Reported by: (none) Owned by: cyxx
Priority: normal Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

ScummVM 0.10.0svn (Nov 19 2006 12:04:08)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Load the attached savegame and either walk around
or just stand there, music will stop playing
completely after one minute and some seconds.

Will be off until a soundeffect is played, e.g.
falling down the hole at the female zombie's
place.

If i can provide anything to help further, let
me know

English talkie

AmigaOS4
gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1599572. Ticket imported from: bugs/2920.

Attachments (2)

queen.s07 (12.2 KB) - added by SF/*anonymous 13 years ago.
Do whatever you want
queen.s08 (12.2 KB) - added by SF/*anonymous 13 years ago.
walk to exit on the right

Download all attachments as: .zip

Change History (11)

Changed 13 years ago by SF/*anonymous

Attachment: queen.s07 added

Do whatever you want

comment:1 Changed 13 years ago by cyxx

Looking at the tune/song data, that's apparently how it is supposed to sound :

/* 34 - Temple Fanfare 1 */
{ { 60, 162, 0 }, { 0, 0 }, 2, 0 },

The sixth field is equal to 2, which means "don't loop and play the tune once".

Changed 13 years ago by SF/*anonymous

Attachment: queen.s08 added

walk to exit on the right

comment:2 Changed 13 years ago by (none)

well, alright, but shouldn't there be some background
atmospheric going on? It's quite too silent.

And why does the atmospheric sound comes when Joe drops
down to the wind-tunnel thingie?
Attached a savegame now, where it is silent at the
femal zombie's place, just drop down to hear the
background sound coming back

comment:3 Changed 13 years ago by cyxx

I agree with you, it's too silent. It would be nice to test this with the original version under DOS and compare.

Anyway, it's normal you hear the music back when Joe drop down from the zombie's place. When that event occurs, another tune is queued :

/* 58 - Temple Fountain Room */
{ { 55, 0 }, { 0, 0 }, 1, 0 },

"1" standing for "play the tune and loop".

comment:4 Changed 13 years ago by cyxx

A possible problem could be that we are not saving the _songQueue array.

Question: did you always observe this behaviour just after loading a savegame ? Or could this also happen in game without having restored the game for a long time ?

comment:5 Changed 13 years ago by (none)

> A possible problem could be that we are not saving
> the _songQueue array.

> Question: did you always observe this behaviour just
> after loading a savegame ? Or could this also happen
> in game without having restored the game for a long
> time ?

I played the game right through (in one go) the first
time, saving periodically (for bug hunting) and got
this behaviour there too (with no loading at all) the
other times aswell (when loading from saved games to
reach the exact point where the music stops).

So, yes, it also happened while palying and not
loading at all...

comment:6 Changed 12 years ago by salty-horse

I have a similar problem in the jungle in room 9.
To reproduce, open the debug console and type "room 9", then leave the room and return.

An "intro" theme will play for a few seconds.
In the original engine, the end of that scene will start another music that will loop.
In ScummMV, after that initial theme nothing plays.

I have made a bad recording of the original music, if anyone wants to compare, but I have no way of attaching it to this bug.

comment:7 Changed 12 years ago by cyxx

In the case of the room 9, when entering the room, the following music tunes are queued :

song 93 // corresponds to the intro theme
song 1002 // starts playing randomly the songs from the tune list number 2 (1002 - 1000)

The list of songs from tune 2 are 15, 16, 17, 18, 7, 8, 9, 10, 11, 12, 13, 14.

Not sure what the problem is, it seems that some midi songs are "silent" (or partially) under scummvm.

So, as far as I can tell, scummvm behaves like the original interpreter from the "event/scripting point of view" (if you try several times under the original, a different song should begin to play after the song 93). Maybe a problem with the instruments mapping, volume etc.

comment:8 Changed 12 years ago by cyxx

Support for Adlib tracks has been added (previously ScummVM was using the Roland ones).
No "problem" for room 9 anymore.

comment:9 Changed 12 years ago by cyxx

Owner: set to cyxx
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.