Opened 15 years ago

Closed 15 years ago

#2919 closed defect (fixed)

FOTAQ: Clicks at the beginning of speech

Reported by: (none) Owned by: cyxx
Priority: normal Component: Engine: Queen
Version: Keywords:
Cc: Game: Flight of the Amazon Queen

Description

ScummVM 0.10.0svn (Nov 19 2006 12:04:08) Features compiled in: Vorbis FLAC MP3 zLib MPEG2

When NPC's start to talk there is always an enerving "click" before that, like one can hear when an LP-needle picks up some dust. It happens only with the speech from NPC's and only if Joe talks to one, it does not happen when inbetweeners with NPC's-only are being played.

Attached a savegame where Joe is with the female zombies, Just talk to them and it should trigger the click everytime the zomie speacks a new line.

English talkie

AmigaOS4 gcc version 4.0.2 (AmigaOS build 20051012)

Ticket imported from: #1599393. Ticket imported from: bugs/2919.

Attachments (1)

queen.s07 (12.2 KB ) - added by SF/*anonymous 15 years ago.
Just talk to those "ladies"

Download all attachments as: .zip

Change History (6)

by SF/*anonymous, 15 years ago

Attachment: queen.s07 added

Just talk to those "ladies"

comment:1 by SF/mthreepwood, 15 years ago

I can reproduce it on Mac OS X 0.10.0svn (11-9-06) 10.2.8

comment:2 by cyxx, 15 years ago

Not sure what we can do about it. These particular sound files of the english version *do* contain noise/garbage at the beginning of the data. Maybe we should add another workaround in compress_queen or the engine... <sigh>

Anyway, I tested the french talkie version, the sound played fine in this particular room (which seems "logical" since all the sound files had to be re-recorded for this version).

comment:3 by cyxx, 15 years ago

Summary: FotAQ: Clicks at the beginning of speechFOTAQ: Clicks at the beginning of speech

comment:4 by cyxx, 15 years ago

Owner: set to cyxx
Resolution: fixed
Status: newclosed

comment:5 by cyxx, 15 years ago

Apparently the english talkie version has 2 different .SB file formats. One with a header of 110 bytes and one with a header of 122. With the previous code, we always assumed it was 110. Hence the "click".

I fixed this in SVN, unfortunately you'll need to have to an original uncompressed version to benefit from this. And that also mean that the version we offer for download should be recompressed.

Thanks for your report !

Note: See TracTickets for help on using tickets.