Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2611 closed defect (fixed)

SPYFOX1: Problem with dial buttons

Reported by: SF/tristan9 Owned by: Kirben
Priority: high Component: Engine: SCUMM
Keywords: script Cc:
Game: Spy Fox 1

Description

The safe dial buttons only allow the dial to advance
one "click" from the present position (ie. 0->9, 0->1,
9->0 and 1->0). In original game installation buttons
allow repeated clicks on button. Saving the game at
this point results in a save game that is corrupted.
You cannot exit the room (the unsaved game you can).
The view is incorrect (it shows the general room not
the safe) and the actor (spyfox) is not visible in the
room. clicking anywhere in the pane results in the same
repeated (cycles) dialog. This is with the last stable
release 0.8.2

Ticket imported from: #1493340. Ticket imported from: bugs/2611.

Change History (9)

comment:1 Changed 13 years ago by sev-

Which spyfox1 version are you talking about? Please, provide
a savegame for it. Please, test with daily SVN snapshot.

Which room are you talking about?

comment:2 Changed 13 years ago by sev-

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 Changed 13 years ago by sev-

Summary: prevents continuation of gameSPYFOX1: Problem with dial buttons

comment:4 Changed 13 years ago by SF/tristan9

* ScummVM version : 0.8.2 Last stable version from gentoo
* Bug details: See above and below
* Language of game: English
* Version of game : CD
* Platform and Compiler: Linux GCC
* Attach a save game if possible: spyfox.s05 (This file is
to large to attach 360K Even when tarred and I now have had
to spend another half hour retyping this entire bug report
so it just might not have all of the details that the
original one had!!)
* If this bug only occurred recently: all versions

Bug 1: When you enter the office and a click on the picture
you need to set the buttons to different colors on the game
that is saved the buttons need to be blue, red and yellow.
(Windows98 Allows you to continue to press one button and
cycle through the different colors until you come to the one
you want. Then you go on to the next one.) What is
currently happening is you are only allowed to press the
button and have it change colors once. To get it to change
colors a second or third time you need to change the color
on a different button and go back to the first button to
change it a second time.

Bug 2, Once you get the painting opened and it brings up the
safe you attach the safe crackers. This tells you the
combination to the safe. All you need to do is turn the dial
to the correct numbers in the right direction. (Simple under
Windows98). What it is doing is only allowing you to
click the arrows above the dial one time so you can turn
from 0 to either 9 or 1. It will not allow you to turn the
dial past the first number no matter how many times you
click on the arrows.

Bug 3, When you try to save the game at this point it will
show the office but when you click around on the screen it
will bring up pictures form the safe screen.

Bug 4, Unable to attach the saved file because it will not
tar down past 360 K, what would you like me to do so you can
have the file?

comment:5 Changed 13 years ago by Kirben

Bug 1 - 2 are the same issue and a known problewm, click in
another area between each change. Either click on a
different dial or on the safe itself.

Bug 3 is caused, since you shouldn't be allowed to save the
game in that location. Unfortunately ScummVM can save
anywhere, which the original engine was not designed to
handle.

comment:6 Changed 13 years ago by Kirben

Note:
The work around I mentioned earlier, will only help if
subtitles are enabled in the game.

comment:7 Changed 13 years ago by Kirben

Owner: set to Kirben
Priority: normalhigh

comment:8 Changed 13 years ago by Kirben

Status: newclosed

comment:9 Changed 13 years ago by Kirben

Resolution: fixed
Note: See TracTickets for help on using tickets.