Opened 13 years ago

Closed 13 years ago

Last modified 13 years ago

#2610 closed defect (wontfix)

SWORD2: White noise with CoreAudio driver.

Reported by: (none) Owned by: fingolfin
Priority: normal Component: Engine: Sword2
Keywords: Cc:
Game: Broken Sword 2

Description

Versions = 0.8.2 and 0.9.0svn
Language = English
Platform = Mac OS X 10.4.6

This bug occurs in various locations throughout Broken Sword 2. For
example, start a new game, skip the introductory cutscene, and examine
(right-click) the bookcase.

When using the CoreAudio driver, you should hear "white noise" that
drowns out the music and dialogue. This doesn't happen when the
QuickTime driver is selected.

Could this be a byte ordering issue, similar to bug #1374198?

Ticket imported from: #1491175. Ticket imported from: bugs/2610.

Change History (18)

comment:1 Changed 13 years ago by fingolfin

Are you on an intel or a PowerPC system (kinda important to know when you are
talking about byte ordering issues *g*).

comment:2 Changed 13 years ago by (none)

Sorry. I'm using a PowerPC system...

Machine Name = PowerBook G4 15"
Machine Model = PowerBook5,4
CPU Type = PowerPC G4 (1.1)
Number Of CPUs = 1
CPU Speed = 1.5 GHz
L2 Cache (per CPU) = 512 KB
Memory = 512 MB
Bus Speed = 167 MHz

comment:3 Changed 13 years ago by fingolfin

I don't hear anything problematic in that spot (and I always use the CoreAudio
driver, anyway). Normally, I'd say the problem is with the voice data, not the
music anyway, but since you say that it goes away with the QuickTime driver...
odd.

comment:4 Changed 13 years ago by eriktorbjorn

I thought the CoreAudio and QuickTime drivers were only for
MIDI, but if that was the case they shouldn't make any
difference for Broken Sword 2...

comment:5 Changed 13 years ago by fingolfin

Indeed :-). I knew something was odd and bothering me here but I couldn't quite
put my finger on it ... :-)

comment:6 Changed 13 years ago by (none)

This might just be a random glitch on my system.

Over the last couple of weeks, I was continually experiencing the problem,
and could reliably reproduce it. Then, soon after submitting this bug report,
the problem occurs less frequently.

Swapping between the CoreAudio and QuickTime drivers seemed to have an
effect, but if these are just for MIDI...

I'm guessing that SDL is used for non-MIDI games?

comment:7 Changed 13 years ago by eriktorbjorn

SDL is used for all digital sound, yes. There could, of
course, be an endian problem in the Broken Sword 2 sound
decoder, though if there is it ought to affect all the
speech and all the music, since they use the same decoder.
(Sound effects are different, though. They are just WAV data
inside.)

There could be something going on that's corrupting the
index into the speech/music files. Trying to decode the data
from some random position would be likely to cause noise.

One possible reason for that could, as Fingolfin pointed
out, be corrupted data files. (You'd be surprised at how
often a bug report turns out to be just that.) Could you try
re-copying them from your CDs, and see if that makes any
difference?

comment:8 Changed 13 years ago by (none)

I've recopied the data files from my CDs, and verified the hard disk with Disk
Utility. I'll test the game over the next few days and let you know if the sound
problem reoccurs.

comment:9 Changed 13 years ago by fingolfin

What is the status of this item?

comment:10 Changed 13 years ago by fingolfin

Owner: set to fingolfin
Resolution: worksforme
Status: newpending

comment:11 Changed 13 years ago by (none)

Status: pendingnew

comment:12 Changed 13 years ago by (none)

I couldn't reproduce the bug as described in my initial comment, but the sound
problem did occur elsewhere, when Nico is at the British Museum.

If the data files were corrupt, I should hear white noise every time a certain part
of the game is played. So why does the problem only occur intermittently?

If no one else is experiencing this problem, you could close this item with
"Works For Me".

comment:13 Changed 13 years ago by sev-

Status: newclosed

comment:14 Changed 13 years ago by SF/necroyeti

I'm experiencing the same issue. Steps to repdroduce the
problem (reliable):

1. reboot (important)
2. launch scummvm, start bs2, skip intros
3. as soon as george speaks for the first time, the white
noise appears

If I quit ScummVM then and try step 2 and 3 again,
everything is ok, no white noise can be heard.

---

ScummVM 0.9.0 (Jun 22 2006 13:19:37)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

Mac OS X 10.4.6
iBook G4 (PPC G$ 1.2 GHz, 512 MB RAM)

comment:15 Changed 13 years ago by (none)

I've reopened this item, so that it's visible on the bug tracker. Restarting the OS,
as suggested by necroyeti, should enable others to hear the problem.

comment:16 Changed 13 years ago by (none)

Status: closednew

comment:17 Changed 13 years ago by fingolfin

This is either a bug in the OS, or in SDL, but not in ScummVM. There is nothing
we can do about it.

comment:18 Changed 13 years ago by fingolfin

Resolution: worksformewontfix
Status: newclosed
Note: See TracTickets for help on using tickets.