Opened 14 years ago

Closed 14 years ago

Last modified 14 months ago

#2598 closed defect (fixed)

GUI: SCUMM pause dialog breaks upon scaler switch

Reported by: fingolfin Owned by: sev-
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

Steps to reproduce: 0) Use latest SVN to start any SCUMM game with the SDL backend 1) Press <space> to show the pause dialog 2) Use Ctrl-Alt-NUM to switch to a different scaler

Result: The pause dialog vanishes. Even pressing space again and again, to toggle pause on/off repeatedly, won't make it reapper.

Assigned to LordHoto, just to make sure he's aware, feel free to unassign immediately / reassign to sev / do something else :-).

Ticket imported from: #1483272. Ticket imported from: bugs/2598.

Change History (8)

comment:1 by lordhoto, 14 years ago

Owner: changed from lordhoto to sev-

comment:2 by lordhoto, 14 years ago

It doesn't vanish over here, but the position is not correct, since sev said that he rewrites the resizing I'll assign this to him, we could disable the resizing for now to fix this.

comment:3 by eriktorbjorn, 14 years ago

The same thing happens with the version dialog in V7 games. Not surprising since that dialog is a pause dialog, too.

comment:4 by eriktorbjorn, 14 years ago

It may have something to do with the definition of "dummyDialog" in our themes, and/or that we create the dialog once and then re-use it. (We do that with the SCUMM engine's MainMenuDialog as well, but that one calls handleScreenChanged() from its open() method.)

comment:5 by sev-, 14 years ago

No. The problem is that widget position and dimension are computed in widget constructor, not defined in our theme config. It cannot be put there because the widget shows arbitrary string.

Correct solution would be to overload handleScreenChanged() and recaluclate everything. Quite trivial task.

Another problematic dialog is scumm help dialog. It's even worse with it. You have to restart ScummVM to render it in different resolution properly.

comment:6 by sev-, 14 years ago

Fixed in SVN.

comment:7 by sev-, 14 years ago

Resolution: fixed
Status: newclosed

comment:8 by digitall, 14 months ago

Component: GUI
Note: See TracTickets for help on using tickets.