Opened 15 years ago

Closed 14 years ago

Last modified 11 years ago

#2439 closed defect (fixed)

DOTT/Disk: PocketPC crash when using stamp with envelope

Reported by: SF/nulusios Owned by: SF/arisme
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Day of the Tentacle

Description

I am trying to use the stamp with the envelope and the game crashes. I moved the same savefile to PC and it worked fine.

I have tried the same action with all three heros in the game and produced the same result.

I would attach the save file (where you just "use" the two items together to see what I am talking about) but the system doesn't allow for such things.

(ah forgot... 0.8.0 on both systems, PocketPC is 2003)

Ticket imported from: #1399830. Ticket imported from: bugs/2439.

Attachments (2)

tentacle.s08 (32.7 KB ) - added by SF/nulusios 15 years ago.
just use stamp and contract to crash pocketpc scummvm
scummvmCrash_07_01_2006_01_19_52.txt (807 bytes ) - added by SF/nulusios 15 years ago.
crash dump

Download all attachments as: .zip

Change History (29)

by SF/nulusios, 15 years ago

Attachment: tentacle.s08 added

just use stamp and contract to crash pocketpc scummvm

comment:1 by sev-, 15 years ago

Keywords: script added
Summary: PocketPC only crash in specific actionDOTT: PocketPC crash when using stamp with envelope

by SF/nulusios, 15 years ago

crash dump

comment:2 by SF/nulusios, 15 years ago

contrary to what I mention above, I attach the save file plus I attach one of the crash dumps...

comment:3 by fingolfin, 15 years ago

Please state for which version of DOTT this savegame was made. I can't open it.

Anyway: The good old contract+stamp crash, reported countless time, never reproduced on a developer's machine...

comment:4 by fingolfin, 15 years ago

Status: newpending

comment:5 by SF/nulusios, 15 years ago

it's 0.8.0 of course (official builds) I opened the save game both with x86 SCUMMVM and WM2k3

maybe it doesn't happen on an emulator (if you use an emulator not a real PDA)

comment:6 by SF/nulusios, 15 years ago

Status: pendingnew

comment:7 by SF/nulusios, 15 years ago

oups sorry... you said which DOTT version not SCUMMVM...

well I am not sure of the version number (how do I look?) but it's the English US/DOS one, reported with ID "tentacle" by SCUMMVM

comment:8 by sev-, 15 years ago

Max, it's 2723fea3dae0cb47768c424b145ae0e7

I just commited code to print that out on debug level 2.

comment:9 by fingolfin, 15 years ago

Yeah, I figured out that already some time ago. The real problem why I wasn't able to use the savegame is the MD5 based game detection code, which tried to start MM instead (didn't notice that initially, as it simply errored out) :-(

comment:10 by fingolfin, 15 years ago

I still don't have the correct version of DOTT (this is the Floppy version B, according to our MD5 table), so all I can do is guess that this is another of these bugs specific to the floppy version (similar to the chattering teeth bug).

Another unrelated thing: The savegame thumbnail shows up with wrong colors over here. This might indicate a bug in the thumbnail code :-/.

comment:11 by SF/lasombra, 15 years ago

It is well known that PPC emulators are very different of the real thing. :(

comment:12 by SF/arisme, 14 years ago

Mmh. The mystery deepens, this bug is similar to the crash happening in FOTAQ http://sourceforge.net/tracker/index.php?func=detail&aid=1392815&group_id=37116&atid=418820

that I traced back to a crash in setOwnerOf (object.cpp).

This one seems to be PocketPC specific since nobody else complained :(

comment:13 by fingolfin, 14 years ago

Summary: DOTT: PocketPC crash when using stamp with envelopeDOTT/Disk: PocketPC crash when using stamp with envelope

comment:14 by fingolfin, 14 years ago

I think you meant to write "FOA" not FOTAQ (considering FOTAQ is not even a SCUMM game) :-)

comment:15 by fingolfin, 14 years ago

I now have this version of DOTT (thanks to ebay). I still can't reproduce the issue, though... Some similar bug reports hint that it may matter in which order you combine the two items, but I tried both, and still no crash...

nulusios, you can reproduce the problem both on your PDA, and on your regular PC, using the savegame? Anything special you are doing? Does it always crash, or only sometimes?

comment:16 by SF/nulusios, 14 years ago

fingolfin I already said that the same savefile worked on PC. In fact this is how I passed this stage. I leaded on PC, combined the two items, saved again and the new save game (with the items already combined) worked fine (till the end of the game).

Combining the two items on PocketPC ALWAYS had the same result: SCUMMVM crash.

I didn't do anything special. My PDA is a WM2003SE VGA machine (PocketLOOX 720).

comment:17 by SF/arisme, 14 years ago

Can you check with this version and tell me is the bug is still present ?

http://arisme.free.fr/tempo/scummvm-0.8.0-debug-1.zip

It should allow me to know if it's a compiler related problem or not.

comment:18 by SF/nulusios, 14 years ago

OK this sucks.

I downloaded this debug version, but before I installed it, I thought of trying the save file (I am not sure if it is the same I have attached in this thread) where the envelope and the stamp are not already combined. This time it worked! It is stupid. Back when I started the thread it was crashing ALL the time!

I have in fact tried an older save file too, and it still worked.

I have a new bug now though... the "envelope" graphic in the inventory doesn't always change to the "closed envelope with stamp" graphic! (although the stamp is gone so I suppose it is the correct object)

I don't know what to say. Later I will reload MY save file attached here, and try with this one.

Weird.

comment:19 by SF/arisme, 14 years ago

OK, let me know if it works with the original saved game. If it's successful I'll try to disable optimization selectively.

comment:20 by SF/nulusios, 14 years ago

OK I tried.

The old save game (submited here), with original 0.8.0 did crash again.

The debug version with that save game, DID NOT. So yes you probably found the reason.

Of course now remains to be seen why my newer save game did not crash (same character, same place, same inventory... it's probably a save game I made after I moved items to-forth the characters a bit - I cannot remember now). And let's not forget the bug where the envelope graphic doesn't change.

comment:21 by fingolfin, 14 years ago

I ask again: Does it make any difference in which *order* you combine the items? I.e. "use stamp with envelope" vs. "use envelope with stamp"

comment:22 by SF/nulusios, 14 years ago

no same thing happens

comment:23 by SF/arisme, 14 years ago

OK, this erratic behaviour is not surprising if it's yet another optimizer bug as I suspect :)

Let's try this version with optimization specifically disabled on the offending file

http://arisme.free.fr/tempo/scummvm-0.8.0-debug-2.zip

comment:24 by SF/nulusios, 14 years ago

yeap you found it :D

comment:25 by SF/arisme, 14 years ago

Resolution: fixed
Status: newclosed

comment:26 by SF/arisme, 14 years ago

OK, until the next optimizer bug :)

I'll add a note in the README for potential builders to remember to disable optimization for this file if they aren't using my project files.

Closing for now and the similar bugs then, I'll apply that on 0.8.2 and cross fingers :)

comment:27 by Kirben, 11 years ago

Owner: set to SF/arisme
Note: See TracTickets for help on using tickets.