Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2292 closed defect (wontfix)

LOOM CD: Cannot find file: '00.lfl'

Reported by: SF/nikioko Owned by: sev-
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

This is the message I encounter when using ScummVM
0.8.0 on the Loom CD version which is patched with the
German subtitle patch from www.gandimann.de
Version 0.7.1 worked out fine which this patch, and the
unpatched version of Loom works under ScummVM
0.8.0 as well.
But I get the patched version running by adding the
following line to the scummvm.ini:
target_md5=5D88B9D6A88E6F8E90CDED9D01B7F082

It would be nice if further versions of ScummVM could
again support the patched edition without manually
adding this line as it was until version 0.7.1.-

Nikioko

Ticket imported from: #1330021. Ticket imported from: bugs/2292.

Attachments (1)

scummvm.ini (3.7 KB ) - added by SF/nikioko 14 years ago.
My scummvm.ini

Download all attachments as: .zip

Change History (12)

comment:1 by SF/nikioko, 14 years ago

Summary: Cannot find file: '00.lfl'LOOM CD: Cannot find file: '00.lfl'

comment:2 by sev-, 14 years ago

Just checked it. Works for me. There _was_ bug which
prevented it from working, but it was a week ago or more.
Make sure you're using latest CVS build, not just 0.8.0.

comment:3 by sev-, 14 years ago

Resolution: invalid
Status: newclosed

comment:4 by SF/nikioko, 14 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:5 by SF/nikioko, 14 years ago

I just downloaded and tried the latest daily snapshot, and the
problem still exists.

comment:6 by SF/nikioko, 14 years ago

Status: closednew

comment:7 by sev-, 14 years ago

Please, attach your scummvm.ini, directory list of your loom
and output of

scummvm -d9 loomcd-de

command. (substitute your target name isntead of loomcd-de)

comment:8 by sev-, 14 years ago

Owner: set to sev-
Resolution: invalid

by SF/nikioko, 14 years ago

Attachment: scummvm.ini added

My scummvm.ini

comment:9 by SF/nikioko, 14 years ago

scummvm.ini see as attached. Please note that the line
target_md5=5D88B9D6A88E6F8E90CDED9D01B7F082 has
been inserted manually which made the game run.

content of the LOOM directory:
000.lfl
901.lfl
902.lfl
903.lfl
904.lfl
disk01.lec
track1.mp3

Output WITHOUT the added line:
Debuglevel (from command line): 9
Looking for loom
Trying to start game 'Loom'
File loom.000 not found
File 00.LFL not found
File Maniac Mansion (E).prg not found
File Maniac Mansion (F).prg not found
File Maniac Mansion (SW).prg not found
File Maniac Mansion (U).prg not found
File maniac1.d64 not found
File zak1.d64 not found
Output sample rate: 22050 Hz
Unknown MD5 (c15a22791cf68b4f1249b481252ec43a)!
Please report the details (language, platform, etc.) of this
game to the ScummVM team
allocResTypeData(Buffer/buffer,NONE,10,0)
readIndexFile()
openRoom(0)
openResourceFile(00.lfl)
File 00.lfl not found
Cannot find file: '00.lfl'!

After adding the line
target_md5=5D88B9D6A88E6F8E90CDED9D01B7F082 the
game just works out fine. And as I heard, there is the same
problem with the patches for the FM towns games.

comment:10 by sev-, 14 years ago

I don't understand what made me so blind and not notice that
you say that it _works_ for you with target_md5 added. We
have no means on reverting that sorry. Mainly because
translation teams continue fix bugs in their translations
and md5 changes often. That was the reason why we decided to
meet their needs and add that taget_md5 configuration key.

So sorry, it will not be back. And besides you will have to
add that line just _once_ when you run your game for the
first time. Later, even after translation upgrade it will
still work. That's not a big deal even for computer
illiterate. Tranlsation teams should provide clear
insturctions on their sites or even put some brains into
their installation programs, so that could be done
automagically. Not a big deal either.

Rejected. Wont Fix.

comment:11 by sev-, 14 years ago

Resolution: wontfix
Status: newclosed
Note: See TracTickets for help on using tickets.