Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#2289 closed defect (invalid)

SIMON2WIN: actor freezes

Reported by: SF/cirion81 Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 2

Description

Simon doesn't react to any interaction (= the game
behaves like frozen). After some waiting the game can
be played again, the console shows the following error
message:

WARNING: wait timed out

restarting ScummVM didn't help. Doesn't seem to concide
with a hangig sound / hanging music, thus I din't
restart the system. If anyone loading the attached
savegame can't reproduce the error, I assume ScummVM
had to wait for a system event.

ScummVM Version. 12.10.2005 8.0.0CVS
Game Version: English, Talkie, Win
Win32

Ticket imported from: #1329571. Ticket imported from: bugs/2289.

Attachments (1)

simon2.009 (885 bytes ) - added by SF/cirion81 14 years ago.

Download all attachments as: .zip

Change History (14)

by SF/cirion81, 14 years ago

Attachment: simon2.009 added

comment:1 by SF/cirion81, 14 years ago

Summary: timeut errortimeout error

comment:2 by sev-, 14 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 by sev-, 14 years ago

Summary: timeout errorSIMON2win: actor freezes

comment:4 by sev-, 14 years ago

In which situation does it happen? Any exact steps to

comment:5 by SF/cirion81, 14 years ago

I retested the savegame after I rebooted my machine - the
error still persisted. Also I tried the latest CVS built
0.8.0pre 19.10.2005 and the 0.7.1 built to the same effect.

The situation happened for me in no particular coincidence.
I just happen to stroll around after planting the stink-bomb
on the magic fair, searching for a clue how to continue.
Sorry, I can't give you detailed instructions at how I
reached that exact piont in the game.

What else I just noted: I just did a short "debug-session"
starting ScummVM with the debug option. I piped the output
in a Textfile. But the error Message about the timeout never
showed up in the debug-printout. Instead it was still
printed in the console window from where I started ScummVM.

Another thing which I think wasn't clear enough in my bug
description: the game seems frozen, but I can still move the
mouse-pointer, load and save games and exit ScummVM. It's
just that Simon doesn't react to clicking. Changing the
Cursor to do something (like look etc.) doesn't work as well.

comment:6 by eriktorbjorn, 14 years ago

I vaguely remember seeing a "time-out" problem in Simon 1
when doing one specific action, but I was told it happened
with the original interpreter as well.

I wonder if that's the case for this one, too.

comment:7 by Kirben, 14 years ago

The wait timeout errors come from ScummVM and the game
will continue as normal, if you wait long enough. You can
enable fast mode (Ctrl F or Ctrl G) to reduce the amount of
time, just be sure of disable it again after.

We know of several situations in the game which cause this
problem to occur, but they are usually triggered by a certain
event. So I expect there is some specific event to trigger the
problem in this case, it could be as simple as examining a
certain point on the screen.

The reported problems have always occured in the original
games so far. I keep a list of known issues in the original
games at
http://members.optusnet.com.au/scummvm/simon_bugs.html
(Which I should really move to our wiki).

comment:8 by Kirben, 14 years ago

Owner: set to Kirben

comment:9 by fingolfin, 14 years ago

So... what should be done then? Do you plan to add a hack to work around this
bug, do you hope for a proper solution, or should this just be closed as
"WONTFIX" (since the issue occured in the foirinal, too) ?

comment:10 by fingolfin, 14 years ago

Summary: SIMON2win: actor freezesSIMON2WIN: actor freezes

comment:11 by Kirben, 14 years ago

Closing as invalid, since we don't know the exact trigger
for this bug.

The attached save game is after the problem occurs, so
isn't of any use.

comment:12 by Kirben, 14 years ago

Resolution: invalid
Status: newclosed

comment:13 by Kirben, 13 years ago

Component: Engine: SCUMMEngine: AGOS
Game: Putt-Putt Travels Through TimeSimon the Sorcerer 2
Note: See TracTickets for help on using tickets.