Opened 14 years ago

Closed 13 years ago

#2268 closed defect (fixed)

MANIACNES: Inventory hotspots can be misaligned

Reported by: SF/dfabulich Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

In the attached save, click on GIVE and point to the
word "BOWL" in your inventory. The BOWL of fruit will
not be selected; instead the STAIRS will be selected.
If you click, you'll start trying to "GIVE STAIRS TO
..." which is illogical. You have to pan right to the
word "WAX" in order to select the BOWL of fruit.

This is my favorite reproducible case, but this bug
doesn't always reliably reproduce itself. Sometimes it
comes and goes when I enter/exit a room. Worse, it
doesn't just happen on inventory items with long names,
like the "BOWL OF WAX FRUIT". I got stuck at the end
game when I couldn't figure out any way to USE the CARD
KEY, because the only way to select the CARD KEY was to
point at the blank space to the right of the words
"CARD KEY".

I'm testing on Windows 2000, using Maniac NES (English
US), ScummVM 0.8.0CVS (Oct 15 2005 21:10:23), Features
compiled in: Vorbis FLAC MP3 zLib MPEG2

Ticket imported from: #1328131. Ticket imported from: bugs/2268.

Attachments (3)

maniaca.s02 (6.8 KB ) - added by SF/dfabulich 14 years ago.
Save next to green tentacle with bowl
inventory1.png (13.3 KB ) - added by SF/dfabulich 14 years ago.
screenshot "GIVE STAIRS TO"
inventory2.png (13.4 KB ) - added by SF/dfabulich 14 years ago.
screenshot pointing at "WAX" to "GIVE BOWL OF WAX FRUIT TO"

Download all attachments as: .zip

Change History (7)

by SF/dfabulich, 14 years ago

Attachment: maniaca.s02 added

Save next to green tentacle with bowl

by SF/dfabulich, 14 years ago

Attachment: inventory1.png added

screenshot "GIVE STAIRS TO"

by SF/dfabulich, 14 years ago

Attachment: inventory2.png added

screenshot pointing at "WAX" to "GIVE BOWL OF WAX FRUIT TO"

comment:1 by SF/quietust, 14 years ago

The misalignment was fixed quite a while ago, but the issue
remains that if an object is located at the very top of the
screen (such as Stairs), then moving the cursor into unused
locations within the Verbs/Inventory area will result in
that object being selected.

comment:2 by fingolfin, 13 years ago

What is the status of this item?

comment:3 by fingolfin, 13 years ago

Owner: set to sev-

comment:4 by fingolfin, 13 years ago

Owner: changed from sev- to fingolfin
Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.