Opened 14 years ago

Closed 14 years ago

Last modified 10 years ago

#2252 closed defect (fixed)

DOTT: "ERROR: no parts available"

Reported by: (none) Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

Build: CVS from 2005-10-11 w/tremor support
Platform: OpenBSD/zaurus

When playing the DOTT talkie, if I try to go up the
fireplace with Laverne I immediately get "ERROR: no
parts available". I also tried this on OpenBSD/i386
using the uncompressed sound file and the same error
occurred.

Saved game is attached.

Ticket imported from: #1325487. Ticket imported from: bugs/2252.

Attachments (1)

tentacle.s16 (31.4 KB) - added by SF/*anonymous 14 years ago.
laverne_fireplace_crash_savegame

Download all attachments as: .zip

Change History (10)

Changed 14 years ago by SF/*anonymous

Attachment: tentacle.s16 added

laverne_fireplace_crash_savegame

comment:1 Changed 14 years ago by (none)

MD5 (MONSTER.SOU) = 86ed80f36192937d9a38fa8e9fb48b84
MD5 (TENTACLE.000) = 4167a92a1d46baa4f4127d918d561f88
MD5 (TENTACLE.001) = c5d451e659e0915ac02f5807de3a0bc0

comment:2 Changed 14 years ago by eriktorbjorn

Probably the same problem as the one described in bug #1325060.

comment:3 Changed 14 years ago by eriktorbjorn

I can't reproduce this problem, but it looks to me as if
that error was never intended to be fatal. It just means it
can't create a new part, because there were no unused ones
and the used ones all had higher priority than this new one.
So I've downgraded it to a debug message.

comment:4 Changed 14 years ago by fingolfin

So I assume this can be closed as "fixed" ? I still think there is a deeper
issue here (like the "load" code should probably reset more parts of iMuse
or so), but for now it should work again, shouldn't it?

Jolan Luff, would you please test with a current CVS build to see whether
the problem still occurs?

comment:5 Changed 14 years ago by fingolfin

Summary: dott talkie: "ERROR: no parts available"DOTT: "ERROR: no parts available"

comment:6 Changed 14 years ago by eriktorbjorn

Well, it shouldn't cause ScummVM to terminate any more. As I
said, it doesn't look to me as this function failing was
ever supposed to be a fatal error.

But, as you say, it could still be a bug that caused it to
happen. I'm not sure if saving/restoring was involved in
this particular bug report, though. Unless it's one of the
points where the game saves/restores on its own.

comment:7 Changed 14 years ago by (none)

Yes it was fixed by -r2.58 of imuse_player.cpp, thanks.

comment:8 Changed 14 years ago by (none)

Status: newclosed

comment:9 Changed 10 years ago by Kirben

Resolution: fixed
Note: See TracTickets for help on using tickets.