Opened 14 years ago

Closed 8 years ago

Last modified 8 years ago

#2230 closed defect (fixed)

MI2 FM-TOWNS: Music Stops after staying 5min at mardigras

Reported by: SF/joachimeberhard Owned by: athrxx
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 2

Description

While enjoying what the guests at mardigras had to say
i encountered the following iMuse bug:

The music just stops after hanging around for at least 5
minutes or more (don't know exactly).

Leaving the room sets everything back to normal.

Best regards

Joachim Eberhard

Ticket imported from: #1315950. Ticket imported from: bugs/2230.

Change History (11)

comment:1 Changed 14 years ago by sev-

Priority: normallow
Summary: MONKEY2 FMTOWNS Music Stops after staying 5min at mardigrasMI2towns: Music Stops after staying 5min at mardigras

comment:2 Changed 12 years ago by fingolfin

Summary: MI2towns: Music Stops after staying 5min at mardigrasMI2 FM-TOWNS: Music Stops after staying 5min at mardigras

comment:3 Changed 9 years ago by fingolfin

Florian, any chance your recent FM-TOWNS work will affect this bug? (Or if not, maybe you are interested in looking into this one anyway? :)

comment:4 Changed 9 years ago by fingolfin

Owner: set to athrxx

comment:5 Changed 9 years ago by athrxx

Hmm, like he says in the message: "i encountered the following IMUSE bug".
My changes cannot have affected this.

It might be a bug in the sound data rather than a bug in the IMuse code (since only one specific song seems to have looping issues).

I'll check whether I can reproduce this bug in the DOS version. Maybe I can fix/work around it. But I have to admit I don't know much about the IMuse code...

Joachim Eberhard: Please verify whether this bug is still existent and check which Music device (Adlib, MT-32 etc.) you use.

comment:6 Changed 8 years ago by athrxx

Okay, this bug also applies to the DOS version. It is a regression from the workaround for this:

https://sourceforge.net/tracker/?func=detail&aid=761637&group_id=37116&atid=418820

That workaround has been added in 2003 to fix something in the FOA credits. I have found no other songs (apart from FOA credits and MI2 mardi gras) where this workaround which omits certain imuse commands in the queue kicks in (but this is hard to track - in the mardi gras song it takes a long time until that happens). While this workaround might be useful in FOA the omission of imuse commands will skip the restart of the mardi gras song.

I could fix/work around this issue locally by executing the queued commands which would otherwise be discarded before jumping to the requested marker. But this might not be the optimal solution. There might be other songs in other imuse games where the workaround might kick in. It is hard to tell how these songs would be affected. I also don't know how the original would behave here (e.g. in DOSBox).

comment:7 Changed 8 years ago by bluegr

The revision where this workaround was committed is 8831:
https://fisheye3.atlassian.com/changelog/scummvm?cs=8831

comment:8 Changed 8 years ago by athrxx

This should now be fixed (by reverting fix for bug #761637(https://sourceforge.net/tracker/?func=detail&aid=761637&group_id=37116&atid=418820) which has also been fixed in a different manner.

Please test (works for me).

comment:9 Changed 8 years ago by athrxx

Resolution: fixed
Status: newpending

comment:10 Changed 8 years ago by SF/sf-robot

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:11 Changed 8 years ago by SF/sf-robot

Status: pendingclosed
Note: See TracTickets for help on using tickets.