Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2189 closed defect (invalid)

FOTAQ CD version for download not supported by queenrebuild

Reported by: SF/sndirsch Owned by:
Priority: normal Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

SUSE need to ship scummvm without MAD (MP3) support
(guess why). It should be possible to convert the FOTAQ data
into .ogg/.flac instead of .mp3 format with "queenrebuild".
Actually it is *not*. :-(

# /usr/games/queenrebuild --ogg queen.1c
Unknown/unsupported FOTAQ version!

Could this be changed/fixed? This would help our customers a
lot.

Ticket imported from: #1287736. Ticket imported from: bugs/2189.

Change History (9)

comment:1 Changed 14 years ago by sev-

queenrebuild works only with original data. We ship it MP3
compressed to savce bandwidth. So if you want to recompress
it into OGG, you should get full version somewhere. Since it
got freeware, many sites with legal downloads started to
offer FOTAQ.

This is definitely not a bug.

comment:2 Changed 14 years ago by sev-

Resolution: invalid
Status: newclosed

comment:3 Changed 14 years ago by SF/sndirsch

Can you give me an example of "somewhere"? How much bigger
would the data become when using .ogg instead of .mp3
compression? Maybe you can provide them both for download?
Would be much easier for our customers than to tell them to
download the original data "somewhere" and convert it to .ogg
format. SUSE is not the only distribution which meanwhile lacks
MAD/MP3 support.

comment:4 Changed 14 years ago by SF/sndirsch

Component: ToolsEngine: Queen
Game: Flight of the Amazon Queen
Resolution: invalid
Status: closednew

comment:5 Changed 14 years ago by sev-

Resolution: invalid
Status: newclosed

comment:6 Changed 14 years ago by sev-

Please, do not fiddle with bugreport attributes especially
if you're not going to fix it by yourself.

Again, this is _not_ a bug, so I'm closing it.

I have no slightest idea on where to get the game. As I've
told you it is legal to download it since it got freewared.
You're not "a customer" but "a user of ScummVM" since you
didn't pay us. We offer our service for free with no
guarantees, go read the GNU Public License.

And no, it would not be easier to offer 2 versions of the
game or uncompressed one due to bandwidth restrictions on
sf.net. We already overdued it 2x times than allowed.

How come that SUSE lacks MAD support? Just go and install it.

comment:7 Changed 14 years ago by SF/sndirsch

Sure it is not a bug. I would set it to enhancement with the new
summary "Provide FOTAQ CD Version also in .ogg format".
Unfortunately this seems not to be possible with this bugtracking
system. :-(

Ok, looks like it is not that difficult to find the full version using
Google, e.g. '"Flight of the Amazon Queen" download' as search
string does the trick.

Maybe I should mention that I maintain scummvm for the SUSE
Linux distribution. And I'm still convinced that you're interested
scummvm seing on Linux distributions. Since I want to make
a good job maintaining scummvm I contacted you about this
problem to work a solution. Unfortunately it's not an option for
us to include MAD support (MP3 license issues).

I don't see the bandwith argument. Do you think people will download
both versions (.ogg + .mp3)? It might be a harddisk space problem
though.

Anyway, I'll document this issue and describe how to download and
rebuild the FOTAQ data to .ogg in a README.SUSE now.

comment:8 Changed 14 years ago by sev-

I see. The problem with sf.net is that they restrict project
file space to 100M and we've crossed 200M line some time
ago. If there would be some server which will put
uncompressed version permanently we will gladly add link to
it. Though correct place for such discussion is
scummvm-devel mailing list. So I propose you to describe
license problem with SUSE there and we will see how to solve it.

comment:9 Changed 14 years ago by SF/sndirsch

Thanks. I'm subscribed now to the scummvm-devel list and
will discuss this on the ML. I'll talk with SUSE/Novell.
Maybe we can provide the URL/server for downloading the full
version or at least an ogg compressed version.

BTW, I was wrong. It isn't that easy to find a full version
for download. Up to now (tried about a dozen download links)
all version has been compressed versions (about 32 MB
zipped) and therefore handled as unsupported versions by
"queenrebuild".

Is it correct, that queenrebuild only can convert from the
original version to ogg/mp3/flac and not the other way round
and also not between the compressed file formats? Currently
this is my understanding of the situation.

Note: See TracTickets for help on using tickets.