Opened 14 years ago

Closed 14 years ago

#2188 closed defect (invalid)

BASS: Crash in the pipe factory

Reported by: SF/toreanderson Owned by: lavosspawn
Priority: low Component: Engine: Sky
Keywords: script Cc:
Game: Beneath a Steel Sky

Description

Hi. I just got this bug report from Francesco Poli, a user of the Debian package. The full bug log is available at <http://bugs.debian.org/323657>.

---quote--- I think I found a bug in _Beneath a steel sky_ (but it may well be ScummVM's fault, I don't know).

I managed to find a way to make sky hang up completely: the attached autosave reproduces the bug. After restoring this autosave, as soon as I click on anything in the room, I see a bunch of identical stderr messages and I'm unable to do anything else in the room. I even managed to crash scummvm, by clicking on another character in order to start a dialog, and repeatedly clicking on "never mind..." (the only possible phrase).

Here's the stderr (redirected to a file):

| WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | WARNING: Place compact's getToTable is NULL!! | Unknown script command: 24033!

Here's my .scummvmrc:

| [scummvm] | versioninfo=0.7.1 | | [sky] | subtitles=true ---quote---

I can reproduce it using his autosave file, which I'll attach here as well, on both 0.7.1 and a fresh CVS snapshot from today.

Tore

Ticket imported from: #1286589. Ticket imported from: bugs/2188.

Attachments (1)

SKY-VM-CD.ASD (13.1 KB ) - added by SF/toreanderson 14 years ago.
Autosave from the room outside the nuclear reactor in the pipe factory.

Download all attachments as: .zip

Change History (13)

by SF/toreanderson, 14 years ago

Attachment: SKY-VM-CD.ASD added

Autosave from the room outside the nuclear reactor in the pipe factory.

comment:1 by sev-, 14 years ago

Summary: Crash in the pipe factorySKY: Crash in the pipe factory

comment:2 by sev-, 14 years ago

Please, test this bug with latest daily build which you can find on bottom of our downloads page at http://www.scummvm.org/downloads.php.

comment:3 by sev-, 14 years ago

Priority: normalhigh

comment:4 by sev-, 14 years ago

Forgot to raise priority. If this is a real bug then it is a show stopper.

comment:5 by SF/toreanderson, 14 years ago

I can still reproduce it with a binary built from a CVS tree updated not ten minutes ago.

Tore

comment:6 by lavosspawn, 14 years ago

Two bytes in the savegame are corrupt, fixing it with a hexeditor makes it work perfectly again. I'm quite sure it wasn't caused by a logic bug, though. I guess it was either caused by a defective harddisk(?) or memory corruption.

The idea of a defective harddisk may sound like a quite lame excuse... but we've run BASS with valgrind several times by now, and I really don't think there's any memory corruption going on there. So, in other words, I really don't know. Sorry. :)

comment:7 by SF/toreanderson, 14 years ago

Ok, so we should close this bug as invalid, or at least lower the severity so it isn't considered a blocker?

I can ask Francesco if he's aware of any hardware problems on his computer, if you wish.

Tore

comment:8 by sev-, 14 years ago

I think we could close it. In the meantime I lower priority and remove from the list.

comment:9 by sev-, 14 years ago

Owner: set to lavosspawn
Priority: highlow

comment:10 by fingolfin, 14 years ago

What is the status of this item?

comment:11 by fingolfin, 14 years ago

Summary: SKY: Crash in the pipe factoryBASS: Crash in the pipe factory

comment:12 by fingolfin, 14 years ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.