Opened 15 years ago

Closed 15 years ago

#2097 closed defect

SAM: chatting with Snuckey's clerk crashes

Reported by: SF/gmarcon Owned by:
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Sam and Max

Description

Experienced on the last daily build. In the attached savegame, starting a chat to the clerk in Snuckey crashes with the following message: (11:11:0x74): Value 27469 is out of bounds (0,1099) (Object 27469 out of range in putState)

- ScummVM 0.8.0CVS (Jul 24 2005 09:06:42) - Language of game: Italian - Version of game: Talkie - Platform and Compiler: Win32

Ticket imported from: #1243988. Ticket imported from: bugs/2097.

Attachments (1)

samnmax.s04 (36.4 KB ) - added by SF/gmarcon 15 years ago.
Savegame where crash occurs when chatting to Snuckey's clerk

Download all attachments as: .zip

Change History (11)

by SF/gmarcon, 15 years ago

Attachment: samnmax.s04 added

Savegame where crash occurs when chatting to Snuckey's clerk

comment:1 by SF/gmarcon, 15 years ago

Looks like it crashes chatting to anyone. If it can be helpful the last thing I remember I did was to collect the pecan candies...

comment:2 by eriktorbjorn, 15 years ago

I only have the English version unfortunately, so I can't use your savegame and it's unlikely that I'll be able to reproduce the exact circumstances. Script 11 is probably the same in both versions:

[0000] (70) setState(1005,0) [0007] (70) setState(1004,0) [000E] (6E) setClass(1005,[22]) [0018] (6E) setClass(1004,[22]) [0022] (43) localvar0 = 1064 [0028] (5D) while (localvar0 <= 1067) { [0032] (70) setState(localvar0,0) [0039] (6E) setClass(localvar0,[22]) [0043] (4F) localvar0++ [0046] (**) } [0049] (43) localvar0 = 0 [004F] (5D) while (localvar0 <= 7) { [0059] (5D) if (array190[localvar0]) { [0062] (70) setState(array190[localvar0],0) [006C] (47) array190[localvar0] = 0 [0075] (**) } [0075] (4F) localvar0++ [0078] (**) } [007B] (C9) kernelSetFunctions.clearCharsetMask([]) [0082] (66) stopObjectCodeB() END

So I guess something has corrupted the contents of array190, but I have no idea what.

comment:3 by sev-, 15 years ago

So probably it's only save in the world with this proble. gmarcon, may replay the game from the beginning and see if problem persists?

comment:4 by sev-, 15 years ago

Status: newpending

comment:5 by SF/sf-robot, 15 years ago

This Tracker item was closed automatically by the system. It was previously set to a Pending status, and the original submitter did not respond within 14 days (the time period specified by the administrator of this Tracker).

comment:6 by SF/sf-robot, 15 years ago

Status: pendingclosed

comment:7 by SF/gmarcon, 15 years ago

Status: closedpending

comment:8 by SF/gmarcon, 15 years ago

I restarted playing from a previous savegame and I could not reproduce the problem (I succesfully finished the game).

comment:9 by SF/sf-robot, 15 years ago

Status: pendingclosed

comment:10 by SF/sf-robot, 15 years ago

This Tracker item was closed automatically by the system. It was previously set to a Pending status, and the original submitter did not respond within 14 days (the time period specified by the administrator of this Tracker).

Note: See TracTickets for help on using tickets.