Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2059 closed defect (worksforme)

BS1: Speech doesnt play for some items near end game

Reported by: SF/hfeldman Owned by: eriktorbjorn
Priority: normal Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

Near the end of the game once on the train, a lot of the
speech no longer plays (neither do the captions) and I
get the following error printed in the console:

WARNING: Sound::uncompressSpeech(): DATA tag not
found in wave header!

I am using ScummVM 0.71 precompiled binaries for
windows XP, English Talkie version of Broken Sword 1.
Additionally it crashes in two places reproducibly - when
I talk to the old woman in the train car and ask her
about the castle, the 2nd or 3rd time it exits with no
error message anywhere. Then in the castle at the end
game, if I try to stick the pipe in the gargoyles mouth,
Nico turns to talk to me and then the program craps out
as well with no error I can find.

I've attached a save game near the start of the train
sequence.

Is it possible my speech files are just corrupt? Do you
know the correct MD5/SHA1/CRC for them?

Thanks!

Ticket imported from: #1215416. Ticket imported from: bugs/2059.

Attachments (1)

SAVEGAME.005 (995 bytes ) - added by SF/hfeldman 14 years ago.
Save game at beginning of train sequence

Download all attachments as: .zip

Change History (15)

by SF/hfeldman, 14 years ago

Attachment: SAVEGAME.005 added

Save game at beginning of train sequence

comment:1 by eriktorbjorn, 14 years ago

It certainly sounds like a problem with your data files.
Probably the speech.clu file from the second CD, or possibly
train.clu.

I only have compressed versions of the speech and music on
this computer (I'm not at home where my original CDs are) so
I can't tell you the checksum for them. And anyway, I'm told
there are a few different versions.

I'd suggest you try re-copying the data files from the CD.
It's almost certainly faster than waiting for me to get back
home and check mine. Of course, someone else may be quicker
in producing them.

comment:2 by fingolfin, 14 years ago

If that doesn't help, please tell us the MD5 of the files, and
we can check if they match any of the known versions.

comment:3 by fingolfin, 14 years ago

Status: newpending

comment:4 by SF/hfeldman, 14 years ago

Status: pendingnew

comment:5 by SF/hfeldman, 14 years ago

Here are the MD5's I get on the speech files, and the file
sizes:

2a36888b6b45cbb945dd45b1aecf02a3 *speech1.clu
3aabd273e4f4129b847ba65b0b07cb79 *speech2.clu
348,216,568 speech1.clu
339,493,006 speech2.clu

It is extremely unlikely the file was damaged after copying to
the hard drive. It is of course possible the files on the source
CD itself are damaged (ie scratched etc). Anyways, please
let me know if these file sizes and MD5 seem correct, and if
so, what else could cause the described problem. Is there a
way to disable speech and just watch the text captions?
That might be a good thing to try if its possible to give more
insight into the problem..

comment:6 by eriktorbjorn, 14 years ago

> It is extremely unlikely the file was damaged after copying to
> the hard drive.

You'd be surprised at how many bug reports that have been
resolved by re-copying the data files from the CD. I don't
understand how this happens, but it does. :-)

I've played through the game from boarding the train to the
end, talking to every character about everything I could and
examining everything I could think of. I didn't encounter
any missing speech or crashes.

I have the English "Sold-Out Software" release, and the MD5
sums of my data files are:

7072952037a5e240c868d441ca4a6da9 compacts.clu
1990da4bf81a6402884bd72c5fe7a3b2 general.clu
62337167c67fada0d0689e0e45584ac5 ireland.clu
4640fc95cc73ea2956a516f25aecd107 maps.clu
6c85a3dc5c3f7b4a3e11ac22cb183cc2 paris1.clu
db1dab88dfed88091e20aa38e968426d paris2.clu
205db4a3a86262fa93ce13cc785be0a6 paris3.clu
bfe0e1020272e9ce639981de909826c1 paris4.clu
9a78e8fc591a4f482bffca7083653361 scotland.clu
9a8aa5e562672f9d7a4fbc430d6d3576 scripts.clu
e053954d122ecbce89a58030fbcd1e40 spain.clu
2a36888b6b45cbb945dd45b1aecf02a3 speech1.clu
75ad0248c9a0a5aa65c471f459a58c71 speech2.clu
003f4dc09692592d3a8347bc84ded39f swordres.rif
2595fd92d91bbaa604a820b9bf6d20ad syria.clu
4edc865fa00933c7d7c9cf761ee3efb1 text.clu
d3df148f058f4280e6166c8649aa5a1c train.clu

(I forgot to write down the file sizes. As I said, I don't
have the uncompressed speech files on this computer.)

So it looks like we have the same speech1.clu, but not
speech2.clu.

comment:7 by fingolfin, 14 years ago

Owner: set to eriktorbjorn
Resolution: worksforme
Status: newpending

comment:8 by fingolfin, 14 years ago

Pending response by the bug submitter.

comment:9 by SF/hfeldman, 14 years ago

Status: pendingnew

comment:10 by SF/hfeldman, 14 years ago

What response are you waiting for? I posted the MD5 and
sizes of my speech files long ago. The speech1 matches
Erik's while the speech2 does not. Since you said there are
multiple version this does not mean it is necessarily bad
though. Anyways even if we determined it was corrupted,
how could I 'fix' it anyways?

comment:11 by fingolfin, 14 years ago

Waiting for you to re-check the files on your CD, in case they did get
damaged after / while being copied to your HD.

It's unlikely that a different version of BS1 has identical MD5 for the
first speech file but not for the second. This together with the nature
of the error message you were reporting strongly indicates that your
speech2.clu file has indeed been corrupted somehow. If that is the case,
there is nothing we can do about it, I am afraid.

comment:12 by SF/hfeldman, 14 years ago

The original source file is the same, so I guess it is
corrupted, and I guess I'm just screwed until I find another
copy of the CD. Thanks anyways, at least its not a bug for
you.

comment:13 by eriktorbjorn, 14 years ago

I'm closing this bug report, then.

comment:14 by eriktorbjorn, 14 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.