Opened 15 years ago

Closed 14 years ago

Last modified 13 months ago

#2060 closed defect (invalid)

ALL: hq2x / hq3x scalers with / without nasm

Reported by: eriktorbjorn Owned by: eriktorbjorn
Priority: normal Component: Graphics: Scalers
Keywords: Cc:
Game:

Description

Latest ScummVM CVS snapshot

I don't know if this is a problem with ScummVM or if
it's with my build environment, but if I build ScummVM
with MinGW and nasm the output from the hq2x and hq3x
isn't anywhere near as good as if I build it without
nasm, or if I build it with nasm on my Linux box.

The attached picture shows one of the most obvious
examples (from Sam & Max) that I've found. The images
on the left are from the Windows version, the ones on
the right from the Linux version.

If I compile ScummVM with MinGW but without nasm it
looks fine. It looks fine with our official Windows
releases/snapshots, too. Were they built with or
without nasm?

Ticket imported from: #1216262. Ticket imported from: bugs/2060.

Attachments (2)

hq-scalers.png (6.3 KB ) - added by eriktorbjorn 15 years ago.
Screenshot comparisions
hq3x-comparision.png (14.2 KB ) - added by eriktorbjorn 14 years ago.
Comparision of detail from the Sam & Max intro

Download all attachments as: .zip

Change History (20)

by eriktorbjorn, 15 years ago

Attachment: hq-scalers.png added

Screenshot comparisions

comment:1 by sev-, 15 years ago

Hmmm. Didn't run HQ scaler for a while. I will take a look
into this

comment:2 by sev-, 15 years ago

Owner: set to sev-

comment:3 by eriktorbjorn, 15 years ago

Let me know if there's any further information I could
provide. As I said, I was only able to reproduce the problem
with the version I compiled myself under Windows, so I'd be
overly optimistic if I expected you to be able to easily
reproduce the problem.

comment:4 by Kirben, 15 years ago

The Windows releases and snapshots are compiled under
MinGW, using nasm for the scalers.
NASM version 0.98.31 compiled on May 18 2002

comment:5 by sev-, 15 years ago

Owner: sev- removed

comment:6 by sev-, 15 years ago

Just looked more carefully into this. I see no difference
under FreeBSD.
NASM version 0.98.35 compiled on Sep 2 2003

comment:7 by sev-, 15 years ago

Just looked more carefully into this. I see no difference
under FreeBSD.
NASM version 0.98.35 compiled on Sep 2 2003.

Maybe you configured with --disable-hq-scalers?

comment:8 by eriktorbjorn, 15 years ago

No, I definitely didn't configure with --disable-hq-scalers.
If you look closely, you'll see that the images on the left
are smoothed, just not nearly as nicely as the ones on the
right. This is an extreme example. In the complete
screenshot, some parts (Sam's suit, the subtitles, etc.) are
nicely smoothed while some (the box, Max, etc.) aren't.

I guess I should look for a pre-built version of nasm. I
think I compiled the one I use myself. Maybe something went
wrong there, unlikely though it may seem. Or maybe it's the
oldish - "3.2.3 (mingw special 20030504-1" - version of GCC
that I'm using...

comment:9 by Kirben, 15 years ago

The nasm binary I use, is from the SDL homepage. It can be
downloaded from
http://www.libsdl.org/extras/win32/mingw32/nasm.exe

comment:10 by eriktorbjorn, 15 years ago

Changing nasm didn't make any difference.

If it only happens to me, and not to our official Windows
builds, I guess it's not a big deal.

comment:11 by eriktorbjorn, 15 years ago

I upgraded to MinGW 3.2.0-rc-3, which among other things
includes GCC 3.4.2. This made the problem go away. Closing
this bug report, since whatever the problem is it probably
isn't with ScummVM.

comment:12 by eriktorbjorn, 15 years ago

Owner: set to eriktorbjorn
Resolution: invalid
Status: newclosed

by eriktorbjorn, 14 years ago

Attachment: hq3x-comparision.png added

Comparision of detail from the Sam & Max intro

comment:13 by eriktorbjorn, 14 years ago

Resolution: invalid
Status: closednew
Summary: ALL: hq2x / hq3x scalers with MinGW + nasmALL: hq2x / hq3x scalers with / without nasm

comment:14 by eriktorbjorn, 14 years ago

Though now it happens on my "unstable" Debian box, which at
the moment is running GCC 4.0.1 plus some patches. Reopening
- at least temporarily - and attaching a new comparision.

The complete images can be found at

http://www.update.uu.se/~d91tan/IFStuff/hq3x-asm.png
http://www.update.uu.se/~d91tan/IFStuff/hq3x-soft.png

Some areas are well smoothed in both screenshots, but some
are just slightly blurred in the asm version.

comment:15 by sev-, 14 years ago

Eriktorbjorn, does it still happen?

comment:16 by eriktorbjorn, 14 years ago

Resolution: invalid
Status: newclosed

comment:17 by eriktorbjorn, 14 years ago

No, the problem seems to be gone again. Closing.

comment:18 by digitall, 13 months ago

Component: --Unset--Graphics: Scalers
Note: See TracTickets for help on using tickets.