Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2053 closed defect (fixed)

LOOM/FM-TOWNS: Crash during cutscene with Weaver Elders

Reported by: SF/celemar Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Loom

Description

In the ScummVM Win32 daily build dating from May 28,
23:23:27, there is a fatal crash in Loom FM-TOWNS.

It is easily reproduced. Once Bobbin enters the Loom
Chamber at the game's beginning, the cutscene with the
Elders and Hetchel's transfiguration starts. But when
the swan crashes through the chamber window, ScummVM
crashes with the message "ERROR: Unsupported sound
sub-type 3."

This is the English-language FM-TOWNS version, played
on a Windows XP SP2 system.

The bug did not occur as recently as the May 1,
21:41:48 Win32 daily build of ScummVM.

Ticket imported from: #1210891. Ticket imported from: bugs/2053.

Change History (4)

comment:1 by fingolfin, 14 years ago

Owner: set to Kirben
Summary: Loom FM-TOWNS: Crash during cutscene with Weaver EldersLOOM/FM-TOWNS: Crash during cutscene with Weaver Elders

comment:2 by fingolfin, 14 years ago

Previously we simply printed a warning for these unknown sub types. No
we generate an error. I guess Kirben changed it because people tend not
to report warnings, so the only way to find out if and where unknown
subtypes are used it by forcing a crash...

comment:3 by Kirben, 14 years ago

I checked the disasm. of original versions, and only types 0 -
2 were valid in FM Towns versions of indy3towns, loomtowns
and zaktowns. So I have just removed the error.

The current additional case of 255 for indy3towns doesn't look
right and only occurs in sound resource 40. I wonder if we
should be playing sound resource at all...

comment:4 by Kirben, 14 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.