Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2054 closed defect (worksforme)

FOA: Sub won't enter the airlock to Atlanis

Reported by: SF/cesken Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Indiana Jones 4

Description

Hello,

I am playing FOA (German/DOS) in TEAM mode. I am on the
sub, trying to enter the airlock. But the sub won't
enter (I have tried forward and reverse).

I am attaching a savegame, where the sub stands
*directly* before the airlock. This should make
reproducing the bug quite easy.

Chris

-----------------------------------------------------------
Technical details:
I am running scummvm 0.7.1 under Linux (SuSE9.1). I
have also scummvm 0.7.0 around, with the same
behaviour. The older scummvm Versions that I have
(0.6.x) claim they cannot read all the savegames
("invalid version").

info@home> scummvm -v
ScummVM 0.7.1 (May 26 2005 22:24:46)
Features compiled in: Vorbis FLAC MP3 ALSA zLib MPEG2

info@home> gcc -v
Reading specs from
/usr/lib/gcc-lib/i586-suse-linux/3.3.3/specs
Configured with: ../configure --enable-threads=posix
--prefix=/usr --with-local-prefix=/usr/local
--infodir=/usr/share/info --mandir=/usr/share/man
--enable-languages=c,c++,f77,objc,java,ada
--disable-checking --libdir=/usr/lib --enable-libgcj
--with-gxx-include-dir=/usr/include/g++
--with-slibdir=/lib --with-system-zlib --enable-shared
--enable-__cxa_atexit i586-suse-linux
Thread model: posix
gcc version 3.3.3 (SuSE Linux)

PS: The very old bug 639640 stated the same, but it is
just sooo old and was closed with a WORKSFORME.

Ticket imported from: #1211605. Ticket imported from: bugs/2054.

Attachments (1)

atlantis.s19 (23.2 KB ) - added by SF/cesken 14 years ago.
Savegame for the sub-does-not-enter airlock issue

Download all attachments as: .zip

Change History (8)

by SF/cesken, 14 years ago

Attachment: atlantis.s19 added

Savegame for the sub-does-not-enter airlock issue

comment:1 by SF/cesken, 14 years ago

Component: Engine: SCUMM
Game: Indiana Jones 4
Priority: normalhigh

comment:2 by fingolfin, 14 years ago

Priority: highnormal

comment:3 by fingolfin, 14 years ago

Please do not change the tracker item priorities, we'll just reset them to the
values we think are apporpriate anyway... Thanks.

comment:4 by SF/frank_m24, 14 years ago

I loaded the savegame and ths sub was far away from the
airlock. In my try it was on the right (just before the sub turns
around on the right side) in the front. I had no problem
entering it.

Several times playing FOA I had problems to enter the
airlock, but it was never a ScummVM Bug but every time
quite hard to hit the whole.

Frank

comment:5 by fingolfin, 14 years ago

Yeah indeed. My guess is that the bug reporters mistook the
little 'hole' the sub is standing in front of in this
savegame for the entrance. Which it isn't... and if you
think about it, having a tiny hole in a very tall and
extremly thin spike seems to be a (physically) unlikely
submarine entry, doesn't it? :-)

comment:6 by fingolfin, 14 years ago

Owner: set to fingolfin
Resolution: worksforme
Status: newclosed

comment:7 by SF/cesken, 14 years ago

Acknowledged - it was the "wrong airlock" I was hunting for.

But I found it really hard to navigate to the real one. I was playing
FOA on DOS/Windows (the "real" thing, non-SCUMMVM) last year
and had no problem - but there the airlock was never at that right
side, so you cannot compare this.
Sorry for bothering you with a non-exisiting bug.

Note: See TracTickets for help on using tickets.