Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#2049 closed defect

SIMON2 (Spanish): loadVOCFromStream: Invalid header!

Reported by: SF/dxreaver Owned by:
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 2

Description

WARNING: loadVOCFromStream: Invalid header!
rate effect can only handle rates < 65536!

I got this problem when the game tries to load ANY
speech. If i turn off the voices, don't happens anything.
all goes correct

The game is Simon1 talkie (spanish)

I also have Simon1 talkie in english and it works
perfectly. i noticed that Simon1 talkie english have the
voices in a .wav file instead the .voc file.

i also got this error in Simon2 talkie spanish in a few
conversations (2 or 3). I saved the file often and i
pressed alt+v for avoid that error

I am spanish and my english is not very well. I hope you
to understand me ^^

Ticket imported from: #1210390. Ticket imported from: bugs/2049.

Change History (18)

comment:1 Changed 14 years ago by Kirben

Sounds like you have a corrupt speech file in Simon1
(Spanish)..

What is the exact file size of your SIMON.VOC file ?
What is the md5 checksum of your SIMON.VOC file ?

comment:2 Changed 14 years ago by SF/dxreaver

HOW CAN I CHECK the md5 checksum of my SIMON.VOC
file ?

comment:3 Changed 14 years ago by Kirben

A Windows version of md5 can be found at
http://winmd5sum.solidblue.biz/
For other operating systems, try
http://userpages.umbc.edu/~mabzug1/cs/md5/md5.html

comment:4 Changed 14 years ago by fingolfin

Hmm, if WAV files are used, why is loadVOCFromStream even called?
Seems strange...

comment:5 Changed 14 years ago by fingolfin

Anyway, this is a duplicate of bug #1197271

comment:6 Changed 14 years ago by fingolfin

Resolution: duplicate
Status: newclosed

comment:7 Changed 14 years ago by Kirben

That WAV file comment referred to the English version of
Simon the Sorcerer 1 Talkie only.

This bug report effects the Spanish version of both Simon the
Sorcerer 1 and 2, so should not be closed.

comment:8 Changed 14 years ago by Kirben

Resolution: duplicate
Status: closednew
Summary: loadVOCFromStream: Invalid header!SIMON1/2 (Spanish): loadVOCFromStream: Invalid header!

comment:9 Changed 14 years ago by fingolfin

Beg your pardon, but the other report is about the spanish version, too,
according to the tracker comments, isn't it?

comment:10 Changed 14 years ago by Kirben

The other bug report is specifically for the Spanish version of
Simon the Sorcerer 1.

comment:11 Changed 14 years ago by fingolfin

Component: Engine: AGOSEngine: AGI
Game: Simon the Sorcerer 2Space Quest 2

comment:12 Changed 14 years ago by fingolfin

Uhm, yeah. And this reports is specifically about the
Spanish version of Simon the Sorcerer 1, too, isn't it?

comment:13 Changed 14 years ago by Kirben

No, if you read the complete bug report, you will notice the
problem is reported in the Spanish version of Simon the
Sorcerer 2 too.

comment:14 Changed 14 years ago by Kirben

Component: Engine: AGIEngine: AGOS
Game: Space Quest 2Simon the Sorcerer 2
Summary: SIMON1/2 (Spanish): loadVOCFromStream: Invalid header!SIMON2 (Spanish): loadVOCFromStream: Invalid header!

comment:15 Changed 14 years ago by fingolfin

So, this bug reports that there are VOC header problems in
SIMON 1+2 spanish. The other reports the same, but only
about SIMON 1.

I still think one of them could be closed. Oh well.

In the mean time, to debug this, I'd recommend you insert a
Common::hexdump invocation to let that suspectible header be
printed and send the user(s) involved a binary modified in
that way. Alas, that's up to you <shrug>.

Over and out.

comment:16 Changed 14 years ago by Kirben

The French, Hebrew, Italian and Spanish versions of Simon
the Sorcerer 1 are bundled on a single CD, with a single
(English) speech file included. So a difference in the VOC
header of speech file is extremely unlikey.

So I suspect the speech file is corrupt, which is why I asked
for md5 checksum and a filesize of speech file.
Or maybe a system specific issue, considering the Spanish
version of Simon the Sorcerer 2 is effected too.

dxreaver:
What operating system are you using ?

Are you playing games directly from the CD or from the hard
disk ?

comment:17 Changed 14 years ago by fingolfin

Pending response by the bug submitter.

comment:18 Changed 14 years ago by fingolfin

Status: newclosed
Note: See TracTickets for help on using tickets.