Opened 14 years ago

Closed 14 years ago

Last modified 12 months ago

#2007 closed defect

WINCE: Config file gets corrupted

Reported by: SF/animalangel Owned by: SF/arisme
Priority: high Component: Port: WinCE
Keywords: Cc:
Game:

Description

I have a Bsquare Power Handheld running Windows
CE.NET(4.1). I can get the program to run but I have to
delete the config file everytime before running the
program. If the config file exists I get an error message.

Config file Buggy: Junk found in line 16: ' '

This will continue to pop up and nees a soft reset to get
rid of the error.

I havent tried many games when it works but DOTT
seems to run really well, except it seems to create
loads of 'tentacle' files in the ScummVM root directory.
Also saved files appear in DOTT seem to be damaged.

Ticket imported from: #1189386. Ticket imported from: bugs/2007.

Change History (21)

comment:1 by fingolfin, 14 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:2 by fingolfin, 14 years ago

Owner: set to SF/arisme
Status: newpending
Summary: HandheldPC ARM - Config file BuggyWINCE: Config file gets corrupted

comment:3 by SF/animalangel, 14 years ago

Status: pendingnew

comment:4 by SF/animalangel, 14 years ago

HandheldPC ARM binary 0.7.1 - USED

FIXED DOTT SAVE FILE PROBLEM: if you make save
directory diffrent to the root e.g 'ScummVM/Saved Games'
then they will work fine.

comment:5 by SF/animalangel, 14 years ago

Still Have problem with config file

comment:6 by SF/animalangel, 14 years ago

Dp you need anymore information?

comment:7 by SF/m0tt, 14 years ago

I confirm the same/similar bug on an Ipaq 6365.

Version: v0.7.1 (March 27 2005), English language version
Platform: Windows Mobile 2003

After launching ScummVM for the first time a config file is
created. Once the program launches again it attempts to read
the config file but reports error message "Config file
Buggy: Junk found in line 3". Deleting the config file
allows the program to run successfully.

I also find that the program creates 'tentacle' files in the
root directory.

Unable at this stage to confirm whether the bug also occured
in the earlier release.

comment:8 by SF/pommes_erwin, 14 years ago

Hello,
I have the same problem with a BlueMedia BM6300 (Handheld
with WinCE .NET 4.2).
I've looked at the config file with a text editor and the
problem seems to depend on the line feed/carriage return
interpretation of the config file.
If I run dos2unix and remove all empty lines in this file
and copy it back to the device ScummVM is able to read it
(but if you end ScummVM it is broken again ...)

Hope that helps a little bit.

comment:9 by fingolfin, 14 years ago

Just to check, are all of you who experience the problem using ScummVM
0.7.1 ?

Arisme, I wonder if File::gets() could be the culprit?

comment:10 by SF/arisme, 14 years ago

I'd say either this or if it only happens for Handheld PCs a
bad stdio-wrapper implementation in missing.cpp. I'll
recheck the Handheld PC implementation to be sure.

(note : the 6365 is not an Handheld PC ... I'll review
File::gets() but I've never had the problem on my device)

comment:11 by SF/animalangel, 14 years ago

What is the status of this item?

comment:12 by SF/animalangel, 14 years ago

yes i am using ScummVM-0.7.1-HandheldPC_ARM and i get
this error

comment:13 by SF/pommes_erwin, 14 years ago

I also use scummvm-0.7.1-HandheldPC_ARM.

comment:14 by SF/pommes_erwin, 14 years ago

Hello,
Is it possible that isspace from
backends\wince\missing\missing.cpp should test for \r, \n,
\t, too?
Unfortunately I wasn't able to compile it myself ...

comment:15 by fingolfin, 14 years ago

Priority: normalhigh

comment:16 by fingolfin, 14 years ago

Arisme, did you have a chance to look into this yet?

comment:17 by SF/arisme, 14 years ago

Not yet, I'm trying to rebuild the head version but some
recent changes seem to have killed EVC 4 for good :) I'll
see what I can do ...

comment:18 by fingolfin, 14 years ago

What is the status of this item?

comment:19 by fingolfin, 14 years ago

Status: newclosed

comment:20 by SF/zmk, 14 years ago

I have the same problem too. I'm running the HPC SH3
version of 0.7.1 on a Jornada 690. If I use version 0.6.1b, the
problem does not occur.

comment:21 by digitall, 12 months ago

Component: --Unset--Port: WinCE
Note: See TracTickets for help on using tickets.