Opened 14 years ago

Closed 14 years ago

#1982 closed defect (fixed)

BASS: CD and FLOPPY: French accents displayed incorrectly

Reported by: SF/ketchup_addict Owned by: eriktorbjorn
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

Don't know if it's the same bug as the old one with the
german umlauts, so I'll re-post the information, slightly
updated:

French CD version (0.0368) and French Floppy version
(0.0348) of Beneath A Steel Sky, tested on the last
Win32 CVS build from April 2nd.

While the accents ("é", "č", etc...) are correctly
reproduced during the game, they are NOT when using
a LINC terminal ("Crédit" is spelled "Cr+dit", for
example) or when using the LINC space.

This is not the normal behaviour, as the accents are
perfectly fine in the original game (in both the floppy and
CD versions).

Ticket imported from: #1175186. Ticket imported from: bugs/1982.

Change History (12)

comment:1 by eriktorbjorn, 14 years ago

ScummVM already redefines several of the characters in the
LINC character set. Sometimes (if I remember correctly)
because the original character data looks bad, sometimes
because it's plain wrong. This is done in the
Text::patchLINCCharset() function in sky/text.cpp

It appears that currently this is primarily done for English
and German. Possibly Swedish as well. I guess a few more
could be added for French, but of course I - or whoever else
does it - would need a complete list of the wrong characters
and what they should be.

Note that such a change would change *all* occurences of,
for instance, "+" to "" in the LINC character set. I don't
remember off-hand is "+" is used anywhere where it *should*
be a "+" and not an "".

comment:2 by SF/ketchup_addict, 14 years ago

Well, I think I'll play through the whole game again, to check
which symbol should be replaced by which letter, and if it
messes with other symbols (the one that should stay).

I'll then post the complete list.

comment:3 by SF/ketchup_addict, 14 years ago

List of wrong characters so far:

+ should be
] should be
= should be

Not sure:

> should be

----------------------------------------------------------------------------------------
Seeing that these symbols ( >, +, ], and = ) aren't normally
used in LINC text it should be good. I'll make further tests
anyway since the wrong characters are also appearing in the
LINK Cyberspace, and that I supect them to appear in the
scrambled documents in LINC (before Robert manages to
decrypt them), even if replacing a "+" that should appear by
a "" wouldn't cause anything wrong since the text is pure
garbage when scrambled, but I'll check anyway.

comment:4 by SF/ketchup_addict, 14 years ago

Priority: normalblocker

comment:5 by SF/ketchup_addict, 14 years ago

Just finished the game. I can confirm that none of the wrong
characters appear elsewhere, so that replacing them should
cause no text issue.

Next, there's one more symbol: @ (should be ), and >
should definitely be .

The only places to fix these characters are the LINC terminal,
and the LINK-Space ( @, >, +, ] and = shouldn't appear
anywhere else in any part the game, but in my opinion it'd be
best to restrict the fix to these 2 places -- should be the case
if I judge by the name of the patchLINCCharset function ;) ).

comment:6 by sev-, 14 years ago

Priority: blockernormal

comment:7 by eriktorbjorn, 14 years ago

I've posted a patch to the patch tracker that might fix
this. See
https://sourceforge.net/tracker/index.php?func=detail&aid=1184666&group_id=37116&atid=418822

comment:8 by fingolfin, 14 years ago

Summary: SKY-CD and FLOPPY: French accents displayed incorrectlyBASS: CD and FLOPPY: French accents displayed incorrectly

comment:9 by fingolfin, 14 years ago

Component: Engine: Sky
Game: Beneath a Steel Sky

comment:10 by fingolfin, 14 years ago

I just commited Torbjrn's patch. Thanks Torbjrn!

Jack / ketchup_addict, could you please verify whether the
patch helps / works correctly? It should be contained in the
next daily build (i.e. tomorrow).

comment:11 by fingolfin, 14 years ago

Owner: set to eriktorbjorn

comment:12 by fingolfin, 14 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.