Opened 16 years ago

Closed 16 years ago

Last modified 14 years ago

#1975 closed defect

French SIMON1DOS: wrong text pointers

Reported by: SF/ketchup_addict Owned by: Kirben
Priority: normal Component: Engine: AGOS
Keywords: Cc:
Game: Simon the Sorcerer 1

Description

This bug has been seen with the french DOS as well as the english TALKIE versions of SIMON1.

It appears that nearly every description from the mouse pointer is wrong: for example, when you point your mouse on the dog, instead of "The Dog" the game tells you "The Rose Wood".

I did further tests, and managed to find the culprit: the GAMEPC file (which contains some TEXT that is not in the regular TEXT files). For example if I change this GAMEPC by any of the ones from the English versions, the descriptions are OK.

My idea is that maybe SCUMMVM is using wrong pointers for the text, basing all on the ENGLISH versions.

I've tested this on the last stable 0.7.0 Win32 version, as well as on the last WIN32 0.8.0CVS (Mar 28 2005 09:54:16).

If it helps, here's the log when launching the game:

"Looking for simon1dos Trying to start game 'Simon the Sorcerer 1 (DOS)' bed9134804d96f72afa152b8ec5628c3 GAMEPC Match found in database: target simon1dos, language French, platform DOS"

Ticket imported from: #1172021. Ticket imported from: bugs/1975.

Attachments (1)

original.png (45.1 KB ) - added by Kirben 16 years ago.
Screenshot from original game

Download all attachments as: .zip

Change History (21)

comment:1 by Kirben, 16 years ago

I can't reproduce the issue with English version of Simon the Sorcerer 1 (DOS or Windows) under ScummVM.

The issue with French version is a bug in the original game, the French translation was quite buggy.

comment:2 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: invalid
Status: newclosed

comment:3 by SF/ketchup_addict, 16 years ago

My bad, I've made a mistake; instead of "This bug has been seen with the french DOS as well as the english TALKIE versions of SIMON1" I should have typed "this bug has been seen with ScummVM 0.7.0 and the last 0.8.0CVS".

Of course, the bug occurs only in the French version, and isn't the normal/original behaviour of the game (no bug in the original version, as I tested it myself, and I don't recall the translation being buggy).

comment:4 by SF/ketchup_addict, 16 years ago

Priority: normalblocker
Status: closednew

by Kirben, 16 years ago

Attachment: original.png added

Screenshot from original game

comment:5 by Kirben, 16 years ago

The wrong dog description example you gave for the French version of Simon the Sorcerer 1, occurs in the original game too. See the attached screenshot.

comment:6 by Kirben, 16 years ago

Priority: blockernormal
Status: newclosed

comment:7 by SF/ketchup_addict, 16 years ago

To process your bug report appropriately, we need you to provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build) * Bug details, including instructions on reproducing it * Language of game (English, German, ...) * Version of game (talkie, floppy, ...) * Platform and Compiler (Win32, Linux, MacOS, ...) * Attach a save game if possible * If this bug only occurred recently, please note the last version without the bug, and the first version including the bug. That way we can fix it quicker by looking at the changes made.

This should only take you a little time but will make it much easier for us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:8 by SF/ketchup_addict, 16 years ago

I've seen that there is another topic about that bug in the Closed section -- my bad for not having posted there back then. :(

Anyway:

Indeed, this bug occurs on any of the 3 french versions I've downloaded yet, but NOT on the version I have bought years ago (same SIMON DOS, french, on floppy discs, excepted the bug wasn't there and everything was perfectly translated).

I'll try to get my hands on these old floppies of mine, and check the differences between the files (my bet is there are several versions of the GAMEPC file -- maybe one's a hack or something...)

comment:9 by SF/ketchup_addict, 16 years ago

Priority: normalblocker
Status: closednew

comment:10 by SF/ketchup_addict, 16 years ago

To process your bug report appropriately, we need you to provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build) * Bug details, including instructions on reproducing it * Language of game (English, German, ...) * Version of game (talkie, floppy, ...) * Platform and Compiler (Win32, Linux, MacOS, ...) * Attach a save game if possible * If this bug only occurred recently, please note the last version without the bug, and the first version including the bug. That way we can fix it quicker by looking at the changes made.

This should only take you a little time but will make it much easier for us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:11 by SF/ketchup_addict, 16 years ago

OK, I've managed to find these old floppies I was talking about; indeed, the GAMEPC file is different (ScummVM 0.8.0CVS doesn't recognize it) and the texts are FINE.

However, the game protection is still valid (I suppose ScummVM uses a hack to bypass the protection of the other versions -- unless it's the same as for the SCUMM games, the crack is already included in the interpreter of older versions).

Now, onto the infos:

ID: simon1dos (when adding the game, ScummVM proposes to choose between DOS and Talkie)

MD5 of the GAMEPC file: b6cfe7449a32418ed523bde22f5125ed

Platform: DOS

Language: French

comment:12 by SF/ketchup_addict, 16 years ago

After extended searches, I managed to find the culprit: it was not GAMEPC, but TABLES05.

Replacing this file by the other one (the one from the version recognized by ScummVM) bypasses the protection... but messes with the text. :P

I'll do other searches and report it here if I find something worthy of a report.

comment:13 by SF/ketchup_addict, 16 years ago

To process your bug report appropriately, we need you to provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build) * Bug details, including instructions on reproducing it * Language of game (English, German, ...) * Version of game (talkie, floppy, ...) * Platform and Compiler (Win32, Linux, MacOS, ...) * Attach a save game if possible * If this bug only occurred recently, please note the last version without the bug, and the first version including the bug. That way we can fix it quicker by looking at the changes made.

This should only take you a little time but will make it much easier for us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:14 by Kirben, 16 years ago

Priority: blockernormal
Status: newclosed

comment:15 by Kirben, 16 years ago

I added the addiotnal md5 details to ScummVM.

The bug still occurs in original game, so closing again. That French version of Simon the Sorcerer 1 sounds like a hacked version, especially since it bypasses the copy protection.

We only bypass copy protection in ScummVM, if a game was later re-released without the copy protection. The non- talkie versions of Simon the Sorcerer 1 and 2 always had the copy protection enabled.

comment:16 by SF/ketchup_addict, 16 years ago

The bug occurs in the original game (read: not cracked) of Simon1DOS (french)?

Thanks for this information, because it shows that the copies I found on the web must all have been this original version (with the bug), but cracked to remove the copy protection (while I previously thought it was the crack that make the bug appearing).

Anyway, and just in case, here are more informations about the differences between these versions, compared to the legit french floppy version (without the bug) I possess:

1) *.VGA and *.MUS are the same for both versions. 2) Cracked version: the timestamp on the files shows 1993. Legit version: timestamp shows 1994. 3) GAMEPC is different (like previously stated, so I won't talk about it further). 4) Nearly all TABLES* are different.

Sadly I can't compare with the legit buggy version since I don't have it, but I hope this helps.

One suggestion, though: why not make ScummVM check the CRCs (or MD5, or whatever) of ALL the required files (and not only the canonical "first" file) when adding a game for the first time? This way, it'd be better to identify alternative versions (because I believe it could happen that alternative versions may use the same canonical file and that only other files are changed from a version to another).

One last thing (I know it doesn't fit in this topic, but I may always ask): Is a "vertical synchronisation" feature planned for future releases of ScummVM? I'm asking this because my monitor is limited to 60Hz, and that I got screen tearing in every game. :/

comment:17 by SF/ketchup_addict, 16 years ago

Resolution: invalid

comment:18 by Kirben, 15 years ago

No, I meant the text bugs were specific to the cracked version of Simon the Sorcerer 1 (French). We will not support any cracked versions.

Checking the md5 checksum of all files would cause too much disk access and be too slow on some ports I expect.. Corrupt files aren't very common, although cracked versions are too common.

Monitor synchronisation is controlled by the operating system, not ScummVM. So I can only suggest you check the settings for your video card.

comment:19 by fingolfin, 15 years ago

Component: Engine: AGOSEngine: AGI
Game: Simon the Sorcerer 1Space Quest 1

comment:20 by Kirben, 14 years ago

Component: Engine: AGIEngine: AGOS
Game: Space Quest 1Simon the Sorcerer 1
Note: See TracTickets for help on using tickets.