Opened 16 years ago

Closed 16 years ago

Last modified 2 years ago

#1974 closed defect (wontfix)

GUI: graphics filter is overridden with GUI displayed at 3x

Reported by: SF/jellby Owned by:
Priority: normal Component: GUI
Keywords: Cc:
Game:

Description

ScummVM 0.8.0CVS (Mar 26 2005 17:06:13) Features compiled in: Vorbis FLAC MP3 ALSA zLib MPEG2

Start a classic scumm game like monkey at 3x size. Choose any graphics filter you want (only 3 to choose from at this size, I guess), and then press <space> several times. When the message is displayed the game graphics change, as if a different filter was in use, and it's none of the three (but it's closer to advmame3x).

I assume this is an effect of the GUI being defined with a different resolution than the game. This effect is not important at all, maybe just a curiosity, but I thought it was worth reporting it, in case it had been unnoticed.

Ticket imported from: #1171063. Ticket imported from: bugs/1974.

Change History (3)

comment:1 by sev-, 16 years ago

Resolution: wontfix
Status: newclosed

comment:2 by sev-, 16 years ago

Yes, this is known behaviour. And you correctly understood that it is caused by bigger GUI. I.e. at 3x mode GUI, which is 640x400 should be scaled 1.5x. It uses AdvMame to stretch game surface to 2x then draws GUI on top of it and finally apples 1.5x scaler.

GUI is in progress of improvements (see thumbnails patch in our tracker) and eventually all widgets will benefit from bigger resolution.

Please, be patient with us.

comment:3 by digitall, 2 years ago

Component: --Unset--GUI
Note: See TracTickets for help on using tickets.