Opened 15 years ago

Closed 14 years ago

Last modified 7 years ago

#1969 closed defect (worksforme)

TOOLS: compress_scumm_bun crashes on COMI

Reported by: SF/jellby Owned by: aquadran
Priority: normal Component: Tools
Keywords: Cc:
Game:

Description

I'm compressing a Spanish version of COMI, "compress_scumm_bun
VOXDISK2.bun . compressed --ogg" segfaults at this point:

--------------------------------
Abriendo con el módulo wav: WAV file reader
Codificando "compressed/LXSO364.IMX_reg000.wav" a
"compressed/LXSO364.IMX_reg000.ogg"
con calidad 0,00
[ 95,0%] [quedan 0m00s ] -

Codificación del fichero finalizada "compressed/LXSO364.
IMX_reg000.ogg"

Longitud del fichero: 0m 03,0s
Tiempo consumido: 0m 00,1s
Tasa: 36,8984
Tasa de bits media: 34,0 kb/s

Segmentation fault
--------------------------------
(sorry, Spanish messages, I guess they are understandable
anyway)

md5 of VOXDISK2.bun: c61eac03bd3671c3d353e948ee0d3076

Ticket imported from: #1168378. Ticket imported from: bugs/1969.

Attachments (1)

compress_scumm_bun.check.patch (1.5 KB ) - added by SF/jellby 15 years ago.
patch for debugging compress_scumm_bun

Download all attachments as: .zip

Change History (15)

comment:1 by fingolfin, 15 years ago

Owner: set to aquadran
Summary: compress_scumm_bun crashes on COMITOOLS: compress_scumm_bun crashes on COMI

by SF/jellby, 15 years ago

patch for debugging compress_scumm_bun

comment:2 by SF/jellby, 15 years ago

By the way, it crashes with mp3 or ogg compression.

With the attached patch the processing is quicker (the actual compression
is skipped) and this is the output before the segfault:

--------------------------------
start loop: 3022/4675
start loop: 0/14
* firstWord: 508
start loop: 1/14
* firstWord: -6829
Segmentation fault
---------------------------------

The first loop (3022/4675) refers to the i < numFiles loop in main{}, while 0/
14 and 1/14 are the i < numCompItems loop in decompressBundleSound{}.

I have no idea what should happen here, but I hope this can be useful to
identify the problem... Any more tests I could do? Any ideas?

comment:3 by aquadran, 15 years ago

it's rather not compression error, but comi decompression
codec error. and it's look like damaged bundle file, are you
sure that file is correct ?

comment:4 by SF/jellby, 15 years ago

Well, the file on the CD has the same md5, and there are no read errors. I
played the whole game with this file and I didn't find any crash or problem
that could be related to this... but maybe I never used the "offending"
dialogue line.

Is the "correct" md5 for the Spanish VOXDISK2.BUN available
somewhere?

comment:5 by fingolfin, 14 years ago

What is the status of this item?

comment:6 by fingolfin, 14 years ago

Status: newpending

comment:7 by SF/jellby, 14 years ago

Status: pendingnew

comment:8 by SF/jellby, 14 years ago

I'm still getting the same error at the same place, although now --ogg
defaults to quality 3. Tools updated from CVS just today (june 18th).

comment:9 by aquadran, 14 years ago

Resolution: worksforme
Status: newclosed

comment:10 by SF/jellby, 14 years ago

I've noticed this bug has been closed as "works for me". Does that mean
someone has been able to compress the Spanish voxdisk2.bun? What
was the MD5? Would it be possible to "fix" my version if it happens to be
corrupt?

comment:11 by aquadran, 14 years ago

yes, i did compress spanish version without any problems

comment:12 by SF/jellby, 14 years ago

And is the md5 checksum for your version the same as mine
(c61eac03bd3671c3d353e948ee0d3076)?

If it is, what's your system? Which gcc version are you using (if you're
using gcc)? Mine, it's a Mandriva LE2005 with gcc-3.4.3-7mdk.

If it isn't, could you please contact me (jellbyATyahooDOTcom) and see if
we can find where the difference is?

P.S. I assure you I have a 100% legal, purchased in a store, version of
COMI (it's the "Monkey Island Saga" bundle, which includes 1, 2 and 3). But
I guess if you fear I have a pirated copy, no "proof" I could give you would
be enough.

comment:13 by SF/jellby, 7 years ago

I'm sorry to bring this back, but I'm still having the problem.

Maybe there are different versions of the VOXDISK2.BUN file? The fact is I can't compress my legal copy of COMI, and compress_scumm_bun segfaults (which any good program should never do).

Couldn't anyone help me find a workaround or what the problem is?

comment:14 by SF/jellby, 7 years ago

Well, just for the record, I had to search for another copy of the game, which had a VOXDISK2.BUN file with a different checksum:

4d3d26690c639fb966dd0b8a2ddc0258

This one works fine.

Note: See TracTickets for help on using tickets.