Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1899 closed defect (duplicate)

BASS: Lock up when talking to the gardner

Reported by: SF/sndirsch Owned by: lavosspawn
Priority: normal Component: Engine: Sky
Keywords: Cc:
Game: Beneath a Steel Sky

Description

scummvm-0.6.1b
BASS-20030801

game locks up when you talk to the gardner, you have to
restore a game to continue

* How to reproduce:
- unpack the attached savegame tarball
- start scummvm/BASS
- press f5 to access file menu
- restore game 7
- talk to the gardner

Ticket imported from: #1106347. Ticket imported from: bugs/1899.

Attachments (1)

sky-saved-games.tar.bz2 (121.1 KB ) - added by SF/sndirsch 15 years ago.
savegames tarball - another try

Download all attachments as: .zip

Change History (27)

comment:1 by SF/sndirsch, 15 years ago

Still happens with scummvm 0.7.

comment:2 by fingolfin, 15 years ago

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 by fingolfin, 15 years ago

Status: newpending
Summary: BASS locks upBASS: lock up wen talking to the gardner

comment:4 by SF/sndirsch, 15 years ago

Status: pendingnew
Summary: BASS: lock up wen talking to the gardnerBASS: lock up when talking to the gardner

comment:5 by SF/sndirsch, 15 years ago

scummvm version: 0.6.1b + 0.7
bug details: already reported
language: english
game version: floppy
platform/Compiler: Linux / gcc 3.3.4
save game: already attached

comment:6 by eriktorbjorn, 15 years ago

Sounds similar to this bug in the BASS bug tracker:

https://sourceforge.net/tracker/index.php?func=detail&aid=1097997&group_id=37116&atid=574223

comment:7 by SF/sndirsch, 15 years ago

Maybe one of the developpers can simply try to reproduce the
problem with the attached savegame tarball?

comment:8 by SF/sndirsch, 15 years ago

Looks like creating attachments does not work with this
bugtracker. :-((((

Error message:
"Tracker Item: Nothing Changed - Update Cancelled"

by SF/sndirsch, 15 years ago

Attachment: sky-saved-games.tar.bz2 added

savegames tarball - another try

comment:9 by SF/sndirsch, 15 years ago

Finally managed to attach the savegames tarball.

comment:10 by fingolfin, 15 years ago

Component: Engine: Sky
Game: Beneath a Steel Sky
Summary: BASS: lock up when talking to the gardnerLock up when talking to the gardner

comment:11 by fingolfin, 15 years ago

Moving this to the BASS bug tracker.

comment:12 by SF/sndirsch, 15 years ago

> Moving this to the BASS bug tracker.
Ok. Can I see somewhere the progress or is the BASS bug
tracker closed for non-developpers?

comment:13 by eriktorbjorn, 15 years ago

The BASS bug tracker can be reached through the "Click here
for the Beneath a Steel Sky bug list" from the ScummVM bugs
page, if that's what you mean.

comment:14 by SF/sndirsch, 15 years ago

Ah ... that's simply another component. It sounded to me that this
is a complete different Bugtracking tool.

comment:15 by fingolfin, 15 years ago

Summary: Lock up when talking to the gardnerBASS: Lock up when talking to the gardner

comment:16 by fingolfin, 15 years ago

Component: Engine: Sky
Game: Beneath a Steel Sky

comment:17 by fingolfin, 15 years ago

Owner: set to lavosspawn

comment:18 by fingolfin, 15 years ago

Could this be related to bug #1097997 ?

comment:19 by SF/sndirsch, 15 years ago

> Could this be related to bug #1097997 ?

Unfortunately I cannot say, since I cannot reload the savegame of
this bugreport although I compiled the current daily snapshot
20050604.

"The savegame was created by Beneath a Steel Sky v0.0368
It cannot be loadey by this version (v0.0348)."

comment:20 by SF/sndirsch, 15 years ago

Oops. My BASS version is to old. Not scummvm ...

comment:21 by SF/sndirsch, 15 years ago

Looks like there is no newer floppy version avaiable. I'll try the CD
version now.

comment:22 by SF/sndirsch, 15 years ago

Loading savegame works now with CD version. Yes, I would say
that it's exactly the same problem as in #1097997.

comment:23 by fingolfin, 15 years ago

OK, then I am closing this as a duplicate of #1106347 (which is the older
bug report and was made using a newer version of ScummVM). Thanks for
the feedback, we'll track this issue on the other item.

comment:24 by fingolfin, 15 years ago

Resolution: duplicate
Status: newclosed

comment:25 by SF/sndirsch, 15 years ago

Ok. BTW, as you could read in my comment of

Date: 2005-06-05 14:02

I verified that this problem still happens with scummvm 20050604
(daily snapshot).

comment:26 by fingolfin, 15 years ago

To clarify this: There were a total of apparently similar bug reports.
- #1106347
- #1166890
- #1097997

I only leave #1097997 open, as it is the oldest of the three.
Please add any further information to that bug report only.

Note: See TracTickets for help on using tickets.