Opened 15 years ago

Closed 15 years ago

Last modified 6 years ago

#1890 closed defect (fixed)

DIG/FT: Crash, possibly due to lack of sound

Reported by: SF/jellby Owned by: aquadran
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

I have two systems with Mandrake 10.1, one of them has a soundcard, the
other one has not (actually, it has, but it's still unrecognized). I'm using a
CVS version of ScummVM (7-jan-2005).

The system with soundcard seems to work fine. In the system without
soundcard ScummVM crashes early in the intro of "The Dig" (when the
green computer display appears) and "Full Throttle" (while the Lucasarts
logo is still shown). If I try to escape the intro, the same crash happens (it
just says "Fatal signal: Segmentation Fault (SDL Parachute Deployed)".

This happens even if I use the "-enull" option when starting scummvm,
and I always get a "/dev/dsp: No such file or directory" message, and
sometimes: "WARNING: Sound mixer initialization failed!"

Ticket imported from: #1099518. Ticket imported from: bugs/1890.

Change History (6)

comment:1 by fingolfin, 15 years ago

Owner: set to aquadran
Summary: Early crash in "dig" and "ft", possibly due to lack of soundDIG/FT: Crash, possibly due to lack of sound

comment:2 by fingolfin, 15 years ago

-e null is only for MIDI music, and has nothing to do with the
digital audio used by FT and The Dig.

Possible reason: the code doesn't check whether the mixer is
"ready" (by calling g_mixer->isReady() ) and hence starts queuing
audio data, which never is consumed, since the mixer is not
running. A crash then is the result.

comment:3 by fingolfin, 15 years ago

Priority: normalhigh

comment:4 by aquadran, 15 years ago

Resolution: fixed
Status: newclosed

comment:5 by aquadran, 15 years ago

it was propably caused by out of memory. freeing memory was
when g_mixer->isReady() is true.

comment:6 by Strangerke, 6 years ago

Component: --Unset--Engine: SCUMM
Note: See TracTickets for help on using tickets.