Opened 15 years ago

Closed 15 years ago

Last modified 10 years ago

#1832 closed defect (worksforme)

BS1: Distorted Fullscreen Image

Reported by: SF/magnushult Owned by: fingolfin
Priority: normal Component: Engine: Sword1
Keywords: Cc:
Game: Broken Sword 1

Description

When viewing Broken Sword 1 in fullscreen mode, the
image is heavily distorted. Due to some sort of
alignment error, the image is skewed. The image is
divided into small "tiles" and the graphic inside a
tile looks correct, but the tiles are misaligned.
Besides, most of the tiles contain parts of the image
of my desktop, not of the game. The image is distorted
both during videos and in the game itself.

I would attach a screenshot to clarify the error, but
every screenshot I grab looks correct.

The game works excellent in windowed mode. I also tried
Day of the Tentacle, which runs perfectly well in
fullscreen.

I run the game on X under Debian unstable with Gnome,
and scummvm -v says
ScummVM 0.6.1b (Aug 6 2004 12:49:49)
Features compiled in: Vorbis MP3 ALSA zLib MPEG2

My graphics card is a Radeon 9200 SE with the fglrx
drivers from ATI.

Ticket imported from: #1074614. Ticket imported from: bugs/1832.

Change History (6)

comment:1 by fingolfin, 15 years ago

Sounds a lot like a problem with your setup, as the problem is not
reproducible elsewhere; it is further supported by the fact that your
screenshots all end up right, indicating that ScummVM doesn't do
anything wrong with the graphics buffer.

Try using another GFX driver, maybe the ATI one is buggy...

comment:2 by SF/evil_penguin, 15 years ago

I think that fingolfin may be right, suspecting the ATI
fglrx drivers.

Could you try reproducing this with the vesa or radeon (DRI)
XFree86 drivers?

Also, what fglrx version are you using?

(I don't currently have a machine with fglrx handy, but this
machine is running a very similar setup other than graphics
card + driver, and I have no issues.)

comment:3 by lavosspawn, 15 years ago

The BS1 graphics aren't tile-based at all, and the engine
doesn't even know if it's running in a window or fullscreen, so
this is certainly not a BS1 related error.
I'd assume that DOTT works fine because it's running in a
320x240 resolution instead of 640x480 as BS1 does.

comment:4 by lavosspawn, 15 years ago

The BS1 graphics aren't tile-based at all, and the engine
doesn't even know if it's running in a window or fullscreen, so
this is certainly not a BS1 related error.
I'd assume that DOTT works fine because it's running in a
320x240 resolution instead of 640x480 as BS1 does.

comment:5 by fingolfin, 15 years ago

Resolution: worksforme
Status: newclosed

comment:6 by Kirben, 10 years ago

Owner: set to fingolfin
Note: See TracTickets for help on using tickets.