Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#1831 closed defect (fixed)

DOTT/Disk: Can't get teeth (reopen 576884)

Reported by: SF/dnloreto Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: script Cc:
Game: Day of the Tentacle

Description

Hi!

I have the same teeth problem mentioned on 576884 but I
can't (or don't know how to) reopen the bug. If I start
a game from scratch and go directly to teeth section I
can trap it and pick it up. But I was doing a regular
play and now I can't get the teeth.

Attached is a savegame where Bernard is next to the
teeth and can't pick them up.

Using 0.6.1b compiled from source in Gentoo Linux on a
x86 machine with gcc-3.4.3. Note that I have zlib
compiled in so I think the savegame is compressed (for
what I was told in IRC). DOTT is the English US PC version.

Please contact me (happyguy_pt AT hotmail . com) if it
can help (please place SCUMMVM on the subject).

Thank you for your time and making scummvm that allows
me to replay games I loved!

Duarte "HappyGuy" Loreto

Ticket imported from: #1074444. Ticket imported from: bugs/1831.

Attachments (1)

tentacle.s07 (15.6 KB ) - added by SF/dnloreto 15 years ago.
Bernard next to the teeth

Download all attachments as: .zip

Change History (19)

by SF/dnloreto, 15 years ago

Attachment: tentacle.s07 added

Bernard next to the teeth

comment:1 by Kirben, 15 years ago

Summary: Can't get teeth (reopen 576884)DOTT: Can't get teeth (reopen 576884)

comment:2 by eriktorbjorn, 15 years ago

CD (talkie) or floppy (non-talkie) version? (The savegame
doesn't work at all for me, andI have the CD version of the
game.)

comment:3 by SF/dnloreto, 15 years ago

Floppy version (they don't talk, only text is written on
screen). Sorry not to say it before but I dodn't know it was
important.
I can provide an 8Mb zip of the game, in case you have the
original CD (if this does not represent an unlawful act -
not sure).

comment:4 by eriktorbjorn, 15 years ago

That'd probably be unlawful, yes. But there's got to be some
other developer who does have the floppy version.

comment:5 by SF/tobybear, 15 years ago

Hi!
I have the English disk version of DOTT and I could load
your savegame without problems. I can't pick up the teeth
either, tested with latest stable and CVS. Bernard says that
there is a grating with chattering teeth inside when I look
at it, but there is no hotspot for the "teeth", only for the
grating. Trying to pick up the grating makes the metallic
sound of the grating closing, but nothing else. Opening and
closing the grating works.

Cheers

Toby

comment:6 by fingolfin, 15 years ago

So, if you open the grating instead (to release the teeth) then
catch them again and then try to pick 'em up -- does that work?
Or is there really no way other than restarting the game to get
at those teeth?

Anyway: It appears that this problem only occurs with the floppy
version of DOTT. Since I don't have that, I have no way to look
into this. Most probably, it's a script bug in that release of
DOTT, i.e. I doubt that it is a bug in ScummVM.

Of course, we could try to add a workaround for this bug anyway,
like we did with so many other bugs in the original game in the
past; but to do that, I'd need the original floppy version of
DOTT (legally, please don't offer to send me an illegal copy,
even if your intentions may be pure :-).

Maybe some other dev owns that game and can look into it; maybe
some day I'll own the floppy version and can look into it myself.

comment:7 by SF/tobybear, 15 years ago

You can open and close the grating, nothing happens, the
teeth are always trapped inside the grating, Bernard sees
them, but can't interact with them. Leaving the room and
re-entering also doesn't help. Maybe someday I could try to
look into this problem (I also think it is a script bug),
but right now my time is too limited.

Cheers

Toby

comment:8 by SF/khalek, 15 years ago

Just played the cd version from start to finish and did not
see this at all.

comment:9 by SF/matthewdaly, 15 years ago

I just played the CD version with 0.7.1 and encountered the
problem just as tobybear describes it. Then I restored a
new game and headed straight for that room to try to get the
teeth immediately and was able to get it. I have tried to
replicate the error, but have not yet been successful, so I
don't know quite what the trigger is.

comment:10 by fingolfin, 15 years ago

You reproduced the problem with the CD version? Wow, that's strange. Did
you make a savegame after the problem occured? If so, please attach it.

comment:11 by SF/matthewdaly, 15 years ago

I'm so sorry. I did have a savegame, but I overwrote it
after seeing the remarks here that made me hope that
restarting would give me a chance to not have the problem
recur.

The gamestate didn't seem remarkably interesting to me,
since it was just like the "normal" state where you catch
the teeth except that the "trapped teeth" item was not drawn
or hotspotted. Bernard reacted to the grate by saying that
there were teeth there and nothing made them jump back out
and back into the bin. I assumed that seeing the broken
state wasn't important compared with figuring out what I did
to get into it in the first place.

I'll give it a few more shots to see if I can recreate the
state.

comment:12 by SF/chucky2, 14 years ago

I had the same problem, but here is some workaround to continue
playing:
In the party room with the teeth in the gutter do:
- Press Ctrl+D to start the debug console
- type: object 182 pickup
- type: exit

Now you have the teeth. It is a bit ugly that they are also still lying in the
sink, but at least you can continue playing. Enjoy it.

PS: Thanks for this extraordinary and beautiful system enabling us to
play those old cute games with even smoother than with the original!
Thanks a lot!

comment:13 by fingolfin, 14 years ago

Summary: DOTT: Can't get teeth (reopen 576884)DOTT/disk: Can't get teeth (reopen 576884)

comment:14 by fingolfin, 14 years ago

Summary: DOTT/disk: Can't get teeth (reopen 576884)DOTT/Disk: Can't get teeth (reopen 576884)

comment:15 by fingolfin, 14 years ago

I now have the Floppy version of DOTT. I see the problem in
the attached savegame, but am not sure what is causing it.
At least at a first glance, the relevant scripts seem
identical, too.

Maybe this is some kind of subtle object layering bug, but
w/o a good way to reproduce the issue, it's hard to say... I
tried to reproduce it using some of my own savegames, but
that didn't work.

comment:16 by fingolfin, 14 years ago

Status: newclosed

comment:17 by fingolfin, 14 years ago

Owner: set to fingolfin
Resolution: fixed

comment:18 by fingolfin, 14 years ago

I still don't quite know what is/was causing the bug, but
the problem turned out to be that object 182 (the "teeth
object" you can pick up; the teeth themselves, BTW, are
actor 6) had class bit 32 set, which means that they can't
be picked up. Normally, when you trap the teeth, that bit is
cleared, so you can take them. For unknown reasons, that
didn't happen here.

I added a workaround to CVS which checks bitvar69, which is
set if and only if the teeth are supposed to be trapped and
ready to be taken. It works well enough for me on the
savegame attached here, and should be safe in all other
cases, too (I did some testing but found no problems).

Note: See TracTickets for help on using tickets.