Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1826 closed defect

DOTT: Hang after entering the copy protection code (PALM)

Reported by: SF/alexejv Owned by: SF/chrilith
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Day of the Tentacle

Description

Palm ScummVM, in both 0.6.1b and 0.7.0 (test),
English/PC

Hangs (no VM crash) after entering right baterry plan
proportions. If wrong props, then o.k. no hanging. In
windows version of ScummVM everything o.k.
Tried in various seqs, all the same.

Ticket imported from: #1067648. Ticket imported from: bugs/1826.

Change History (18)

comment:1 by sev-, 15 years ago

Summary: Hangs after entering the copy protection code (PALM)DOTT: Hang after entering the copy protection code (PALM)

comment:2 by fingolfin, 15 years ago

Owner: set to SF/chrilith

comment:3 by SF/chrilith, 15 years ago

I don't have this problem.
Can you tell me :

- what version of the game you are using
- what device you are using
- what is the amount of free memory using the memory panel
from scummvm for palmos

thanks

comment:4 by fingolfin, 15 years ago

Status: newpending

comment:5 by fingolfin, 15 years ago

Alexei Vinogradov, we are awaiting your response.

comment:6 by SF/alexejv, 15 years ago

Sorry. Had forgot to answer. It was

- CD-Version English of DOTT
- Pam Tungsten E
- i ve already cleaned the game up :(, cant say...

comment:7 by SF/alexejv, 15 years ago

Status: pendingnew

comment:8 by fingolfin, 15 years ago

Did you try this out on your PC, too? That is, does the problem only
occur on your Palm, or also at your windows/linux/whatever PC ?

comment:9 by SF/alexejv, 15 years ago

Yes, everything all right on PC.
I have read some russian forums, and they have the same
problems (on Palm only, i think Zire 72 or so), so i thought it
could be a common problem.

comment:10 by SF/chrilith, 15 years ago

I think this is a memory issue, i'll compile a new version based
on lastest CVS, and a one with lower memory requirement.

comment:11 by fingolfin, 15 years ago

Any news on this?

comment:12 by SF/chrilith, 15 years ago

Well, didn't have my answer on the free memory.

I have uploaded a branch-0.7.0 snapshot here :
http://capers.free.fr/ScummVM/download/0-7-0.zip

Can you try this new version and let me know if you still have
the problem, there is 2 versions of the scumm engine can you
try them both ?

Then can you tell me :

- if you were using the new modular version or the older one
- what screen mode you were using (if "flipping" try "buffered"
and you may have a system error message instead of just a
freeze)

But if this was a memory problem this v0.7.0 will not help
since there are some addition that use more memory now
(Wiz object and new about dialog).

comment:13 by fingolfin, 15 years ago

Status: newclosed

comment:14 by fingolfin, 15 years ago

W/o assistance by the bug submitter, I am afraid we won't be
able to do anything about this report...

Pending...

comment:15 by SF/malegretti, 15 years ago

Hi, I'm having the same problem as Alexei. My hardware is a
Tunsgten E too, DOTT english version, ScummVM version
0.7.0 (Dec 23 2004). The memory tab reads 1911 free
dynamic memory of a 2048 total, and 12769 storage of a
29503 total.

Haven't tried both versions of the engine, will try later today
and then I submit the results here. Should I try with the
2005-01-03 test version, too?

Just detailing the error a little bit... the copy protection
screen comes up, then I enter the correct proportions. The
yellow message from the doctor is displayed, but then
ScummVM hangs (with the copy protection screen still
displayed), the only solution being a soft reset.

I have Monkey Island 2 and Fate of Atlantis installed on the
same machine, running fine so far.

Thanks in advance,
Alegretti

comment:16 by SF/chrilith, 15 years ago

Yes, please try the lastest test version too, this one will give
you engine startup memory too

Thanks

comment:17 by SF/malegretti, 15 years ago

Hi there.
Well, I've tried with the 0.7.0 engine from the zip file
suggested on a previous post (although I believe it was the
same version I used before, downloaded from the home
page), and with the latest test available on the home page,
with this results:

- 0.7.0: the problem remains exactly the same
- latest test (2005-01-03): now shows the available startup
memory, 1832 on my case, but then hangs on a black screen
soon after (game doesn't even load).

Any more tests I could do to help?

Thanks,
Alegretti

comment:18 by SF/malegretti, 15 years ago

Hi,
I've seen this bug has been closed, any solution I have
missed?

Note: See TracTickets for help on using tickets.