Opened 15 years ago

Closed 9 years ago

#1817 closed defect (fixed)

MI FM-TOWNS: No text on maps

Reported by: SF/typhon666 Owned by: athrxx
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 1

Description

ScummVM version: ScummVM 0.7.0CVS (Oct 27 2004 00:23:28)
Game: Monkey Island 1 FM-Towns-version
Language: English
Platform: Win32

When I take a look at the map for the forest or the map
how to reach Monkey Island, no text is shown. In the
PC-version this problem doesn't exist, only on FM-Towns.

This bug makes the FM-Towns-version practically
uncompletable without a walkthrough.

You can easily reproduce this bug by using boot-param
2221. You will be on the ship. Then use commands "look
at map" (8th item in invenory) and "look at piece of
paper" (12th item).

Ticket imported from: #1055391. Ticket imported from: bugs/1817.

Change History (20)

comment:1 by SF/typhon666, 15 years ago

Priority: normalhigh

comment:2 by sev-, 15 years ago

Please, do not play with priority settings.

comment:3 by sev-, 15 years ago

Priority: highlow

comment:4 by SF/typhon666, 15 years ago

I'm sorry. I though the user who submits the bug also has to
estimate the priority.
But you chose 1? Isn't this rather low for a bug that makes
a version of a (officially supported) game basically
uncompletable?

comment:5 by sev-, 15 years ago

I set it to 1 because the game is extremely rare. Only few
devteam members have it to test, and not too much people
could get it as well. I have no idea when this bug will be
addressed, but it will not happen soon, as this bug is very
obvious but still wasn't resolved.

Basically it will stay here as a reminder when somebody will
manage to devote some time to it, and so priority really has
no meaning here.

comment:6 by fingolfin, 15 years ago

Summary: MI1 FM-Towns: No text on mapsFM-TOWNS MI1: No text on maps

comment:7 by Kirben, 14 years ago

What is the status of this item?

comment:8 by fingolfin, 13 years ago

Status is unknown but likely unchanged. As it is, we don't even have an
independent verification of the bug.

comment:9 by SF/typhon666, 13 years ago

The bug is still there in 0.9.0 stable.
Don't know about SVN, but since nobody wrote anything in
here I guess it's also still in this version.

comment:10 by fingolfin, 13 years ago

Summary: FM-TOWNS MI1: No text on mapsMI FM-TOWNS: No text on maps

comment:11 by bluegr, 13 years ago

I got this game too and I made a dump of the scripts for that scene

The interesting ones are entry-63.dmp (the dancing lessons map) and entry-84.dmp (the cooking map) but I can submit all the relevant ones for that room. Would they be useful to debug this glitch?

comment:12 by bluegr, 13 years ago

Forgot to add that I also get this glitch in the FM-TOWNS version
The PC version works fine, though

comment:13 by bluegr, 13 years ago

Not sure if this helps, but here goes:
If I force the platform to "PC" and open the cooking map, it's still the same: no text is shown
IF I open the dancing lessons map when the platform is set to "PC", ScummVM crashes with the error:
"Unknown screen effect, 12!"

comment:14 by fingolfin, 13 years ago

The FM-TOWNS version draws text on some kind of overlay. This causes this bug and many other FM-TOWNS bugs, as we currently don't implement that feature.

comment:15 by athrxx, 9 years ago

Owner: set to athrxx
Status: newpending

comment:16 by athrxx, 9 years ago

This should be fixed now.

Pleae test again with latest SVN. Be sure to use a build with Hi-Color support (USE_RGB_COLOR). Using old savegames may lead to palette glitches. It would be appreciated if you could play through your Scumm Fm-Towns games again right from the beginning and report any bugs you find.

I set this item to pending.

Florian

comment:17 by athrxx, 9 years ago

Resolution: worksforme

comment:18 by athrxx, 9 years ago

Resolution: worksformefixed

comment:19 by SF/sf-robot, 9 years ago

This Tracker item was closed automatically by the system. It was
previously set to a Pending status, and the original submitter
did not respond within 14 days (the time period specified by
the administrator of this Tracker).

comment:20 by SF/sf-robot, 9 years ago

Status: pendingclosed
Note: See TracTickets for help on using tickets.