Opened 15 years ago

Closed 15 years ago

#1787 closed defect (fixed)

MANIAC: v1 intro glitches

Reported by: eriktorbjorn Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

Maniac Mansion, English v1 version
Latest ScummVM CVS snapshot

I just noticed several glitches in the Maniac Mansion
intro. The first happens during the character
selection, where a selected character's portrait is
mostly black.

Probably related, when the meteorite hits the ground,
and when the lights go on in the building, these are
drawn as black squares.

See attached screenshots.

Ticket imported from: #1035291. Ticket imported from: bugs/1787.

Attachments (2)

maniac1.png (1.7 KB) - added by eriktorbjorn 15 years ago.
Character selection screen
maniac2.png (929 bytes) - added by eriktorbjorn 15 years ago.
Early during the intro

Download all attachments as: .zip

Change History (5)

Changed 15 years ago by eriktorbjorn

Attachment: maniac1.png added

Character selection screen

Changed 15 years ago by eriktorbjorn

Attachment: maniac2.png added

Early during the intro

comment:1 Changed 15 years ago by eriktorbjorn

I forgot to mention that I haven't yet taken the time to
look at the actual gameplay. I just happened to notice this
in passing.

comment:2 Changed 15 years ago by Kirben

Owner: set to Kirben
Resolution: fixed
Status: newclosed

comment:3 Changed 15 years ago by Kirben

This was caused by my recent attempt to fix drawBitmap()
problems of reading too far in DOTT, reverted.

Note: See TracTickets for help on using tickets.