Opened 15 years ago

Closed 15 years ago

#1744 closed defect (fixed)

DIG: Crash during intro

Reported by: SF/leerqbasic Owned by: aquadran
Priority: blocker Component: Engine: SCUMM
Keywords: Cc:
Game: The Dig

Description

Using the win32 daily build on WinXP:
ScummVM 0.7.0CVS (Aug 26 2004 23:18:25)
Features compiled in: Vorbis FLAC MP3 zLib MPEG2

The Dig sometimes crashes after the video sequence with
the following error, this happens when someone is
trying to speak:

Assertion failed: skip + output_size <=
(int)sizeof(_compOutput), file
scumm/imuse_digi/dimuse_bndmgr.cpp, line 247

As of now I cannot simply reproduce the bug or create a
savegame as it seems to be quite random.

Ticket imported from: #1017220. Ticket imported from: bugs/1744.

Change History (8)

comment:1 by fingolfin, 15 years ago

I added that assert some time ago when I run into a crash in right that
spot -- but I never could reproduce the problem afterwards, so I thought
it was just caused by the other bug I was actually tracking down :-).

comment:2 by fingolfin, 15 years ago

Owner: set to aquadran

comment:3 by Kirben, 15 years ago

Priority: normalblocker

comment:4 by Kirben, 15 years ago

That assert often occurs in the Dig and COMI, making them
unplayable at the moment.

comment:5 by fingolfin, 15 years ago

aquadran, did you look at this already? This should be a top priority, as
it's a crash... before I added that assert, we overwrote memory, so
something is wrong here..

comment:6 by aquadran, 15 years ago

not yet, but i'll look into

comment:7 by SF/leerqbasic, 15 years ago

After the dimuse_bndmgr.cpp changes I tested it again, and
now it crashes with the following message:

skip: 1, output_size: 8192, _outputSize: 8192
skip: 1, output_size: 8192, _outputSize: 8192!
Fatal signal: Segmentation Fault (SDL Parachute Deployed)

So appearantly memory is still overwritten. Is bug #1022629
a duplicate of this?

comment:8 by aquadran, 15 years ago

Resolution: fixed
Status: newclosed
Note: See TracTickets for help on using tickets.