Opened 16 years ago

Closed 16 years ago

#1702 closed defect (fixed)

FT: Crash at junkyard

Reported by: SF/jurassicfrog Owned by: fingolfin
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

Full Throttle - CD english Get the same "(28: 2013: 0x9342): Invalid actor 25924 in o6_getActorScale" using the 0.6.1 release on OSX 10.3.

Savegame is in the junkyard - just go right and it'll drop you to a shell with the above error.

I'd give you more info if I could... can a .app be executed from the terminal to accept arguments like -d9?

Ticket imported from: #1003717. Ticket imported from: bugs/1702.

Attachments (1)

ft.s03 (8.9 KB ) - added by SF/jurassicfrog 16 years ago.
English savegame - in junkyard

Download all attachments as: .zip

Change History (12)

by SF/jurassicfrog, 16 years ago

Attachment: ft.s03 added

English savegame - in junkyard

comment:1 by SF/jurassicfrog, 16 years ago

Summary: English savegame-same as [918280]FT:Crash at junkyardFT: English savegame-same as [918280]FT:Crash at junkyard

comment:2 by fingolfin, 16 years ago

You can use -d9. Go to the terminal, then change to the directory ScummVM.app is in. Then start the executable, which is *inside* the .app package :

ScummVM.app/Contents/MacOS/scummvm -d9

comment:3 by fingolfin, 16 years ago

It appears the invalid actor ID comes from some invalid value being stored in one of the arrays array-417 till array-420

comment:4 by fingolfin, 16 years ago

Owner: set to fingolfin
Resolution: fixed
Status: newclosed

comment:5 by fingolfin, 16 years ago

Fixed in CVS. Turned out that a workaround I put into CVS for similiar (array) issues was not having any effect due to two stupid mistakes of mine <sigh>.

comment:6 by SF/jurassicfrog, 16 years ago

Tried with 0.7.0CVS checked out this morning. Appears to still be doing the same thing. Using same save file.

Here's the error w/out -d9: [WOPR:~/cvsroot/scummvm] nate% ./scummvm Looking for ft Trying to start game 'Full Throttle' (28:2013:0x9342): Invalid actor 77 in o6_getActorScale

Below is what I assume the relevant chunk of output is that I get from a -d9 ... appears the address is the same, the actor #'s diff tho.

readvar(16384) writeVar(16384, 1) Script 2014, offset 0x98fd: [73] o6_jump() Script 2014, offset 0x9832: [3] o6_pushWordVar() readvar(16384) Script 2014, offset 0x9835: [1] o6_pushWord() Script 2014, offset 0x9838: [1] o6_pushWord() Script 2014, offset 0x983b: [15] o6_sub() Script 2014, offset 0x983c: [12] o6_le() Script 2014, offset 0x983d: [5D] o6_ifNot() Script 2014, offset 0x9840: [1] o6_pushWord() Script 2014, offset 0x9843: [43] o6_writeWordVar() writeVar(16385, 0) Script 2014, offset 0x9846: [3] o6_pushWordVar() readvar(16385) Script 2014, offset 0x9849: [1] o6_pushWord() Script 2014, offset 0x984c: [1] o6_pushWord() Script 2014, offset 0x984f: [15] o6_sub() Script 2014, offset 0x9850: [12] o6_le() Script 2014, offset 0x9851: [5D] o6_ifNot() Script 2014, offset 0x9854: [3] o6_pushWordVar() readvar(16384) Script 2014, offset 0x9857: [3] o6_pushWordVar() readvar(16385) Script 2014, offset 0x985a: [B] o6_wordArrayIndexedRead() readvar(417) getResourceAddress(String,19) == 0x2578074 Script 2014, offset 0x985d: [5D] o6_ifNot() Script 2014, offset 0x9860: [1] o6_pushWord() Script 2014, offset 0x9863: [1] o6_pushWord() Script 2014, offset 0x9866: [3] o6_pushWordVar() readvar(16384) Script 2014, offset 0x9869: [3] o6_pushWordVar() readvar(16385) Script 2014, offset 0x986c: [B] o6_wordArrayIndexedRead() readvar(417) getResourceAddress(String,19) == 0x2578074 Script 2014, offset 0x986f: [3] o6_pushWordVar() readvar(16384) Script 2014, offset 0x9872: [3] o6_pushWordVar() readvar(16385) Script 2014, offset 0x9875: [1] o6_pushWord() Script 2014, offset 0x9878: [1] o6_pushWord() Script 2014, offset 0x987b: [5E] o6_startScript() runScript(2013) from 2014-28 getResourceAddress(Room,28) == 0x63cb004 Script 2013, offset 0x933f: [3] o6_pushWordVar() readvar(16384) Script 2013, offset 0x9342: [AA] o6_getActorScaleX() (28:2013:0x9342): Invalid actor 25441 in o6_getActorScale Locking mutex IMuseDigital::callback() Unlocking mutex IMuseDigital::callback() ****** where it dumps to the scumm command line

comment:7 by SF/jurassicfrog, 16 years ago

Resolution: fixed
Status: closednew

comment:8 by fingolfin, 16 years ago

Using your savegame, I exit to the right. Works flawlessly. I see a bunch of broken cars, and the guard dog running around.

Anon CVS tends to lag behind the developers CVS. However, I just checked, anon CVS already has the fix for this issue (at least now it has).

Since I can't reproduce the problem anymore, there is nothing I could do about it...

comment:9 by fingolfin, 16 years ago

Resolution: worksforme
Status: newpending
Summary: FT: English savegame-same as [918280]FT:Crash at junkyardFT: Crash at junkyard

comment:10 by SF/jurassicfrog, 16 years ago

Resolution: worksformefixed
Status: pendingclosed

comment:11 by SF/jurassicfrog, 16 years ago

looks like the commit just wasn't in the anon cvs yet. works great now! Thanks!

Note: See TracTickets for help on using tickets.