Opened 16 years ago

Closed 16 years ago

Last modified 2 years ago

#1703 closed defect (fixed)

IMUSE+DEBUG: 'room' debug command + imuse digital = lockup

Reported by: fingolfin Owned by: aquadran
Priority: low Component: Engine: SCUMM
Keywords: Cc:
Game:

Description

When using the "room" command in the debugger in any iMuseDigital game (dig, ft, comi), you get a dead lock. So the "room" command is right now totally unusable in these games.

The problem is caused by stopAllSounds, which hangs in an endless loop. It waits for the callback timer to stop&remove any remaining sounds; but at this point, the callback timer is paused! So of course it hangs in an endless loop...

Might want to add a check in stopAllSounds, and if the game is paused, just directly remove all the sounds.

Ticket imported from: #1003849. Ticket imported from: bugs/1703.

Change History (4)

comment:1 by aquadran, 16 years ago

what is current status after fix ?

comment:2 by fingolfin, 16 years ago

I wasn't aware that there was a "fix" ?! Must have missed that commit...

In any case, this is still occuring.

comment:3 by aquadran, 16 years ago

Resolution: fixed
Status: newclosed

comment:4 by digitall, 2 years ago

Component: --Unset--Engine: SCUMM
Note: See TracTickets for help on using tickets.