Opened 16 years ago

Closed 16 years ago

#1679 closed defect (fixed)

CMI: Regressions after recent animation fix

Reported by: eriktorbjorn Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Monkey Island 3

Description

The recent fix for Wally's hook / floating head (thank you thank you thank you!) seems to have caused a few regressions with old savegames: the subtitles are gone, characters are not moving their mouths and at least with one older savegame spoken sentences were being cut off.

So far, it does seem to work when playing from the beginning of the game, so it's not a major regression. It's something we're likely to get bug reports about, though...

Ticket imported from: #992160. Ticket imported from: bugs/1679.

Attachments (2)

comi.s40 (50.0 KB ) - added by eriktorbjorn 16 years ago.
Recent savegame at Wally, crying
comi.s01 (51.5 KB ) - added by (none) 16 years ago.
Older savegame at the barber shop

Download all attachments as: .zip

Change History (10)

comment:1 by eriktorbjorn, 16 years ago

Owner: set to Kirben

comment:2 by Kirben, 16 years ago

Could you attach an old save game for an example ?

by eriktorbjorn, 16 years ago

Attachment: comi.s40 added

Recent savegame at Wally, crying

by (none), 16 years ago

Attachment: comi.s01 added

Older savegame at the barber shop

comment:3 by eriktorbjorn, 16 years ago

I've attached two savegames: one I made yesterday when testing my (rejected) fix for the animation glitch, and an older one (I don't remember when I made it) at the barber shop.

It's the latter that has cut off speech.

comment:4 by fingolfin, 16 years ago

Looking at those changes, the regression isn't a big surprise: things are now setup and used in a somewhat different way; but of course old savegames will still follow the old scheme.

A potential workaround would be to up the savegame version; then add "conversion" code to the load code which tries to setup VAR_HAVE_MSG in V8 games, for example...

comment:5 by Kirben, 16 years ago

I'm not sure what exactly is going wrong in those save games, anyone else want to try at conversion code ? Odd point is none of the save games I have show any problems, even though they range up to a year old.

comment:6 by Kirben, 16 years ago

It looked like the stopTalk() call in CHARSET_1() was cause of the speech cut offs and missing subtitles but I don't know why....

comment:7 by Kirben, 16 years ago

Resolution: fixed
Status: newclosed

comment:8 by Kirben, 16 years ago

The regressions were not related to animation fixes at all. The cause was adding support for VAR_DEFAULT_TALK_DELAY, since we never set it to default value before. I was looking in wrong places. I will bump save game version and commit fix.

Note: See TracTickets for help on using tickets.