Opened 16 years ago

Closed 16 years ago

#1678 closed defect (invalid)

Choppy Audio on Maniac Mansion Enhanced

Reported by: SF/ltngstlkr Owned by: Kirben
Priority: normal Component: Engine: SCUMM
Keywords: Cc:
Game: Maniac Mansion

Description

Hello. I'm running ScummVM v0.6.0 on W2k SP4 and the audio is very choppy. It doesn't seem to be from the video processing hogging the CPU either because it does it even if I run it with normal graphics.

Thanks.

Ticket imported from: #991306. Ticket imported from: bugs/1678.

Change History (6)

comment:1 by Kirben, 16 years ago

Could be related to sound card drivers, does issue occur in other games under ScummVM too ?

Open a command prompt, type: set SDL_AUDIODRIVER=waveout Then start scummvm from that command prompt, ie. scummvm maniac

And see if that helps at all.

comment:2 by SF/ltngstlkr, 16 years ago

Yes, as a matter of fact I just discovered that it does the same thing in Monkey Island. It's a good VM though otherwise, quite impressive. I'll try that environment variable too.

Thanks.

comment:3 by SF/ltngstlkr, 16 years ago

Okay that environment variable definitely worked. Audio playback is perfect now.

Thanks!

The Lightning Stalker

comment:4 by SF/ltngstlkr, 16 years ago

I suppose I should ask what you think is causing this issue?
Probably something to do with my audio drivers?

comment:5 by Kirben, 16 years ago

Owner: set to Kirben
Resolution: invalid
Status: newclosed

comment:6 by Kirben, 16 years ago

Yes, buggy sound card drivers are the cause of the choppy sound. SDL uses DirectSound for sound output by default and changing that environment variable uses the older multimedia interface for sound output. I suggest setting that environment variable permanently on your system, via Advanced tab of System control panel. Closing bug report, since it isn't a ScummVM issue.

Note: See TracTickets for help on using tickets.