Opened 15 years ago

Closed 15 years ago

#1661 closed defect

BS2fr: Savegames are corrupted

Reported by: SF/seyb Owned by: eriktorbjorn
Priority: normal Component: Engine: Sword2
Keywords: Cc:
Game: Broken Sword 2

Description

Broken Sword 2 - French w/ French Speaking - PC ; Platform =
OSX 10.3.4

Hi !

With at least the 3 latest CVS ScummVM OSX (20040606, 20040522
and one more + 0.6.0 stable), it's impossible
to load a saved game.
To reproduce this, start a new game and when you get control of
Georges, just save a game. Quit and relaunch BS2 and try to load
your saved game, there should be a message saying something
like : "Impossible to load this game, it is corrupted".

I guess such a big bug won't occur with the English Version (it
would be known for a while if it was so), but it would be great if
we could find out why this bug is occuring... At least for the French
speaking community. ;-)

Thanks a lot for your wonderful work in here. :-)

Ticket imported from: #972123. Ticket imported from: bugs/1661.

Change History (10)

comment:1 by SF/seyb, 15 years ago

Summary: [BS2fr] Savegames are corruptedBS2fr: Savegames are corrupted

comment:2 by eriktorbjorn, 15 years ago

Could you try with the latest version? I fixed a bug like
that in the CVS version recently. (I accidentally broke some
code when all I was trying to do was cleaning it up a bit,
and it took several days before I even noticed.)

Though that bug shouldn't affect 0.6.0... well, not unless
you try to load a corrupted savegame into it, of course. But
savegames created with 0.6.0 ought to be ok.

comment:3 by eriktorbjorn, 15 years ago

Owner: set to eriktorbjorn

comment:4 by eriktorbjorn, 15 years ago

Just to clarify, any corrupted savegame is beyond salvation.
The fix I made just ensures - I hope - that that new
savegames will not be corrupted.

comment:5 by SF/seyb, 15 years ago

Ok, I tried with the 0.6.0 stable and you were right, it works with a fresh
saved game. Thanks for pointing that. :-)
Now I'm trying to find out how CVS works to tell you how it is going on
with the latest version (there's no binaries yet for OSX). ;-)

comment:6 by SF/khalek, 15 years ago

There is a new OS X snapshot up if you haven't already
managed to build your own.

comment:7 by SF/seyb, 15 years ago

I tried the latest OSX Snapshot (couldn't build mine. I tried hard ! ;-) ).
My 0.6.0 stable saved game works like a charm with this new version,
thanks a lot. :-)

comment:8 by eriktorbjorn, 15 years ago

That's not surprising since the savegame format never
changed -- at least not deliberately. The big question is,
can the snapshot version create new savegames that can be
loaded by any version at all? :-)

comment:9 by eriktorbjorn, 15 years ago

So what is the status of this? Does the new snapshot create
usable savegames for you, or doesn't it?

comment:10 by eriktorbjorn, 15 years ago

Status: newclosed
Note: See TracTickets for help on using tickets.