Opened 15 years ago

Closed 14 years ago

Last modified 14 years ago

#1592 closed defect

FT: Going between Mineroad and Highway.

Reported by: SF/xake Owned by:
Priority: high Component: Engine: SCUMM
Keywords: Cc:
Game: Full Throttle

Description

If I while I'm on the mineroad escapes (i.e. press
button 4 on the gamepad) the game drops me at a place
were I can save (like the broken bridge or the mink
farm). If I then go back onto the road the graphics is
all messed up, and when I try to enter the Mineroad it
gives me the same filmclip as if I were leaving the
Mineroad and next thing I am on the highway and
everything is just like it should be.

And another thing: If I try to save during a filmclip
then when the game has been saved it has skipped the
filmclip. And loading the saved game places me directly
after the clip. Really annoying if the clips got a
point you don't want to miss, and are afraid that the
game will go crazy during it.

Ticket imported from: #933631. Ticket imported from: bugs/1592.

Attachments (2)

valgrind.txt (8.0 KB) - added by Kirben 15 years ago.
Valgrind log
ft.txt (16.1 KB) - added by Kirben 14 years ago.
Valgrind log

Download all attachments as: .zip

Change History (35)

comment:1 Changed 15 years ago by fingolfin

Please always file one separate bug report for each bug you encounter.

comment:2 Changed 15 years ago by fingolfin

To process your bug report appropriately, we need you to
provide the following additional information:

* ScummVM version (PLEASE test the latest CVS/Daily build)
* Bug details, including instructions on reproducing it
* Language of game (English, German, ...)
* Version of game (talkie, floppy, ...)
* Platform and Compiler (Win32, Linux, MacOS, ...)
* Attach a save game if possible
* If this bug only occurred recently, please note the last
version without the bug, and the first version including
the bug. That way we can fix it quicker by looking at the
changes made.

This should only take you a little time but will make it much easier for
us to process your bug report in a way that satisfies both you and us.

Thank you for your support!

comment:3 Changed 15 years ago by SF/xake

For the filmie-thing:

* Using 0.6.0
* The way to reproduce it is described in the initial comment.
...and it happened everytime I try.
* English
* CD, talkie
* Linux, gcc 3.3.2
* I have not tested this with any other version yet, but I
will test with the daily as soon as I have time.

comment:4 Changed 15 years ago by sev-

As of second "bug", original version didn't allow you to
save at those places either.

comment:5 Changed 15 years ago by SF/xake

Sev: not as much as it is not possible to save there as it
skips the filmclip nomatterwhat.

comment:6 Changed 15 years ago by SF/dgasaway

I've also experienced this bug. Came here to report it, in
fact.

Periodically, if I hit ESC to skip a fight on the mine road,
I'll get kicked to the range or the bridge area. If I hit
the highway again, the graphics are corrupted and the exit
signs show HWY 9. Sure enough, if I take an exit, I'm on
the highway, and the graphics are normal again.

I've reproduced the problem in release v0.6.0 and the Jun 20
daily build. Full talkie English CD version. Running on
Windows XP Home.

Thanks.

comment:7 Changed 15 years ago by fingolfin

Owner: set to sev-

comment:8 Changed 15 years ago by fingolfin

Sounds like an INSANE bug?

comment:9 Changed 15 years ago by sev-

I cannot reproduce bug with messed graphics. Apparently it
is Windows-specific.

comment:10 Changed 15 years ago by SF/manny182

same happened to me, while pressing esc.

version in use: 0.6.1b

comment:11 Changed 15 years ago by SF/xake

I had the problem in Linux, so it is not windows-specific.

I have not had the time to produce a good bugreport and it
does not look like I will have with school and all.

But could someone please write them a full bugreport
including version of scummvm, OS and stuff like that
including a savegame while on the mineroad so they can
easily reproduce?
That will make the problem solved, not just mention "Me too"
on a list.
Or if someone just post a savegame while on the mineroad I
could do the rest - Its playing til I am at that place I
don't have time for......

comment:12 Changed 15 years ago by fingolfin

Priority: normalhigh

comment:13 Changed 15 years ago by sev-

Does this bug still occur?

Any detailed instructions on how to reproduce this? I.e.
savefiles at like.

comment:14 Changed 15 years ago by SF/dgasaway

I just testing with verion 0.6.1b on Windows, and I can
still get the bug. Reproducing it is simple. Just ride the
mine road, and abort the fight sequences. Note: you have to
actually let the fight start, but then hit ESC to get out.
You can escape as soon it changes to the fight view. The
important thing to remember is, it may take a few times
before the bug shows itself. In testing with 0.6.1b just
now, I had to abort eight fights before the corruption happened.

Now, I can provide a save game *near* the mine road (e.g.,
at the broken bridge) - it's, of course, not possible to
save the game *on* the mine road. It is possible to make a
save game after the bug warps you to the bridge or the
ranch, but loading such a save game shows no wierd behavior.

Although, I've found if you load an after-warp save game in
the same play session, you'll get some other ... interesting
results. Such as, you'll be unable to see Ben or the bike
on the freeway, no steering, nothing - all you can do is
ride it out to the next area. If a developer thinks there
might be some interesting data in one of these save games
(even though it seems to work okay after quitting ScummVM),
let me know.

Now, if I could only figure out how to attach a file.
Ordinary folk to have permissions to add attachments? Oh
well, you can download a save game at the bridge area here ...

http://dave.gasaway.org/misc/ft.zip

comment:15 Changed 15 years ago by SF/dgasaway

I've also uploaded a screenshot:

http://dave.gasaway.org/misc/ft-highway.png

comment:16 Changed 15 years ago by SF/xake

Thanks dgasaway for the savegame.
However it seems like I no longe can reproduce the behavior
in Linux ScummVM 0.6.1b.
This is becouse when I press ESC to skip a fight it only
skips the fight and places me on the mineroad again. There
seems for me to be no way to press ESC and ending at the
farm or broken bridge as long as I am on the mineroad
anymore. I do not know if this is the correct behavior, but
it seems to fix the problems I had encountered before.

comment:17 Changed 15 years ago by SF/dgasaway

That is the correct behavior, xake. And I, also, could not
reproduce it on Linux (forgot to mention that in my last post).

comment:18 Changed 15 years ago by SF/deonarin

OS: Windows 2000 Pro
ScummVM ver: 0.6.1b, also the Win32 daily for 10/9/04

You can easily reproduce this behavior by:

1. Go to the mine road
2. Press ESC repeatedly (might take 10 times or so, I think
it might be timing related: you might have to press it
twice quickly)

Behavior: Instead of skipping around the mine road, you
will end up at the bridge or the ranch. Trying to go back
to the highway leads to a scene with screwed up (inverted?)
graphics. The signs on this road are for the highway.
Taking one of the exits takes you back to the highway. If
you hit ESC while on the screwed up highway, it takes you
back to the mine road.

I've not seen the other behaviors mentioned (by dgasaway)
although I have noticed something else. When my game
bugged, I was no longer able to find any of the bikers with
the goggles (cavefish?). Also, every time I fought the
biker with the ball-and-chain, I got the ball and chain,
although I already had it. (ie, I saw the scene where he
holds the ball and chain every time)

Once I shut down my game and re-loaded it, these other
behaviors went away.

comment:19 Changed 15 years ago by sev-

I can't reproduce it on my system, but it was repeatedly
confirmed on Win32. I deassign myself from it. Maybe Kirben
or aquadran could do it?

comment:20 Changed 15 years ago by sev-

Owner: sev- deleted

comment:21 Changed 15 years ago by Kirben

I noticed valgrind reported several errors recently, when I
was escing madly on mine road in Full Throttle. Using latest
ScummVM cvs.

Changed 15 years ago by Kirben

Attachment: valgrind.txt added

Valgrind log

comment:22 Changed 14 years ago by fingolfin

See also bug #894249 and #1087234.

comment:23 Changed 14 years ago by sev-

My bad I didn't report it earlier. I tried to fix it some
time ago and spend bunch of time on windows machine. There
is really memory overwrite, but it is so bad that it occurs
on innocent ours File class. I.e. some code badly overwrites
big chunk of heap. Judging from valgrind and by my own
suspection it is Smush audio.

comment:24 Changed 14 years ago by Kirben

I just tried mine road areas again in Full Throttle (Using boot
parameter 550), and unfortunately still get the odd glitch:
Ben disappeared on main road, although without the usual
palette change.
I was suddenly been chased on main road, even though I had
not gone near mink ranch.

comment:25 Changed 14 years ago by fingolfin

The valgrind log you attached is quite useful, though. I added a mutex,
which should avoid at least one race between INSANE and SMUSH
(seekSan sometimes was deleting a file/chunk object while it was still
being used by SMUSH).

It's possible that this or any of the other open FT/INSANE/SMUSH issues
may be helped by this -- or not...

Changed 14 years ago by Kirben

Attachment: ft.txt added

Valgrind log

comment:26 Changed 14 years ago by Kirben

Attached another valgrind log of current ScummVM cvs, in
case it is any help.

comment:27 Changed 14 years ago by fingolfin

That crash looks like _channels[i].stream was NULL, or had a random
value. I modified CVS to catch the NULL case, could you try again with
latest CVS? Thanks

comment:28 Changed 14 years ago by Kirben

No useful warnings under Valgrind with current ScummVM
CVS.

comment:29 Changed 14 years ago by fingolfin

Thanks Kirben. I assume the problem still occurs, though? I.e. messed up
graphics etc. as described in the first paragraph of this bug report? (Sorry
for the repeated question, I just want to make sure this fact is clearly
stated).

comment:30 Changed 14 years ago by Kirben

I have not been able to reproduce the issues recently, but
they always occured at random, so difficult to tell if it is fixed
for sure.

Could people who reported issues please try the current
ScummVM daily snapshot and report their experiences too ?

comment:31 Changed 14 years ago by fingolfin

Status: newclosed

comment:32 Changed 14 years ago by fingolfin

Setting to pending. We have no reports on this occuring with latest CVS,
so unless one of you speaks up, this item will auto-close in 14 days.

I still hope that one of the people who were able to easily reproduce this
(e.g. deonarin) can re-test this and give us a concrete feedback (works /
still buggy).

comment:33 Changed 14 years ago by SF/dgasaway

Sorry I've taken so long, but I just tested with 0.8.0, and
could not reproduce. Congrats, and thand you so much.

Note: See TracTickets for help on using tickets.