Opened 15 years ago

Closed 15 years ago

Last modified 15 years ago

#1565 closed defect

FOTAQ: crash on simpad (hpc2000)

Reported by: SF/adicks Owned by: SF/arisme
Priority: normal Component: Engine: Queen
Keywords: Cc:
Game: Flight of the Amazon Queen

Description

I run the handheldpc version 0.6.0 of scummvm on my
siemens simpad sl4 (hpc2000). As soon as I talk to the
bellboy right at the beginning of FOTAQ (Floppy version
from scummvm site), the game hangs with a message
like "unallowed action" or something. I put the memory
slider to appr. 56MB program memory, so lack of
memory should not be the problem.

Ticket imported from: #923570. Ticket imported from: bugs/1565.

Change History (21)

comment:1 Changed 15 years ago by fingolfin

Dunno who from the FOTAQ team is responsible (cyx? joostp? twogood?),
but I hope if cyx doesn't feel responsible, maybe he can decide who else
could look into this :-)

comment:2 Changed 15 years ago by fingolfin

Owner: set to cyxx
Summary: crash on simpad (hpc2000)FOTAQ: crash on simpad (hpc2000)

comment:3 Changed 15 years ago by cyxx

Owner: changed from cyxx to SF/arisme

comment:4 Changed 15 years ago by cyxx

This doesn't seem to be related to the engine itself but more
to the backend (Windows CE ?). Using the SDL one, there
isn't any problems when talking to the bellboy.
Recently, arisme committed some code regarding FOTAQ
crashes, so maybe the issue described here is already fixed...
So, re-assigning it to arisme :)

comment:5 Changed 15 years ago by SF/arisme

Please retry with
http://arisme.free.fr/PocketScumm/binaries/unstable/scummv
m-0.6.x-branch-03-29-04-1-HandheldPC_ARM.zip to see if
the problem was fixed.

comment:6 Changed 15 years ago by fingolfin

Status: newpending

comment:7 Changed 15 years ago by fingolfin

Awaiting response by bug submitter...

comment:8 Changed 15 years ago by SF/adicks

Sorry, it is still crashing with "Severe application error".
Exception 0x80000002
Address 0x0012e688

comment:9 Changed 15 years ago by SF/adicks

Status: pendingnew

comment:10 Changed 15 years ago by SF/arisme

0x80000002 is a datatype misalignment, and I'm pretty sure
there is no misalignment at this point anymore, or it would
crash on all ARMs at least. It works fine on my PDA, and has
been reported to work fine on other ARM devices. I'll recheck,
but I don't have much hope to fix this problem.

comment:11 Changed 15 years ago by fingolfin

Arisme, so did you actually try the scene adicks describes?

If not, maybe somebody could provide a savegame for arisme ?

comment:12 Changed 15 years ago by SF/ender

What is the status of this item?

comment:13 Changed 15 years ago by fingolfin

Status: newclosed

comment:14 Changed 15 years ago by SF/arisme

Never been able to reproduce it ... was fixed by the last
month build on other ARM devices ...

comment:15 Changed 15 years ago by SF/stephp

I have the same problem on my Jornada 720 - downloaded the
latest branch for HPC ARM, 03-29-04-1, with the same result:

Talk to Bellboy -> "Hello" -> illegal operation
exception 0x80000002
address 0012e688

(I believe I have the CD freeware version - about 22,7Megs in
size)

I use a German OS - perhaps that's related?

comment:16 Changed 15 years ago by SF/arisme

I'll see if the HPC build runs on my device to recheck. Then I
can think of 2 options 1) my build was bad (don't think so
because I double checked it) 2) the HPC optimizer has
differents bugs and in that case I'll have to think of a new
workaround, or just disable it for FOTAQ on HPCs.

comment:17 Changed 15 years ago by SF/stephp

Can we re-open this?
The crash still occurs the same way after installing version 0.
6.1b. Same place in the game, same error message

comment:18 Changed 15 years ago by cyxx

I just rewrote some code in the queen engine that wasn't
really alignment safe (mostly in the dialogue choices handling).

I am not sure if that's related with the described issue ; but,
arisme can you provide a build using the latest cvs, so that
the bug submitter test again if the problem is still here ?

comment:19 Changed 15 years ago by cyxx

So, has this been tested again ?

comment:20 Changed 15 years ago by SF/stephp

I have only been able to test with the stable version - unable
to find a beta/daily snapshot that will run on my Jornada720 -
I don't see any listed :-(

comment:21 Changed 15 years ago by SF/arisme

Yes, sorry, I only build the betas for PocketPC ARM because
the build process is not automated, but I'll make one for
you when I get time to review a few things (~ after the 15th
of September)

Note: See TracTickets for help on using tickets.